LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 12-22-2003, 12:00 PM   #1
codedv
Member
 
Registered: Nov 2003
Location: Slough, UK
Distribution: Debian
Posts: 146

Rep: Reputation: 15
No eth ????


I have just installed Debian. Never before used it. Only to find that there is no network device files. i.e eth0.

Do ethernet devices go by another name in Debian or is something wrong?
 
Old 12-22-2003, 12:34 PM   #2
llamakc
Member
 
Registered: Nov 2003
Distribution: Debian & Ubuntu
Posts: 402

Rep: Reputation: 31
They go by the ethX naming. Did you configure the network during install, or install straight from cd? If the latter, edit the file /etc/network/interfaces then bring the device up with ifup (or dhclient). Is the card detected by lspci -v?
 
Old 12-22-2003, 06:00 PM   #3
codedv
Member
 
Registered: Nov 2003
Location: Slough, UK
Distribution: Debian
Posts: 146

Original Poster
Rep: Reputation: 15
I have done the following:
  1. Run lspci -v: It said the following.
    Code:
    00:13.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 10/100 Ethernet (rev 02)
        Subsytem: Silicon Integrated Systems [SiS] SiS900 10/100 Ethernet Adapter
        Flags: bus master, medium devsel, latency 64, IRQ 12
        I/O ports at e400 [size=256]
        Memory ay e8000000 (32 bit, non-prefetchable) [size=4k]
        Expansion ROM at e7000000 [disabled] [size=128k]
        Capabilities: [40] Power MAnagement version 2
    I'll assume that means that it can see it.
  2. I checked the /dev/ directory. It contains no ethXX device files.
  3. I edited the interfaces file to the following:
    Code:
    auto lo, eth0
    
    iface lo inet loopback
    iface eth0 inet dhcp
    For obvious resons it did not work, as there is no device file called eth0.
I did install straight from the CD. I do not understand why installing the server distro of debian, network support isn't included by default.
 
Old 12-23-2003, 01:27 AM   #4
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 63
Quote:
Originally posted by codedv
I have done the following:
  1. Run lspci -v: It said the following.
    Code:
    00:13.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 10/100 Ethernet (rev 02)
        Subsytem: Silicon Integrated Systems [SiS] SiS900 10/100 Ethernet Adapter
        Flags: bus master, medium devsel, latency 64, IRQ 12
        I/O ports at e400 [size=256]
        Memory ay e8000000 (32 bit, non-prefetchable) [size=4k]
        Expansion ROM at e7000000 [disabled] [size=128k]
        Capabilities: [40] Power MAnagement version 2
    I'll assume that means that it can see it.
  2. I checked the /dev/ directory. It contains no ethXX device files.
  3. I edited the interfaces file to the following:
    Code:
    auto lo, eth0
    
    iface lo inet loopback
    iface eth0 inet dhcp
    For obvious resons it did not work, as there is no device file called eth0.
I did install straight from the CD. I do not understand why installing the server distro of debian, network support isn't included by default.
Networking support is included by default you are however expected to configure the system to load the proper modules if it is not already built into the kernel. Try this as root in a console or console window modprobe sis900 if the module loads correctly then /etc/init.d/networking restart this will restart the networking and now that the module was loaded it should be able to get the DHCP lease from whatever server you have that gives you your IP. You may want to check in your /etc/resolv.conf and make sure that you have at least one nameserver in there or you will not be able to resolve internet addresses. To make the change permanent edit the file /etc/modules as root and put the sis900 module name on a line by itself and it will be loaded at boot. BTW what does uname -a say you are running for a kernel if this does not work.
 
Old 12-23-2003, 08:18 AM   #5
codedv
Member
 
Registered: Nov 2003
Location: Slough, UK
Distribution: Debian
Posts: 146

Original Poster
Rep: Reputation: 15
On using modprobe it said it was unable to locate the module. I'm assuming this means I need to obtain the source for the Sis900 driver and compile it into the kernel?
 
Old 12-23-2003, 02:15 PM   #6
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 63
Quote:
Originally posted by codedv
On using modprobe it said it was unable to locate the module. I'm assuming this means I need to obtain the source for the Sis900 driver and compile it into the kernel?
Yes if it is available for the 2.2 kernel that you must be running in my firewall's old kernel config which was using the 2.4.18-bf2.4 kernel which would have been installed if you used that option the module is compiled into the kernel so you should be able to use your network card if you are running that kernel so what does uname -a in a console window tell you?
Code:
stephen@SleepyTux:~$ grep SIS /boot/config-2.4.18-bf2.4
CONFIG_BLK_DEV_SIS5513=y
CONFIG_SIS900=y
CONFIG_TMSISA=m
CONFIG_AGP_SIS=y
You should be able to install a 2.4.18 kernel from the CD(s) that you have and get the required support for the card.
 
Old 12-24-2003, 04:59 AM   #7
codedv
Member
 
Registered: Nov 2003
Location: Slough, UK
Distribution: Debian
Posts: 146

Original Poster
Rep: Reputation: 15
Thanks for the all the help. I have compiled the latest kernel 2.4.23 and made sure I included the SiS900 support. After a bit of tweaking I have got it working - for the moment though I have had to set the interfaces file up as follows:
Code:
auto lo eth0 eth0:1

iface lo inet loopback

iface eth0 inet static
  netmask 255.255.255.0
  address 192.168.0.2

iface eth0:1 inet static
  netmask 255.255.255.0
  address 192.168.0.20
Unfortunatly using the dhcp option causes them not to work - the dhcp server does not give them ip addresses.

Again, thanks for all the help. Debian is very different from RedHat :s so I might need some more guidance.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wlan instead of eth jimjamjahaa Linux - Wireless Networking 2 06-12-2005 02:36 AM
Upgrade to 2.6.x and eth goes down sara_W Linux - Networking 7 09-25-2004 08:37 AM
Eth problem in RH 7.3 mef Red Hat 7 09-11-2003 01:24 AM
Eth fails, but why? DiZASTiX Linux - Networking 4 05-03-2003 01:18 PM
eth(x) confuses me Cbomb Linux - Networking 3 05-16-2001 10:14 PM


All times are GMT -5. The time now is 08:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration