Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Debian This forum is for the discussion of Debian Linux.


  Search this Thread
Old 07-26-2007, 12:30 AM   #1
LQ Newbie
Registered: Jul 2007
Posts: 4

Rep: Reputation: 0
nfs client does not mount server-shares automatically on boot


I am new to Debian; using etch.

I have installed nfs on server and client in a small home-network. NFS is functional manually but does not mount the shares automatically from /etc/fstab.

I have modified /etc/init.d/ to mount nfs by changing the 'nonfs' to 'nfs' in the starting lines shown below:

'mount_all_local() {
mount -a -t nonfs,nfs4,smbfs,cifs,ncp,ncpfs,coda,ocfs2,gfs \
-O no_netdev

While booting, the error ('failed' shown in red) is as under:

"Mounting local filesystems."
"mount on nfs Server failed. The Server is down"

But the server is very much up.

Extract from my /etc/fstab is as below: /mnt/rsp nfs soft,nfsvers=2 0 0 /mnt/shp nfs soft,nfsvers=2 0 0

After loging-in as a user I can mount nfs by just running command 'sudo mount -a' on the terminal.

I suspect that the script '' is executed before the network is up. And there is no link for starting this script in any of the '/etc/rc?.d' directories. So I cannot make out at what stage this script is executed. But it is executed during boot, for sure. I say this because after reversing the changes, there is no error but the nfs shares are not mounted automatically.

What more is needed here?

Any suggestions please?



Last edited by rsp; 07-26-2007 at 12:36 AM.
Old 07-27-2007, 12:15 PM   #2
Registered: Nov 2004
Location: Florida, USA
Distribution: Debian, Redhat
Posts: 383

Rep: Reputation: 31
/etc/init.d/ is called from /etc/rcS.d/ As the files in rcS.d I believe fire off before networking is setup in rc3.d (I believe... correct me if I am wrong), it is not surprising that NFS mounts fail at this time.

You may have to do a link in /etc/rc3.d to fire off again once networking has finished setting up.
Old 07-29-2007, 08:26 AM   #3
LQ Newbie
Registered: Jul 2007
Posts: 4

Original Poster
Rep: Reputation: 0
nfs client does not mount server-shares automatically on boot

Thanks for your response and putting me wise on /etc/rcS.d.

What was useful in solving this problem, was the following extract from /etc/rcS.d/README:

"The following sequence points are defined at this time:

* After the S40 scripts have executed, all local file systems are mounted
and networking is available. All device drivers have been initialized."

So I made the link in /etc/rcS.d/ as ''. That has solved the problem.

Now there is no need to make any more links to '/etc/init.d/' in any other run-level.

Thanks and Regards,


Last edited by rsp; 07-29-2007 at 08:28 AM.


at, automatically, boot, mount, nfs, shares

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
NFS server - client cannot mount remote file system mikemrh9 Linux - Networking 6 10-13-2006 12:05 AM
how to mount a nfs mount from linux client to AIX nfs server dennyqian AIX 8 09-22-2006 04:34 AM
automatically mount NFS shares turbo_acura Linux - Networking 1 10-28-2004 06:33 PM
NFS client loses shares tomanthony Linux - Networking 0 09-16-2004 12:33 PM
Automatically mount file shares? odious1 Linux - Newbie 1 07-03-2003 02:57 PM

All times are GMT -5. The time now is 10:19 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration