LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   nfs client does not mount server-shares automatically on boot (http://www.linuxquestions.org/questions/debian-26/nfs-client-does-not-mount-server-shares-automatically-on-boot-572318/)

rsp 07-25-2007 11:30 PM

nfs client does not mount server-shares automatically on boot
 
Hi,

I am new to Debian; using etch.

I have installed nfs on server and client in a small home-network. NFS is functional manually but does not mount the shares automatically from /etc/fstab.

I have modified /etc/init.d/mountall.sh to mount nfs by changing the 'nonfs' to 'nfs' in the starting lines shown below:

'mount_all_local() {
mount -a -t nonfs,nfs4,smbfs,cifs,ncp,ncpfs,coda,ocfs2,gfs \
-O no_netdev
}'

While booting, the error ('failed' shown in red) is as under:

"Mounting local filesystems."
"mount on nfs Server 192.168.1.7 failed. The Server is down"
"failed"

But the server is very much up.

Extract from my /etc/fstab is as below:

192.168.1.7:/home/rsp /mnt/rsp nfs soft,nfsvers=2 0 0
192.168.1.7:/home/shp /mnt/shp nfs soft,nfsvers=2 0 0

After loging-in as a user I can mount nfs by just running command 'sudo mount -a' on the terminal.

I suspect that the script 'mountall.sh' is executed before the network is up. And there is no link for starting this script in any of the '/etc/rc?.d' directories. So I cannot make out at what stage this script is executed. But it is executed during boot, for sure. I say this because after reversing the changes, there is no error but the nfs shares are not mounted automatically.

What more is needed here?

Any suggestions please?

Regards,

RSP

Wells 07-27-2007 11:15 AM

/etc/init.d/mountall.sh is called from /etc/rcS.d/S35mountall.sh. As the files in rcS.d I believe fire off before networking is setup in rc3.d (I believe... correct me if I am wrong), it is not surprising that NFS mounts fail at this time.

You may have to do a link in /etc/rc3.d to fire off mountall.sh again once networking has finished setting up.

rsp 07-29-2007 07:26 AM

nfs client does not mount server-shares automatically on boot
 
Thanks for your response and putting me wise on /etc/rcS.d.

What was useful in solving this problem, was the following extract from /etc/rcS.d/README:

"The following sequence points are defined at this time:

* After the S40 scripts have executed, all local file systems are mounted
and networking is available. All device drivers have been initialized."

So I made the link in /etc/rcS.d/S35mountall.sh as 'S80mountall.sh'. That has solved the problem.

Now there is no need to make any more links to '/etc/init.d/mountall.sh' in any other run-level.

Thanks and Regards,

rsp


All times are GMT -5. The time now is 04:04 AM.