LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 10-04-2012, 01:21 PM   #1
Caullyn
LQ Newbie
 
Registered: Oct 2012
Posts: 2

Rep: Reputation: Disabled
New user customization


Hello,

I have created a new debian user using

Code:
useradd -m [username]
When I login to the user, it doesn't have all of the functionality that root, or my postgres user, does. If I press up, it doesn't show me the recent commands, instead I just see '^[[A'.

Also, ctrl+r just prints ' ^R', instead of doing a reverse search.

Also, there is no prefix like 'root@[host] $'

Is there a simple way to have this level of functionality when creating the user? If not, what files do I need to alter to get these working?

If there is a file that I can just copy over from my postgres user, that would be great. I don't see any obvious ones in the home dir. .profile is empty. I tried changing the .bashrc in home/[user] and /etc/skel/
 
Old 10-04-2012, 03:33 PM   #2
pingu
Senior Member
 
Registered: Jul 2004
Location: Skuttunge SWEDEN
Distribution: Debian preferably
Posts: 1,318

Rep: Reputation: 124Reputation: 124
First question: are you logging in with putty from Windows?
Because I've seen the same thing a few times when logging in from something else than Linux terminal.
I *think* - though I can't be sure - that the problem is not related to the Debian system, but to the terminal you use to log in with.
But just to be on the safe side, check users shell:
grep <username> /etc/passwd - what shell does it show you? (The last path in the output.)
 
Old 10-04-2012, 03:48 PM   #3
ukiuki
Senior Member
 
Registered: May 2010
Location: Planet Earth
Distribution: Debian
Posts: 1,030

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Have you tried?:
Code:
# adduser [username]
It normaly does all you need.

Regards
 
Old 10-04-2012, 04:53 PM   #4
Caullyn
LQ Newbie
 
Registered: Oct 2012
Posts: 2

Original Poster
Rep: Reputation: Disabled
In /etc/passwd I switch "bin/sh" to "bin/bash" and now it seems to be the same!

Thanks!

adduser also appeared to set the user up with "bin/bash" in etc/passwd. So, both solutions are great. I will use adduser from now on.

Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
linux customization clarodina Linux - Newbie 5 09-21-2011 02:15 PM
[SOLVED] e-17 customization matiasar Linux - Desktop 4 11-23-2010 07:24 AM
Berly Customization Help soldier228 Linux - Software 8 05-10-2007 09:43 PM
Customization Jmcatch742 Linux - General 7 08-21-2004 10:55 PM
Debain customization. Vipes Debian 3 01-26-2004 11:25 AM


All times are GMT -5. The time now is 12:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration