LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 04-05-2005, 01:04 AM   #1
damienduff
Member
 
Registered: Feb 2004
Distribution: Etch
Posts: 117

Rep: Reputation: 15
new debian user. need help with chinese filenames


decided to make the plunge to debian from my suse.
apt-get is very good! updating the kernel to 2.6.8-2. was a piece of cake!

I have SCIM working in KDE3.3. but how do i display chinese filenames correctly?

the chinese filenames I saved from the internet are displayed as funny character inside my /home/user/ folder.

and chinesename.txt i created myself is displayed as ???

my .bashrc has
export LC_CTYPE="zh_CN.gb2312"

my locale is

LANG=en_US
LC_CTYPE=zh_CN.gb2312
LC_NUMERIC="en_US"
LC_TIME="en_US"
LC_COLLATE="en_US"
LC_MONETARY="en_US"
LC_MESSAGES="en_US"
LC_PAPER="en_US"
LC_NAME="en_US"
LC_ADDRESS="en_US"
LC_TELEPHONE="en_US"
LC_MEASUREMENT="en_US"
LC_IDENTIFICATION="en_US"
LC_ALL=

any advice is appreciated.

Last edited by damienduff; 04-05-2005 at 04:44 AM.
 
Old 04-05-2005, 06:58 AM   #2
mcosta
Member
 
Registered: Jan 2005
Location: Spain
Distribution: Debian
Posts: 44

Rep: Reputation: 15
First you need fonts with these characters installed. Normaly the package is called xfonts-xxx-big5. Then you should 'dpkg-reconfigure locales' and build the locales you'd want. In a mixed system like yours setting utf8 as default locale is a good idea.
 
Old 04-05-2005, 01:16 PM   #3
damienduff
Member
 
Registered: Feb 2004
Distribution: Etch
Posts: 117

Original Poster
Rep: Reputation: 15
U the man! U the man! UTF8 fixed the problem!

LANG=en_US.UTF-8
LC_CTYPE=zh_CN.gb2312
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
locale: Cannot Set LC_ALL to default locale: No such file or directory. asym Linux - General 10 03-24-2013 08:35 PM
SCIM only works in ZH LOCALE LaoNiu Debian 6 05-04-2005 02:30 AM
Strange Debian/Firefox locale problem... fannymites Debian 2 04-04-2005 06:12 PM
setting LOCALE variables in Debian LaoNiu Linux - Software 0 11-10-2004 08:56 AM
Debian install breaks on 'Add Locale' jhecht Linux - Software 0 07-22-2004 02:16 PM


All times are GMT -5. The time now is 04:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration