LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 06-05-2004, 11:44 AM   #1
JediGuy_bob
LQ Newbie
 
Registered: Apr 2004
Location: Albuquerque/Chicago
Posts: 22

Rep: Reputation: 15
networking and sound failures after apt-get upgrade


I just ran an apt-get upgrade on my unstable machine and have run into the following problems:

1. Networking fails, specifically: eth0 not started: Error getting interface flags.

I solved this problem by doing a modprobe 8139too and a networking restart, but I don't know how to safely add it to /etc/modules.conf

2. Sound has stopped working:
It was working prior to the upgrade. sndconfig finds it as Model: Intel Corp.|82801BA/BAM AC'97 Audio. (Not currently supported). During boot I get this message:
Trying to initialize mixer.... failed

I would add more information, but I'm not sure where to find it.

Thanks in advance!!

-bob
 
Old 06-05-2004, 12:17 PM   #2
JediGuy_bob
LQ Newbie
 
Registered: Apr 2004
Location: Albuquerque/Chicago
Posts: 22

Original Poster
Rep: Reputation: 15
After some further exploraton I'm running into the problem of

/dev/dsp: no such device
/dev/mixer: no such device

there are symlinks and permissions set at:

lrwxrwxrwx 1 root audio 11 Apr 13 22:22 mixer -> /dev/mixer0
crwxrwxrwx 1 root audio 14, 0 Apr 13 22:22 mixer0

lrwxrwxrwx 1 root root 11 Apr 13 22:22 audio -> /dev/audio0
crw-rw---- 1 root audio 14, 4 Apr 13 22:22 audio0
 
Old 06-05-2004, 12:32 PM   #3
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
If you're using 2.4 kernel, edit /etc/modutils/aliases to include the kernel module for your nic, and then run "update-modules".

If you're using 2.6 kernel, the aliases file to edit is /etc/modprobe.d/aliases.

If you've got the "modconf" utility installed, that may be the easiest method to load kernel modules.

Here's another thread that discusses similar issues:

http://www.linuxquestions.org/questi...hreadid=172998

That should help you to get the network up again, but I'm not at all sure what causes your sound card problem. Did you upgrade from 2.4 kernel to 2.6 kernel? Do you have the alsa-base package installed? Enabling alsa sound requires that you run "alsaconf" (as root).

Perhaps someone can offer better advices on the sound card issue?
 
Old 06-05-2004, 09:18 PM   #4
onnyloh
Member
 
Registered: Nov 2002
Posts: 57

Rep: Reputation: 15
Re: networking and sound failures after apt-get upgrade

Quote:
Originally posted by JediGuy_bob
I just ran an apt-get upgrade on my unstable machine and have run into the following problems:

1. Networking fails, specifically: eth0 not started: Error getting interface flags.

I solved this problem by doing a modprobe 8139too and a networking restart, but I don't know how to safely add it to /etc/modules.conf

2. Sound has stopped working:
It was working prior to the upgrade. sndconfig finds it as Model: Intel Corp.|82801BA/BAM AC'97 Audio. (Not currently supported). During boot I get this message:
Trying to initialize mixer.... failed

I would add more information, but I'm not sure where to find it.

Thanks in advance!!

-bob
use /sbin/modconf
to add support for your device.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apt-get question: dist-upgrade vs upgrade Arodef Fedora 9 06-15-2012 01:33 PM
runlevel 1 networking (apt-get) problem rosslaird Debian 5 07-16-2004 11:02 PM
What's the difference between apt-get upgrade and apt-get dist-upgrade? davidas Linux - Newbie 4 04-04-2004 08:19 PM
APT-GET troubles - networking? MTU? blietaer Linux - Hardware 1 01-06-2004 11:29 AM
Sound server could not start after apt-get upgrade satimis Linux - Hardware 0 07-15-2003 04:28 AM


All times are GMT -5. The time now is 02:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration