LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   netinstall cd & sis900 module (http://www.linuxquestions.org/questions/debian-26/netinstall-cd-and-sis900-module-248786/)

tib_tib 10-29-2004 12:44 PM

netinstall cd & sis900 module
 
hello,

i'm a quite newbie in llinux installations and tried to install debian with a netinstal cd.
the problem is that my network card is not recognised... which is inconvenient for a netinstall ....
my network card is a Sis900-Based PCI Fast Ethernet Adapter,
but when i arrive at the module configuration step and i try to load the sis 900 module it fails ....

here are the messages :
"/lib/modules/2.2.20-idepci/net/sis900.o : init_module : Device or resource busy, hint : irns mod errors can be used by incorrect parameters, includin invalid IO or IRQ parameters.
/lib/modules/2.2.20-idepci/net/sis900.o : insmod /lib/modules/2.2.20-idepci/net/sis900.o failed.
/lib/modules/2.2.20-idepci/net/sis900.o : insmod sis900 failed"

do anyone knows what to do?

thank you very much

tib

haimeltjnfg 10-29-2004 11:02 PM

netinstall has never failed to get my sis900 working.

hmm. it seems the installer is loading a 2.2.20 module. i thought the installer uses 2.4 (i know there is an option for 2.6).

try booting kernel 2.6.

TigerOC 10-30-2004 02:43 AM

Try using the switch bf24 to begin the install with the 2.4.18 kernel see options F3 I think it is.

tib_tib 10-30-2004 11:44 AM

thnx for your answers i'm gonna try this

tib_tib 10-30-2004 12:06 PM

i forgot to say that i'm on a laptop , does that makes a difference?

tib_tib 10-30-2004 12:36 PM

Quote:

Originally posted by haimeltjnfg
netinstall has never failed to get my sis900 working.

hmm. it seems the installer is loading a 2.2.20 module. i thought the installer uses 2.4 (i know there is an option for 2.6).

try booting kernel 2.6.

hmm i did not find the option for booting on 2.6 .. . does anyone knows it?

Quote:

Originally posted by TigerOC
Try using the switch bf24 to begin the install with the 2.4.18 kernel see options F3 I think it is.
i also tried with the bf24, my card is not recognised and there is no sis900 module available ....

TigerOC 10-30-2004 12:38 PM

It should not make any difference. You say net-install and by that I read Woody? If the equipment is fairly new then perhaps try the newish Sarge installer with the 2.6 kernel. The switch for this is linux26 on the boot screen again use F3? to see your installation options. I found this installer really good.


All times are GMT -5. The time now is 07:51 PM.