LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 02-21-2004, 10:46 AM   #1
lowlifeboy
LQ Newbie
 
Registered: Feb 2004
Posts: 3

Rep: Reputation: 0
Need to modify - modules.conf


I have Lindows OS (based on Debian) on a Toshiba Satellite Pro 6100 laptop. My laptop has NVidia drivers and I need to add the following the the modules.conf file:
options nvidia NVreg_SoftEDIDs=0 NVreg_Mobile=2

In RedHat, and Mandrake, I knew exactly how to make this change - but I went to make the change on modules.conf and it said not to do it there. The remarks there say to go to /etc/modutils, where do I add this line?

Any ideas?

Thanks
 
Old 02-21-2004, 07:25 PM   #2
lowlifeboy
LQ Newbie
 
Registered: Feb 2004
Posts: 3

Original Poster
Rep: Reputation: 0
Anyone has any ideas on how to do this?
 
Old 02-21-2004, 08:51 PM   #3
liquigel
Newbie
 
Registered: Feb 2004
Location: CT, USA
Distribution: Debian stable
Posts: 29

Rep: Reputation: 15
With debian, you don't modify modules.conf by-hand, but rather use modconf
to do it for you.
 
Old 02-22-2004, 03:52 PM   #4
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 64
You need to edit the file /etc/modutils/aliases as root and add an option for the module settings then once you save the file you need to run update-modules to have the new information entered into the /etc/modules.conf to be available for use. An example of the line from my file.
Code:
# Added by me for Nvidia card
options nvidia NVreg_EnableAGPFW=1
You should put the both options on the one line separated by a space I believe and after you have updated the modules go to the console and stop the X server if using kde then you can do this by /etc/init.d/kdm stop then rmmod nvidia and modprobe nvidia to remove and reload the nvidia module with the new settings. Then /etc/init.d/kdm restart to get a new kde login screen while restarting the X server.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Conf.modules Vs Modules.conf Issue, lost eth0 initialization LinuxFreebie41 Linux - General 3 11-04-2004 07:02 AM
Update-modules: No longer managing /lib/modules/modprobe.conf? geekzen Debian 0 04-03-2004 07:49 PM
/etc/conf.modules is more recent than /lib/module/2.2.15-4mdk/modules.dep Derek-kun Linux - Newbie 3 09-26-2003 03:56 AM
Re: modprobe: Note: /etc/modules.conf is more recent than lib/modules/2.4.9/modules.d Andy.M Linux - General 1 01-24-2002 02:50 AM
Re: modprobe: Note: /etc/modules.conf is more recent than lib/modules/2.4.9/modules.d Andy.M Linux - Newbie 2 01-24-2002 02:40 AM


All times are GMT -5. The time now is 04:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration