LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 06-20-2005, 05:53 AM   #31
Creak
Member
 
Registered: Feb 2004
Distribution: debian
Posts: 187

Rep: Reputation: 30

Really, i don't understand why there is so much problem with your apt sources.list... Maybe you think it's something too much difficult to understand, but it's not... You must miss something...
Please, post the *exact* content of your sources.list file, then post the *exact* output of the "apt-get update" command.

It should look like something like that:
Code:
creak@slibar:~$ cat /etc/apt/sources.list
# deb file:///cdrom/ sarge main

deb http://ftp.fr.debian.org/debian/ testing main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ testing main contrib non-free

deb http://security.debian.org/ stable/updates main
creak@slibar:~$
Code:
creak@slibar:~$ sudo apt-get update
Password:
Atteint http://security.debian.org stable/updates/main Packages
Atteint http://security.debian.org stable/updates/main Release
Atteint http://ftp.fr.debian.org testing/main Packages
Atteint http://ftp.fr.debian.org testing/main Release
Atteint http://ftp.fr.debian.org testing/contrib Packages
Atteint http://ftp.fr.debian.org testing/contrib Release
Atteint http://ftp.fr.debian.org testing/non-free Packages
Atteint http://ftp.fr.debian.org testing/non-free Release
Atteint http://ftp.fr.debian.org testing/main Sources
Atteint http://ftp.fr.debian.org testing/main Release
Atteint http://ftp.fr.debian.org testing/contrib Sources
Atteint http://ftp.fr.debian.org testing/contrib Release
Atteint http://ftp.fr.debian.org testing/non-free Sources
Atteint http://ftp.fr.debian.org testing/non-free Release
Lecture des listes de paquets... Fait
creak@slibar:~$
I've not done the upgrade because i've done one few days ago and i like to wait a little before upgrading my system
BTW, it's in french here...

Last edited by Creak; 06-20-2005 at 05:55 AM.
 
Old 06-20-2005, 09:54 AM   #32
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,732
Blog Entries: 12

Rep: Reputation: 455Reputation: 455Reputation: 455Reputation: 455Reputation: 455
Your permission issues with not being able to save it are because you did not open the text editor as 'root'.

It is very simple and you have been given several ways to fix your problem.


Maybe it is time for you to READ APT HOWTO


Debian is very simple to use and understand if you take the time to read and understand the documentation that is available.

Try this hit Alt+F2 that will open a command window in the window type gksu gedit
then open /etc/apt/sources.list add the appropriate repositories then save it has to be saved to the original place, if you open the editor as "root" you should have no no problems.
 
Old 06-20-2005, 08:37 PM   #33
1702fp
Member
 
Registered: Feb 2005
Location: California
Distribution: Slackware
Posts: 82

Original Poster
Rep: Reputation: 15
#Stable Sarge
deb http://http.us.debian.org/debian/ stable main contrib non-free
#Stable (Sarge) Sources
deb-src http://http.us.debian.org/debian/ stable main contrib non-free
#Security Updates Stable
deb http://security.debian.org/ stable/updates main contrib non-free

# Testing Etch
deb http://http.us.debian.org/debian/ testing main contrib non-free
# Testing Sources
deb-src http://http.us.debian.org/debian/ testing main contrib non-free

Ok I opend the terminal as root

I opened the terminal then typed su and the typed gedit then pasted the above line onto the text editor, clicked save a menu pooped up asking me where I wanted to save the file the choices were home file system cd rom and desktop I chose ... file system I did not have an option to save the file in the src area, then I typed apt-get update and here is what happend

username@linux:~$ su
Password:
linux:/home/username# apt-get update
Get:1 ftp://mirrors.kernel.org testing/main Packages [3430kB]
Hit http://security.debian.org testing/updates/main Packages
Hit http://security.debian.org testing/updates/main Release
Get:2 ftp://mirrors.kernel.org testing/main Release [81B]
Get:3 ftp://mirrors.kernel.org testing/main Sources [1352kB]
Get:4 ftp://mirrors.kernel.org testing/main Release [83B]
Fetched 4783kB in 16s (293kB/s)
Reading Package Lists... Done
linux:/home/username#

I wish Debian would just let me drag the file into the src folder I know I'm not the sharpest pencil in the box but I'm not that dumb either Lol

The file saved to the apt src the file has a Lil lock on it and will not allow me to open it so I can see what is inside


here's what it says inside the originaldeb file:///cdrom/ sarge main

#deb ftp://mirrors.kernel.org/debian/ testing main
deb-src ftp://mirrors.kernel.org/debian/ testing main

deb http://security.debian.org/ testing/updates main

It's not to bad when I open styptic and edit the suppository's from there
only one line apprears to be preventing the updates from updating and that line is the 3rd one deb-src http://ftp.fr.debian.org/debian/ testing main contrib non-free


The following problems were found on your system:

E: Malformed line 3 in source list /etc/apt/sources.list (URI parse)



Last edited by 1702fp; 06-20-2005 at 08:45 PM.
 
Old 06-21-2005, 12:50 AM   #34
Creak
Member
 
Registered: Feb 2004
Distribution: debian
Posts: 187

Rep: Reputation: 30
wow i don't understand everything here... you enter this URL: http://http.us.debian.org/debian/, the update gives you this one: ftp://mirrors.kernel.org, then you talk about http://ftp.fr.debian.org/debian/...

Too much URL for me... and AFAIK, there is only one file that handle the apt system.

try something else: (still as root)
dpkg-reconfigure apt

I hope it'll fix your problem, because I don't know what you've done on your debian, but it seems like there is a problem!
Personnally I don't see what's the problem, normally there is nothing as easy as apt... so I'm kinda confused...
 
Old 06-21-2005, 10:49 PM   #35
1702fp
Member
 
Registered: Feb 2005
Location: California
Distribution: Slackware
Posts: 82

Original Poster
Rep: Reputation: 15
I'm willing to bet money that there is something wrong with the repository's because an error message comes up when I open the text editor (gedit) as root


gedit:4018): GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed

The files not saving because authentication refused to allow me to log in as root






dpkg-reconfigure apt just takes me back to Linux home/username

Think the best bet would be to un install then reinstall Debian all over again
 
Old 06-22-2005, 05:56 AM   #36
Creak
Member
 
Registered: Feb 2004
Distribution: debian
Posts: 187

Rep: Reputation: 30
Quote:
The files not saving because authentication refused to allow me to log in as root
You doesn't have the root privileges...
Log me everything that happens when you type "su" in a shell plz
 
Old 06-22-2005, 07:55 PM   #37
1702fp
Member
 
Registered: Feb 2005
Location: California
Distribution: Slackware
Posts: 82

Original Poster
Rep: Reputation: 15
This is amazing I never had any problems with Ubuntu

Wow... here is what happens when I open the text editor as root


username@linux:~$ su
Password:
linux:/home/username# gedit

(gedit:4015): GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.

The text editor opens just wont open as root
 
Old 06-23-2005, 06:04 AM   #38
Creak
Member
 
Registered: Feb 2004
Distribution: debian
Posts: 187

Rep: Reputation: 30
Wow... that's weird...
I can promise you that Inever had problem with the su command... I'm sorry to say that, but maybe your installation has been corrupted for a reason that I don't know and the reinstallation seems to be the only way to correct this...

Seriously, I understand that you found Debian weird if the su command didn't work... I'm sure you'll like it after a clean install. Here is a little script i use to install the basis: xserver, gnome and nvidia drivers

You'll just have to change the sources.list (at least it'll be done right at the beginning) and change it to testing, update, dist-upgrade and then install a recent kernel by hand before (I didn't include them in the script because it changes quite often):
kernel-headers-2.6.11-1-386
kernel-image-2.6.11-1-386

Code:
#!/bin/sh
## Apt-firstinst:
## Run it just after the basic package is installed.
##
## Thanks to Andrew E. Schulman for the nVidia installation part.
## (http://home.comcast.net/~andrex/Debian-nVidia/)

## xServer and Gnome.
apt-get install xfonts-base xlibs xutils xfonts-scalable xfonts-75dpi xfonts-100dpi xfonts-75dpi-transcoded xfonts-100dpi-transcoded msttcorefonts xserver-xfree86 xscreensaver-gl gnome gdm dvd+rw-tools zip unzip gnome-spell samba-common mdetect read-edid gimp-data-extras gimp-svg alsa

## nVidia driver installation.
apt-get install module-assistant nvidia-kernel-common
module-assistant prepare
module-assistant auto-install nvidia
apt-get install nvidia-glx nvidia-settings xlibmesa-dev xlibmesa-gl-dev xlibmesa-glu-dev freeglut-dev
## Save the conf file.
cp -p /etc/X11/XF86Config-4 /etc/X11/XF86Config-4.bak
## Tell Debian the file has never been edited.
md5sum /etc/X11/XF86Config-4 > /var/lib/xfree86/XF86Config-4.md5sum
## Reconfigure
dpkg-reconfigure xserver-xfree86
## Add "nvidia" if not in the loaded modules.
grep -q ^nvidia /etc/modules || echo "nvidia" >> /etc/modules
 
Old 06-26-2005, 03:55 AM   #39
1702fp
Member
 
Registered: Feb 2005
Location: California
Distribution: Slackware
Posts: 82

Original Poster
Rep: Reputation: 15
Wow turned out that the source.list file was corrupted- Big time. So I tweaked the system a bit then opened the file that said source.list, then erased the old data and replaced it with the new updated version that is posted below this paragraph.

#Stable Sarge
deb http://http.us.debian.org/debian/ stable main contrib non-free
#Stable (Sarge) Sources
deb-src http://http.us.debian.org/debian/ stable main contrib non-free
#Security Updates Stable
deb http://security.debian.org/ stable/updates main contrib non-free

After that, I clicked on the synaptic manager, then repositories everything was in place

So I exited the terminal and opened up synaptic manager again then clicked on the reload tab then choose smart update the system proceeded to download the updates, after that I clicked mark all upgrades, Now here's the part I don't get. For some reason or another the apply tab was grayed out, so I could not apply the updates.

I tried dist-update as well as a few other commands then went back to update the system but still no go the apply tab was still grayed out. I'm most certain that the problem is minor. I'm just glad that everything is in place. Now all I need to do is find out how to get the apply tab to apply the upgrade then I'll be all set.

Wow.... I knew all along that the problem had something to do with a crouped file
 
Old 06-26-2005, 06:16 AM   #40
Creak
Member
 
Registered: Feb 2004
Distribution: debian
Posts: 187

Rep: Reputation: 30
It's weird that there is not even one update, but you are under "stable", and the package doesn't change as quickly as in the other repository.
I think you can easily and safely change your sources.list file to this (now that you can change it ):
Code:
# Testing (Etch)
deb http://http.us.debian.org/debian/ testing main contrib non-free
# Testing (Etch) Sources
deb-src http://http.us.debian.org/debian/ testing main contrib non-free
# Security Updates Stable
deb http://security.debian.org/ stable/updates main contrib non-free
If there is no upgrades even after that, it's that there is a problem!
 
Old 05-25-2006, 11:24 PM   #41
ethyrdude
LQ Newbie
 
Registered: Mar 2006
Posts: 9

Rep: Reputation: 0
First off, I'd like to send accolades to Creak and Craigevil for their patience with this one. I had a similar problem trying to get wmvs to play with totem and that's how I happened to "land" here. I tried the afore mentioned repositories also but these aren't working any more but just in case someone else is having a similar problem, I'd like to add my solution. I ended up going to the mplayer site and downloaded the essential codecs package and extracted the contents to a directory in my home directory. I then copied those files to where totem wanted them under file:/home/"username"/.gnome2/totem-addons and was able to play wmv files. Most things in Debian are pretty simple to do, if I, a 53 year old can use Debian, then anyone can use Debian.
 
Old 05-26-2006, 06:43 PM   #42
jonaskoelker
Senior Member
 
Registered: Jul 2004
Location: Denmark
Distribution: Ubuntu, Debian
Posts: 1,524

Rep: Reputation: 46
Quote:
Most things in Debian are pretty simple to do.
Agreed

Quote:
If I, a 53 year old can use Debian, then anyone can use Debian.
Not agreed. Mind you, I'm not trying to bash Debian (which I love) or you (or anyone for that matter), but I claim Debian (and in fact GNU/Linux in general) takes a certain type of personality. If I recall correctly from LUGRadio, Aq's dad never was that good with computers, but at some point he managed to get his modem working in SuSE and became completely hooked. Aq's comment (on the show) was then "A little sense of adventure will help you."

I believe this to be right on the spot. As a contrapositive, my mom doesn't have much of a sense of adventure when it comes to computers. As a result, I've been called over because "it displayed advertisement on startup". The fix: change the start page of IE.

My mom most likely couldn't use debian. Aq's dad most likely could.

Now, I'm not saying that there's no correlation between age and sense of adventure. However, age is not all that matters (and you argue solely based on age).

So. I didn't mean to nitpick, I just wanted to raise what I think is a valid point; hopefully some of you will get wiser as a result. Because, let's face it, GNU/Linux is not for everybody, and it probably never can be, because computers are not for everybody. I'm not against GNU/Linux being suitable for as many people as possible, I just think there's some way to go. Then there's the hardware issues (have a look at OpenGraphics to see a shining example of the opposite of what I'm referring to here), and the political issues (copyright law and patent law are the two major ones).
 
Old 05-30-2006, 07:06 PM   #43
ethyrdude
LQ Newbie
 
Registered: Mar 2006
Posts: 9

Rep: Reputation: 0
Actually anyone can use this distro, the problem is not everyone can install it or set it up. I agree with the mindset thing, you have to want it to make it work. My wife probably would find the install a bit of a challenge but then she would find installing Windows difficult also. As for using Debian, it has everything she needs, as long as there are icons on the desktop or a start button going to a menu of some type, she is quite happy. If she can't find what she wants, she knows where sys admin is.
 
Old 05-31-2006, 03:49 PM   #44
jonaskoelker
Senior Member
 
Registered: Jul 2004
Location: Denmark
Distribution: Ubuntu, Debian
Posts: 1,524

Rep: Reputation: 46
Quote:
Actually anyone can use this distro, the problem is not everyone can install it or set it up.
Okay, you got a point there, and I've actually made that point myself before, so shame on me for not making that distinction.

Quote:
If she can't find what she wants, she knows where sys admin is.
Fair enough. Not everyone has that luxury, though. My mom and--lacking a better expression--the bloke she's banging provides a good example; I doubt any of them could install and configure Debian. Not long ago, I had to "fix their speakers" (it turns out that the sound was on mute in the windows control panel).
 
  


Reply

Tags
debian, fix, totem


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
plug-ins for mozilla? chillangella Linux - Newbie 1 08-03-2004 09:23 PM
Plug-ins, Plug-ins, Plug-ins, those damn Plug-ins!! GRRRR!! Ausar Linux - Newbie 1 06-09-2004 03:10 PM
Plug-ins for Netscape 7.1 and RH W9RAN Linux - Software 1 04-15-2004 08:15 AM
installing plug-ins bosewicht Mandriva 12 11-10-2003 03:59 AM
netscape plug-ins lub0 Linux - Software 2 10-30-2003 09:50 AM


All times are GMT -5. The time now is 01:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration