LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Nas server, openiscsi,and lvm question-why doesnt this work? (http://www.linuxquestions.org/questions/debian-26/nas-server-openiscsi-and-lvm-question-why-doesnt-this-work-4175427172/)

mxdog 09-14-2012 12:29 AM

Nas server, openiscsi,and lvm question-why doesnt this work?
 
I have a 16 bay-nas server running debian wheezy with 4 drives in it. With out going into all the hardware trivia what i am trying to do is use it as a network media share device. I have a 4Tb volume setup with ntfs-3g as a iscsi target gpt partion table so my win comps can see it. That works. unfortunantly i cant seem to mount that on the server to use it for my mediatomb server. i can get it to mount by running partprobe it generates a partition in /dev/mapper that i can mount and use but if I add files from a connected machine to the target volume the changes are not reflected on the mapped vol-02-p1.

here is some of the setup (Mounted)

mx-nas-01: pvscan

PV /dev/sdc1 VG Vol-02 lvm2 [1.82 TiB / 0 free]

PV /dev/sdd1 VG Vol-02 lvm2 [1.82 TiB / 0 free]

PV /dev/sdb1 VG Vol-01 lvm2 [1.80 TiB / 1.30 TiB free]

PV /dev/sda5 VG mx-nas-01 lvm2 [19.76 GiB / 0 free]
PV /dev/Vol-01/xen-store VG VG_XenStorage-## lvm2 [499.99 GiB / 379.41 GiB free]


you can see the volume doesnt show on sdc1 and sdd1

(striped) (/dev/Vol-02) but is a working ntfs file system as an iscsi-target

blkid partial output after running (less uuid) AFTER partprobe
mx-nas-01:blkid
/dev/mapper/mx--nas--01-swap_1: TYPE="swap"
/dev/sda5:TYPE="LVM2_member"
/dev/sdb1:TYPE="LVM2_member"
/dev/sda1:TYPE="ext2"
/dev/sdc1:TYPE="LVM2_member"
/dev/mapper/mx--nas--01-root:TYPE="ext3"
/dev/dm-0: TYPE="ext3"
/dev/dm-2: SEC_TYPE="ext2" TYPE="ext3"
/dev/mx-nas-01/swap_1: TYPE="swap"
/dev/sdd1:TYPE="LVM2_member"
/dev/mapper/Vol--01-xen--store: TYPE="LVM2_member"
/dev/mapper/Vol--01-eqemu: TYPE="ext3"
/dev/dm-4: TYPE="swap"
/dev/dm-3:TYPE="LVM2_member"
/dev/mapper/Vol--02-mxntfsp1: LABEL="mxntfs" TYPE="ntfs"

So the question is why doesnt the mapped volume Vol--02-mxmtfsp1 update data when i write to the iscsi volume: which is /dev/Vol-02/mxntfs -> ../dm-1 they are mapped to each other and conversly is also true

and why doesnt the system assign it a uuid number (blkid) and why doesnt it show up in blkids output when iet uses it just fine and and and ......

mx-nas-01:/dev# dmsetup ls
Vol--01-eqemu (253:2)
Vol--01-xen--store (253:3)
Vol--02-mxntfsp1 (253:5)
Vol--02-mxntfs (253:1)
mx--nas--01-root (253:0)
mx--nas--01-swap_1 (253:4)

I really dont know what is going on, what do i need to do to make the /dev/mapper/Vol--02-mxntfsp1 slave to the /dev/mapper/Vol--02-ntfs. As a note i have tried many many times to get a partition on vol 2 mount it and then export it to IET either windows sees a bunch of individual partitions or everyhting gets corrupted.I thnk there is a bug here somewhere in the kernel (gpt),mapper(lvm2),or ntfs-3g.IET or some combo of the 4 but it is more then possible i am doing something wrong (other then trying to make this work)

here is the mount info. i dont seem to be getting any corruption yet using the mounted partition but it is pretty worthless other then reading from it when all the file adds come from out of the box again i cant mount the raw vol-02 which is odd because vol-01 which is the same set up less the gpt and ntfs works as expected and as root too with added volumes ..eqemu and xen-storage but it does have a REAL partition on each drive for /boot

sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
udev on /dev type devtmpfs (rw,relatime,size=10240k,nr_inodes=1023071,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=819780k,mode=755)
/dev/mapper/mx--nas--01-root on / type ext3 (rw,relatime,errors=remount-ro,barrier=1,data=ordered)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /run/shm type tmpfs (rw,nosuid,nodev,noexec,relatime,size=1639540k)
/dev/sda1 on /boot type ext2 (rw,relatime,errors=continue)
rpc_pipefs on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw,relatime)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,nosuid,nodev,noexec,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
/dev/mapper/Vol--02-mxntfsp1 on /mnt/ntfs type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,allow_other,blksize=4096)

I know there are easier ways to do this, nfs exports and samba, come to mind but i would really like to get this figured out because it seems to me it should work ..a block device is a block device right?

just to be clear the goal here was to use a 4tb iscsi target (2-2tb drives) for my linux and windows (vista+) machines as one big network drive using ntfs and to also be able to use it on the local linux box for a media server and local storage if needed. As a plus to also be able to add resize move volumes with lvm as i add or remove drives to the box.

Dutch Master 09-14-2012 06:54 PM

This is quite a complex setup, especially when administered by hand. Webmin is usually a good GUI tool to get such things working, syntax errors can mess things up silently but unfindable...


All times are GMT -5. The time now is 01:30 PM.