LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 07-29-2012, 12:16 AM   #1
ninioArg
LQ Newbie
 
Registered: Jul 2012
Posts: 5

Rep: Reputation: Disabled
Angry Multiple applications cannot access the sound device at the same time


That's the problem. I can't listen from two or more source at the same time. There is no problem from just one source. For example: I can't listen 1 MP3 from Amarok and other from Rhythmbox, or music from Amarok and sound from a Youtube video.

I read half of internet about this issue, without solutions, all post are old or talk about alsa-conf or some other useless information.

And of course, I got installed all jack family, alsa family, gstream family, and many other families.

uname -a:
Code:
Linux cosmo 2.6.32-5-amd64 #1 SMP Sun May 6 04:00:17 UTC 2012 x86_64 GNU/Linux
lspci | grep Audio:
Code:
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA) (rev 40)
05:00.1 Audio device: ATI Technologies Inc RV710/730
lsmod | grep snd:
Code:
snd_seq_dummy           1343  1 
snd_hda_codec_atihdmi     2251  1 
snd_hda_codec_via      47887  1 
snd_hda_intel          20035  4 
snd_hda_codec          54292  3 snd_hda_codec_atihdmi,snd_hda_codec_via,snd_hda_intel
snd_hwdep               5380  1 snd_hda_codec
snd_pcm_oss            32591  0 
snd_mixer_oss          12606  1 snd_pcm_oss
snd_pcm                60487  4 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_seq_midi            4400  0 
snd_rawmidi            15515  1 snd_seq_midi
snd_seq_midi_event      4628  1 snd_seq_midi
snd_seq                42881  6 snd_seq_dummy,snd_seq_midi,snd_seq_midi_event
snd_timer              15598  2 snd_pcm,snd_seq
snd_seq_device          4493  4 snd_seq_dummy,snd_seq_midi,snd_rawmidi,snd_seq
snd                    46526  19 snd_hda_codec_via,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore               4598  1 snd
snd_page_alloc          6249  2 snd_hda_intel,snd_pcm
 
Old 07-29-2012, 07:21 AM   #2
Dutch Master
Senior Member
 
Registered: Dec 2005
Posts: 1,684

Rep: Reputation: 124Reputation: 124
Yes, but did you install a mixer?
 
Old 07-29-2012, 08:06 AM   #3
ninioArg
LQ Newbie
 
Registered: Jul 2012
Posts: 5

Original Poster
Rep: Reputation: Disabled
Yes sir, or I think so. I got installed alsa-utils (which comes with alsamixer) and alsamixergui, if it's what you mean.
 
Old 07-29-2012, 03:14 PM   #4
Dutch Master
Senior Member
 
Registered: Dec 2005
Posts: 1,684

Rep: Reputation: 124Reputation: 124
Right, I assume then you un-muted the required channels? (going through all the usual suspects here!)
 
Old 07-30-2012, 02:55 AM   #5
ninioArg
LQ Newbie
 
Registered: Jul 2012
Posts: 5

Original Poster
Rep: Reputation: Disabled
Yes, the required channels are un-muted. I think the problem is when another application use the sound card, because the first got muted until I do something that makes "re-open" the audio channel for it; after this, the second one got muted.
 
Old 07-31-2012, 01:21 PM   #6
ninioArg
LQ Newbie
 
Registered: Jul 2012
Posts: 5

Original Poster
Rep: Reputation: Disabled
[Solved]

Finally I could solve this issue. I uninstalled Everything of alsa and Pulseaudio, and reinstall pulseaudio. After that, I made this file:
Code:
pcm.pulse {
type pulse
}
ctl.pulse {
type pulse
}
pcm.!default {
type pulse
}
ctl.!default {
type pulse
}
pcm.phononpulse {
type plug
slave.pcm {
type pulse
}
hint {
show on
description "PulseAudio"
}
}
Pay attention to:
Code:
pcm.phononpulse {
That's the key.

Thank you everybody for your time
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Multiple applications cannot access sound card alphisb0t Ubuntu 1 08-26-2008 01:40 PM
Multiple applications accessing sound device slackiz Linux - Desktop 1 10-27-2007 07:43 AM
Application using sound, blocks access to soundcard for other applications?? Erik Plaggenmar Linux - Software 1 01-27-2005 12:05 PM
Several sound-applications at the same time atlesn Linux - General 2 04-27-2004 02:36 PM
Help about multiple display/sound device configuration Camion Linux - Newbie 1 05-27-2002 12:30 PM


All times are GMT -5. The time now is 11:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration