LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   mouse stops after a bit at black screen? (http://www.linuxquestions.org/questions/debian-26/mouse-stops-after-a-bit-at-black-screen-377742/)

lugoteehalt 10-28-2005 11:30 AM

mouse stops after a bit at black screen?
 
Since installing Debian Sarge the mouse works for a while at the black screen but when I switch back from X, sometimes - not always, the mouse has dissapeared. Can't work out what prompts this. Mouse allright in X.

Typing 'gpm &' as root has no effect. Sorry to be vaugh but I *think* gpm has stopped - not at computer at moment. Installed a module called mouse or somethinglike but it did not fix problem. Thanks any help.

fsateler 10-28-2005 11:38 AM

How is X configured to use the mouse? Does gpm appear in the output of 'ps -fea'?

lugoteehalt 10-31-2005 10:57 AM

Thanks.

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/psaux"
Option "Protocol" "PS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection
Section "InputDevice"
Identifier "Generic Mouse"
Driver "mouse"
Option "SendCoreEvents" "true"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
931 root 9 0 644 640 548 S 0.0 0.5 0:00.07 gpm

# /etc/gpm.conf - configuration file for gpm(1)
#
# If mouse response seems to be to slow, try using
# responsiveness=15. append can contain any random arguments to be
# appended to the commandline.
#
# If you edit this file by hand, please be aware it is sourced by
# /etc/init.d/gpm and thus all shell meta characters must be
# protected from evaluation (i.e. by quoting them).
#
# This file is used by /etc/init.d/gpm and can be modified by
# "dpkg-reconfigure gpm" or by hand at your option.
#
device=/dev/psaux
responsiveness=15
repeat_type=none
type=autops2
append=''
sample_rate=

It's outside X that it has stopped sometimes when switch back with ctrl-alt-F1.

fsateler 11-01-2005 02:23 PM

I can't figure out what can be happening, but maybe try (as root) "/etc/init.d/gpm restart".

lugoteehalt 11-02-2005 10:36 AM

Right, huge thanks, will try that. It hasn't happened for a while, perhaps it's fixed itself. Linux seems to have a habit of doing that.:confused:

lugoteehalt 11-15-2005 06:04 AM

Quote:

Originally posted by fsateler
I can't figure out what can be happening, but maybe try (as root) "/etc/init.d/gpm restart".
__________________
If your problem has been solved, please let us know.

Agree it is important to finish off threads - you search for things and the thread comes to no conclusion, upsetting.

What prompted the mouse stopping at the black screen was putting the laptop into suspend mode, with Fn+suspend (Dell Inspiron 4000). Other things may do it too, but this is the one I've spotted.

According to ps and top gmp, the general purpose mouse daemon, has stopped.

fsateler's receipe gets it working again. But do it twice: first time it claims to have stopped and then restarted gmp - odd since it was not running. But the mouse does not work. Repeat the command and it says gpm is not running and it has started gpm, then the mouse works.

(Incidently if the mouse stops in X just switch to a terminal with ctrl+alt+F1/6 and then switch back with alt+F7).


All times are GMT -5. The time now is 08:27 AM.