LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 07-17-2005, 12:03 AM   #1
tmack8968
LQ Newbie
 
Registered: Jul 2005
Posts: 8

Rep: Reputation: 0
Mouse/Keyboard don't work.


I just installed the latest version of Debian Linux (stable). I'm not a Linux expert, so help me out

After about a week or two trying to get XServer to run, I finally got it to work. It booted, and I was able to login and see the Debian desktop for the FIRST time!


...but my mouse didn't work. I hard-rebooted the system, the login prompt (I think xdm or kdm?) came up and it appears to be frozen. I see a cursor on the screen, but it does nothing. My mouse doesn't move, and my keyboard doesn't type.

My question is: What is the problem?

Is there anyway I can get back to the console so I can try to reconfigure X? Maybe my mouse/keyboard is configured wrong.

Specs:
AMD AthlonXP 1600+ 1.4GHZ
1.5GIG DDR333 Ram
8 GIG Maxtor 5200 RPM (pretty old!)
Mouse+keyboard connected via PS/2 (usb doesn't work neither)

PS: My system can't be frozen, a screensaver just went on.
 
Old 07-17-2005, 12:18 AM   #2
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
Try ctrl-alt-F1. That should return you to the console. If it does, you'll also know your keyboard in working. I suspect that you may not be able to type anything because the login box doesn't have focus. If that key combo doesn't work try ctrl-alt-backspace. That's the command to kill X and should only be used in emergencies.
 
Old 07-17-2005, 01:51 AM   #3
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
There is a known random bug with kdm in Sarge. I have it on one box and not the other. This is associated with the way kdm is loading. In my case the keyboard is non-funtional. The fact that neither mouse nor keyboard is functional for you is a problem since you are stuck at the kdm login. You need to boot into the command line. I have an option on my grub menu to boot into safe mode. What I did on the box that is fixed now is to apt-get --purge remove kdm and the re-install it and that solved it.

Edit: I have just done a --purge remove and reintall of kdm on the second system and that has also cured the problem.

Last edited by TigerOC; 07-17-2005 at 02:10 AM.
 
Old 07-17-2005, 06:35 AM   #4
farpoint
Member
 
Registered: Sep 2004
Location: France
Distribution: Debian Sarge, Etch. FC1,2,3,4,5. Slackware 10.0. Gentoo. Kubuntu.
Posts: 193

Rep: Reputation: 30
Hi. I had this problem, or one very similar when I installed the 2.6.8 kernel. Kernel 2.4.27-2 was ok, but initially with the 2.6 one X wouldn't start, and X's log complained about missing pointing device. Modprobe mousedev got X to start but the pointer was stuck. Modprobe psmouse fixed the stuck pointer, and I added both mousedev and psmouse to /etc/modules and no further problems. I admit that the keyboard was working ok, but it may be worth trying modprobe keybdev, and if that works add that to /etc/modules as well if it's not already there. Your problem may have nothing to do with this, but you never know. Nigel. aka farpoint.

Debian Woody 3.0r2 upgraded to Sarge and on stable repo.
Debian Woody 3.0r2 upgraded to Sarge and on testing (Etch) repo.

Kernels: 2.4bf2 (orig from cdrom). 2.4.27-2 (now with Alsa 1.09b). 2.6.8 (Alsa 1.04) . 2.6.11 (Alsa 1.08)

KDE3.3 using kdm
 
Old 07-17-2005, 08:50 AM   #5
archtoad6
Senior Member
 
Registered: Oct 2004
Location: Houston, TX (usa)
Distribution: MEPIS, Debian, Knoppix,
Posts: 4,727
Blog Entries: 15

Rep: Reputation: 231Reputation: 231Reputation: 231
This highlights why I gave up Woody & esp. Sarge for desktop use. Servers all the way, but not on the desktop. Instead, I opt for a Debian based distro, currently SimplyMEPIS 3.3.

One of the advantages of SimplyMEPIS is that it uses the RH init level structure (Debian makes 2-5 identical). This in turn allows the addition of a simple '2' or '3' to the kernel parameters at the bootloader screen. You can even add CLI options to the boot menu. You can't do this (easily) in plain Debian. If you have set it up to go directly to X, then the best debugging mode you can get is single user ('S' or '1'). Your other choice is to have Debian boot to the CLI & then start X manually. After all the mouse, keyboard, & other problems are solved; you can change your boot to go directly to X, or re-write the level 5 scripts to mimic the RH structure. Since X problems can always come up, I think is probably best & easiest to always start X manually. Maybe this is unnecessary, but I hate not being able to get to a full bash console when I need it.
 
Old 07-17-2005, 09:34 AM   #6
tmack8968
LQ Newbie
 
Registered: Jul 2005
Posts: 8

Original Poster
Rep: Reputation: 0
Thanks but I can't even get scroll lock to go on in my keyboard when KDM boots. I can't do ctrl+alt+backspace, or ctrl+alt+f1.. nothing happens.


I use Lilo to boot.. I tried putting in the debian CD and typing 'rescue', it boots, then suddenly it says 'kernal panic' and it says something about VPN (not exactly sure if that's right)

Is there any other method to get into the console?
 
Old 07-17-2005, 09:38 AM   #7
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
When you get to kdm try unplugging and plugging the keyboard. That sometimes works for me when my keyboard freezes.
 
Old 07-17-2005, 09:43 AM   #8
tmack8968
LQ Newbie
 
Registered: Jul 2005
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by adz
When you get to kdm try unplugging and plugging the keyboard. That sometimes works for me when my keyboard freezes.
Tried it. I have a PS/2 to USB converter, so I'm rebooting now to see if that'll work..
 
Old 07-17-2005, 09:47 AM   #9
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
No don't reboot. Just try it straightaway.
 
Old 07-17-2005, 09:51 AM   #10
tmack8968
LQ Newbie
 
Registered: Jul 2005
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by adz
No don't reboot. Just try it straightaway.
Tried it both ways.. doesn't work.
 
Old 07-17-2005, 09:37 PM   #11
tmack8968
LQ Newbie
 
Registered: Jul 2005
Posts: 8

Original Poster
Rep: Reputation: 0
Help? Anyone
 
Old 07-17-2005, 10:20 PM   #12
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
Well you can try booting with a rescue/liveCD and disabling kdm. Just copy /etc/init.d/kdm to /etc/init.d/kdm.<whatever> and it wont start up. Then you can try TigerOC's suggestion.

Which debian discs are you trying? Which kernel are you running?
 
Old 07-18-2005, 04:28 PM   #13
tmack8968
LQ Newbie
 
Registered: Jul 2005
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by adz
Well you can try booting with a rescue/liveCD and disabling kdm. Just copy /etc/init.d/kdm to /etc/init.d/kdm.<whatever> and it wont start up. Then you can try TigerOC's suggestion.

Which debian discs are you trying? Which kernel are you running?
Not exactly sure what discs.. it's the latests stable. I decided to give Gentoo a try.. so no more Debian.. although I've learn a lot about it

I might also upgrade the harddrive in the computer.. not sure if I want to yet. Thanks anyway.. Hopefully I won't need help with Gentoo :P
 
Old 07-18-2005, 09:27 PM   #14
ruddigger
LQ Newbie
 
Registered: Sep 2004
Distribution: Debian Sarge
Posts: 13

Rep: Reputation: 0
try booting into a console, from lilo type linux 2 or something like this (I haven't done this in a while so please fill in the blanks) I don't know how to do the same from grub, but there should be a way.
from there try reconfiguring the mouse keyboard in X (suggest google it first, it's a common issue around)
 
Old 07-19-2005, 06:16 PM   #15
ironjohn
LQ Newbie
 
Registered: Mar 2005
Location: Cornwall UK
Distribution: debian
Posts: 3

Rep: Reputation: 0
Just as an aside, I think it is very unwise to unplug ps2 connectors for either mouse or keyboard.
If you find that you are still having the same problem with a different distro then you might have to
consider that the motherboard has got damaged from unplugging ps2 devices whilst switched on.
Unplugging with usb should be fine as its a hot pluggable technology, so if you only unplugged whilst
using a ps2/usb convertor then ignor this reply
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Keyboard & Mouse doesn't work at all stitch23 Linux - Hardware 4 06-23-2005 03:20 PM
the keyboard and mouse can't work!! ayiiq180 Linux - Hardware 2 09-12-2004 09:08 AM
Problems with X. Keyboard/mouse won't work. FLOODS Slackware 1 05-13-2004 09:21 AM
Mouse and Keyboard won't work after install trmong Linux - Hardware 9 11-16-2003 11:38 PM
My mouse and keyboard dont work under X fatal Linux - General 4 06-08-2001 10:45 AM


All times are GMT -5. The time now is 04:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration