LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 05-20-2011, 06:01 PM   #1
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,436

Rep: Reputation: 83
mouse and keyboard are dead on X: Debian testing


Hya,

System Notebook, with Debian testing, with xfce.

Symptom Mouse and keyboard are dead on X. Keyboard is OK on console, mouse, ?? so two mice were checked, both dead.

So far Xorg.0.log reads: Hotplugging is on drivers kbd and mouse are disabled.

So, following this thread, hotplug is disabled. Then Xorg.0.log says that module kbd and mouse are missing...
However, xserver-xorg-input-kbd and -mouse DO exist, and corresponding modules DO sit under /usr/lib/xorg/modules.
And ati modules (which sit under /usr/lib/xorg/modules) are correctly loaded, so modules path is supposed to be good.
Then, completely lost, just hoping good star alignment, installed xserver-xorg-video-fbdev, (log says it is missing), things went well.

Even with fbdev, auto detecting does not work.

Workaround Disable autodetect, install fbdev

By the way This penguin is the same one as this.

Wish ListHow to turn auto detect back on? Does anybody know how to straighten out?

Closing remark Happy Penguins!
 
Old 05-20-2011, 07:03 PM   #2
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947
It's generally better to use evdev these days, instead of the old kbd & mouse drivers. It's designed to automatically handle all basic input devices. make sure you have it installed, and try switching to it if you're still configured for the old types.
 
Old 05-21-2011, 06:05 AM   #3
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,436

Original Poster
Rep: Reputation: 83
Hya,

Thanks for your comment.

Yes, I agree with you. But I do not know how to?

evdev is installed. under /usr/share/X11/, evdev rules exist. However, neither keyboard nor mouse is detected. (or disabled??)

I compared this one to other functioning Penguin. evdev rules are identical. I have not checked udev yet.

May be my penguin is not quite happy yet.
 
Old 05-21-2011, 08:53 AM   #4
odiseo77
Member
 
Registered: Dec 2004
Location: London, UK
Distribution: Debian Sid, OpenSUSE 13.1
Posts: 992

Rep: Reputation: 294Reputation: 294Reputation: 294
Hi, not sure if this will help, because it's a slightly different case: I did a fresh wheezy install a few days ago and my keyboard and mouse were unresponsive on X (I could use the keyboard on the virtual console, however). The solution was to remove the directory /run from the system (what I did was to move it inside /root, just in case, and reboot, then when I checked that everything was fine, I removed it). It's a bug with udev, if I'm not wrong.

Regards.
 
Old 05-22-2011, 04:18 AM   #5
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947
How are you configuring X? If you have an xorg.conf, then you need to check the section of it that configures your drivers, as shown in your archwiki link. It also tells you how you can check your current configuration by using:
"setxkbmap -print -verbose 10"

Other than that I really couldn't tell you offhand, as it's been a while since I've had to fool with it. I go conf-less these days and let X configure itself. I wasn't aware, for example, that they've created a new InputClass section to take over from InputDevice.
 
Old 05-22-2011, 05:17 PM   #6
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,436

Original Poster
Rep: Reputation: 83
Thanks for replies.

odiseo77: I tried your remedy. I regret to say, but it did not work. I guess you hit this bug. Now I know that I need to check something else.

David the H: Yes, I regret to say, but I use /etc/X11/xorg.conf and it IS functional.

cheers
 
Old 05-23-2011, 06:39 AM   #7
chexmix
Member
 
Registered: Apr 2002
Location: Arlington, MA
Distribution: Slackware, Debian, OpenBSD
Posts: 207
Blog Entries: 15

Rep: Reputation: 17
Quote:
Originally Posted by odiseo77 View Post
Hi, not sure if this will help, because it's a slightly different case: I did a fresh wheezy install a few days ago and my keyboard and mouse were unresponsive on X (I could use the keyboard on the virtual console, however). The solution was to remove the directory /run from the system (what I did was to move it inside /root, just in case, and reboot, then when I checked that everything was fine, I removed it). It's a bug with udev, if I'm not wrong.

Regards.
I installed wheezy and had the same trouble -- renamed /run to /old-run and now the system seems to work fine. I'm interested, though, what kind of impact renaming that directory might have ... can it just stay that way indefinitely?

/gb
 
Old 05-27-2011, 05:53 PM   #8
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,436

Original Poster
Rep: Reputation: 83
Dead again

Hya,

After dist-upgrade, mouse and keyboard are dead even with xorg.conf (auto add OFF).



Before dist-upgrade Xorg.log used to say:
Code:
[ 23244.805] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
.
.

[ 23249.774] (II) config/udev: Adding input device HID 04d9:2082 (/dev/input/mouse2)
[ 23249.775] (II) No input driver/identifier specified (ignoring)
[ 23249.778] (II) config/udev: Adding input device PS/2 Mouse (/dev/input/mouse0)
[ 23249.778] (II) No input driver/identifier specified (ignoring)
[ 23249.778] (II) config/udev: Adding input device AlpsPS/2 ALPS GlidePoint (/dev/input/mouse1)
So, I was trying to reconfigure udev, without any luck.

After dist-upgrade
Xorg.log says
Code:
[ 30314.116] (II) config/udev: Adding input device HID 04d9:2082 (/dev/input/mouse2)
[ 30314.117] (II) AutoAddDevices is off - not adding device.
[ 30314.144] (II) config/udev: Adding input device PS/2 Mouse (/dev/input/mouse0)
[ 30314.144] (II) AutoAddDevices is off - not adding device.
[ 30314.147] (II) config/udev: Adding input device AlpsPS/2 ALPS GlidePoint (/dev/input/mouse1)
And mouse and keyboard are dead!!

Without xorg.conf, mouse and keyboard are dead, and log looks like before dist-upgrade, (I have not yet checked line by line)

Symptom went worse, however, there is a clue among upgraded packages.
 
Old 05-28-2011, 01:14 AM   #9
jim_p
Member
 
Registered: Aug 2009
Distribution: Debian testing
Posts: 483

Rep: Reputation: 108Reputation: 108
Make a simple xorg.conf and add these
Code:
Section "ServerFlags"
        Option "AutoAddDevices" "1"
EndSection
 
Old 05-28-2011, 06:15 AM   #10
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,436

Original Poster
Rep: Reputation: 83
Hya,

Thanks jim p.

I made three line xorg.conf, and regret to say but mouse and keyboard are dead.

Log says that no input driver/identifier specified, ignoring.

regards
 
Old 06-02-2011, 05:35 AM   #11
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,436

Original Poster
Rep: Reputation: 83
Hya,

After update (about a week interval after post #8), the workaround posted in #1 works again.

Checking with udevadm, I somewhat think that the problem resides in evdev, (not sure yet).

cheers
 
Old 06-02-2011, 02:55 PM   #12
jeremy-passarelli
LQ Newbie
 
Registered: May 2011
Location: USA
Distribution: Chakra
Posts: 17

Rep: Reputation: 10
Try reinstalling Xorg and what will happen.
 
Old 06-12-2011, 06:24 PM   #13
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,436

Original Poster
Rep: Reputation: 83
Hya

Apology for delay.

I have tried to reinstall xorg, evdev and udev. So far, no luck.

cheers
 
Old 06-13-2011, 04:53 AM   #14
cynwulf
Senior Member
 
Registered: Apr 2005
Distribution: OpenBSD, FreeBSD
Posts: 1,284

Rep: Reputation: Disabled
There is a thread at forums.debian.net - seems like a similar issue: http://forums.debian.net/viewtopic.php?f=6&t=64927

And another: http://forums.debian.net/viewtopic.php?f=7&t=62880

Last edited by cynwulf; 06-13-2011 at 05:15 AM. Reason: update
 
Old 06-22-2011, 08:15 AM   #15
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,436

Original Poster
Rep: Reputation: 83
Hya,

So far, current udev (171-1) and new kernel 2.6.39, still no luck.

cheers

I have not tried to downgraded udev as the thread by Caravel.
 
  


Reply

Tags
evdev, keyboard, mouse, udev, xorg


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] mouse and keyboard not working debian squeeze with kde mf93 Linux - Hardware 7 02-02-2010 06:26 AM
debian testing vs debian stable with testing repositories? wanas Debian 5 02-28-2009 10:23 PM
Dead mouse and keyboard after update of SUSE 10.0 tjw Linux - Software 2 11-22-2005 05:56 AM
Debian - can't use keyboard/mouse Gnome 1jamie Debian 2 09-13-2004 12:40 PM
My USB keyboard and mouse no work in kernel 2.6+ (Debian) 0x86 Linux - Software 5 08-01-2004 12:22 PM


All times are GMT -5. The time now is 05:01 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration