LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   mouse and keyboard are dead on X: Debian testing (http://www.linuxquestions.org/questions/debian-26/mouse-and-keyboard-are-dead-on-x-debian-testing-881873/)

kaz2100 05-20-2011 06:01 PM

mouse and keyboard are dead on X: Debian testing
 
Hya,

System Notebook, with Debian testing, with xfce.

Symptom Mouse and keyboard are dead on X. Keyboard is OK on console, mouse, ?? so two mice were checked, both dead.

So far Xorg.0.log reads: Hotplugging is on drivers kbd and mouse are disabled.

So, following this thread, hotplug is disabled. Then Xorg.0.log says that module kbd and mouse are missing...
However, xserver-xorg-input-kbd and -mouse DO exist, and corresponding modules DO sit under /usr/lib/xorg/modules.
And ati modules (which sit under /usr/lib/xorg/modules) are correctly loaded, so modules path is supposed to be good.
Then, completely lost, just hoping good star alignment, installed xserver-xorg-video-fbdev, (log says it is missing), things went well.

Even with fbdev, auto detecting does not work.

Workaround Disable autodetect, install fbdev

By the way This penguin is the same one as this.

Wish ListHow to turn auto detect back on? Does anybody know how to straighten out?

Closing remark Happy Penguins!

David the H. 05-20-2011 07:03 PM

It's generally better to use evdev these days, instead of the old kbd & mouse drivers. It's designed to automatically handle all basic input devices. make sure you have it installed, and try switching to it if you're still configured for the old types.

kaz2100 05-21-2011 06:05 AM

Hya,

Thanks for your comment.

Yes, I agree with you. But I do not know how to?

evdev is installed. under /usr/share/X11/, evdev rules exist. However, neither keyboard nor mouse is detected. (or disabled??)

I compared this one to other functioning Penguin. evdev rules are identical. I have not checked udev yet.

May be my penguin is not quite happy yet.

odiseo77 05-21-2011 08:53 AM

Hi, not sure if this will help, because it's a slightly different case: I did a fresh wheezy install a few days ago and my keyboard and mouse were unresponsive on X (I could use the keyboard on the virtual console, however). The solution was to remove the directory /run from the system (what I did was to move it inside /root, just in case, and reboot, then when I checked that everything was fine, I removed it). It's a bug with udev, if I'm not wrong.

Regards.

David the H. 05-22-2011 04:18 AM

How are you configuring X? If you have an xorg.conf, then you need to check the section of it that configures your drivers, as shown in your archwiki link. It also tells you how you can check your current configuration by using:
"setxkbmap -print -verbose 10"

Other than that I really couldn't tell you offhand, as it's been a while since I've had to fool with it. I go conf-less these days and let X configure itself. I wasn't aware, for example, that they've created a new InputClass section to take over from InputDevice.

kaz2100 05-22-2011 05:17 PM

Thanks for replies.

odiseo77: I tried your remedy. I regret to say, but it did not work. I guess you hit this bug. Now I know that I need to check something else.

David the H: Yes, I regret to say, but I use /etc/X11/xorg.conf and it IS functional.

cheers

chexmix 05-23-2011 06:39 AM

Quote:

Originally Posted by odiseo77 (Post 4362855)
Hi, not sure if this will help, because it's a slightly different case: I did a fresh wheezy install a few days ago and my keyboard and mouse were unresponsive on X (I could use the keyboard on the virtual console, however). The solution was to remove the directory /run from the system (what I did was to move it inside /root, just in case, and reboot, then when I checked that everything was fine, I removed it). It's a bug with udev, if I'm not wrong.

Regards.

I installed wheezy and had the same trouble -- renamed /run to /old-run and now the system seems to work fine. I'm interested, though, what kind of impact renaming that directory might have ... can it just stay that way indefinitely?

/gb

kaz2100 05-27-2011 05:53 PM

Dead again
 
Hya,

After dist-upgrade, mouse and keyboard are dead even with xorg.conf (auto add OFF).



Before dist-upgrade Xorg.log used to say:
Code:

[ 23244.805] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
.
.

[ 23249.774] (II) config/udev: Adding input device HID 04d9:2082 (/dev/input/mouse2)
[ 23249.775] (II) No input driver/identifier specified (ignoring)
[ 23249.778] (II) config/udev: Adding input device PS/2 Mouse (/dev/input/mouse0)
[ 23249.778] (II) No input driver/identifier specified (ignoring)
[ 23249.778] (II) config/udev: Adding input device AlpsPS/2 ALPS GlidePoint (/dev/input/mouse1)

So, I was trying to reconfigure udev, without any luck.

After dist-upgrade
Xorg.log says
Code:

[ 30314.116] (II) config/udev: Adding input device HID 04d9:2082 (/dev/input/mouse2)
[ 30314.117] (II) AutoAddDevices is off - not adding device.
[ 30314.144] (II) config/udev: Adding input device PS/2 Mouse (/dev/input/mouse0)
[ 30314.144] (II) AutoAddDevices is off - not adding device.
[ 30314.147] (II) config/udev: Adding input device AlpsPS/2 ALPS GlidePoint (/dev/input/mouse1)

And mouse and keyboard are dead!!

Without xorg.conf, mouse and keyboard are dead, and log looks like before dist-upgrade, (I have not yet checked line by line)

Symptom went worse, however, there is a clue among upgraded packages.

jim_p 05-28-2011 01:14 AM

Make a simple xorg.conf and add these
Code:

Section "ServerFlags"
        Option "AutoAddDevices" "1"
EndSection


kaz2100 05-28-2011 06:15 AM

Hya,

Thanks jim p.

I made three line xorg.conf, and regret to say but mouse and keyboard are dead.

Log says that no input driver/identifier specified, ignoring.

regards

kaz2100 06-02-2011 05:35 AM

Hya,

After update (about a week interval after post #8), the workaround posted in #1 works again.

Checking with udevadm, I somewhat think that the problem resides in evdev, (not sure yet).

cheers

jeremy-passarelli 06-02-2011 02:55 PM

Try reinstalling Xorg and what will happen.

kaz2100 06-12-2011 06:24 PM

Hya

Apology for delay.

I have tried to reinstall xorg, evdev and udev. So far, no luck.

cheers

cynwulf 06-13-2011 04:53 AM

There is a thread at forums.debian.net - seems like a similar issue: http://forums.debian.net/viewtopic.php?f=6&t=64927

And another: http://forums.debian.net/viewtopic.php?f=7&t=62880

kaz2100 06-22-2011 08:15 AM

Hya,

So far, current udev (171-1) and new kernel 2.6.39, still no luck.

cheers

I have not tried to downgraded udev as the thread by Caravel.


All times are GMT -5. The time now is 06:04 PM.