LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 03-07-2006, 08:24 PM   #1
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Rep: Reputation: 48
mount: unknown filesystem type 'devfs' error


hi,

Recently I noticed the following messages during the bootup on my Debian etch(2.6.13) installation

Code:
mount: unknown filesystem type 'devfs'
umount: devfs: not mounted
Alhtough the system boots fine and everything works ok, why I am getting these error messages?

Is this because I installed udev on my system couple of weeks back?

Also do I need to uninstall devfs after installing udev?

Thanks
 
Old 03-07-2006, 09:54 PM   #2
cs-cam
Senior Member
 
Registered: May 2004
Location: Australia
Distribution: Gentoo
Posts: 3,544
Blog Entries: 4

Rep: Reputation: 56
I'd say yeah, Udev replaces devfs. Remove the instances of devfs in your fstab and make sure that udev is started on boot and you should be fine
 
Old 03-07-2006, 10:36 PM   #3
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Original Poster
Rep: Reputation: 48
Quote:
Originally Posted by cs-cam
I'd say yeah, Udev replaces devfs. Remove the instances of devfs in your fstab and make sure that udev is started on boot and you should be fine
Thank you so much for looking into this.

How do I remove the instance of devfs from my fstab file. Here is my fstab file
Code:
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hda1       /               ext3    defaults,errors=remount-ro 0       1
/dev/hdb        /media/cdrom0   iso9660 ro,user,auto    0       0
/dev/sda	/media/usb0	vfat	rw,user,auto	1	2
Thanks...

ALso I think udev is started on boot.
 
Old 03-07-2006, 10:47 PM   #4
dracae
Member
 
Registered: Feb 2006
Location: Oklahoma
Distribution: Debian Sid and Etch
Posts: 423

Rep: Reputation: 30
add devfs=nomount to you kernel command line (grub.conf|lilo.conf)
 
Old 03-08-2006, 01:45 AM   #5
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Original Poster
Rep: Reputation: 48
Quote:
Originally Posted by dracae
add devfs=nomount to you kernel command line (grub.conf|lilo.conf)
Thanks dracae. Do I have to give this kernel parameter because the module for devfs is compiled into the kernel?
 
Old 03-08-2006, 02:48 AM   #6
kevkim55
Member
 
Registered: Dec 2005
Location: Edmonton
Distribution: BLFS, Gentoo
Posts: 353

Rep: Reputation: 32
Recompile your kernel with support for udev but, not for devfs thus removing any references to devfs in kernel. That you'd do if you're really bothered about the error mesage and are willing to venture into a recompile.
 
Old 03-08-2006, 02:56 AM   #7
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Original Poster
Rep: Reputation: 48
Quote:
Originally Posted by kevkim55
Recompile your kernel with support for udev but, not for devfs thus removing any references to devfs in kernel. That you'd do if you're really bothered about the error mesage and are willing to venture into a recompile.
Well I will go with the option of giving kernel parameter. Based on your above reply, I am curious to know that if udev is not compiled into my kernel and then how come I am able to run udev in my current installation.

Thanks
 
Old 03-08-2006, 09:02 AM   #8
cs-cam
Senior Member
 
Registered: May 2004
Location: Australia
Distribution: Gentoo
Posts: 3,544
Blog Entries: 4

Rep: Reputation: 56
Udev isn't a kernel module, up until the most recent version it ran entirely in userspace. The new Udev however depends on a uevent kernel module that has been introduced in 2.6.15.
 
Old 03-08-2006, 11:09 AM   #9
biosedit
LQ Newbie
 
Registered: Nov 2005
Posts: 9

Rep: Reputation: 0
I guess you are not choice when compile the new kernel,
 
Old 03-08-2006, 12:57 PM   #10
noxious
Member
 
Registered: May 2004
Location: Ohio, USA
Distribution: LinuxMint Gloria, Ubuntu 9.10
Posts: 299

Rep: Reputation: 30
I had the same question, actually...


Quote:
Originally Posted by dracae
add devfs=nomount to you kernel command line (grub.conf|lilo.conf)

Did this work?
 
Old 03-08-2006, 05:33 PM   #11
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Original Poster
Rep: Reputation: 48
Quote:
Originally Posted by noxious
I had the same question, actually...
Did this work?
No it did not work. I tried giving devfs=nomount. It still shows those messages.

Anyone?
 
Old 03-09-2006, 06:46 PM   #12
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Original Poster
Rep: Reputation: 48
Quote:
Originally Posted by kushalkoolwal
No it did not work. I tried giving devfs=nomount. It still shows those messages.

Anyone?
Anyone???
 
Old 03-09-2006, 07:20 PM   #13
dracae
Member
 
Registered: Feb 2006
Location: Oklahoma
Distribution: Debian Sid and Etch
Posts: 423

Rep: Reputation: 30
dpkg -P devfsd
 
Old 03-10-2006, 08:40 PM   #14
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Original Poster
Rep: Reputation: 48
Quote:
Originally Posted by dracae
dpkg -P devfsd
Still it does not work. I mean there isn't any package called devfsd installed.

Last edited by kushalkoolwal; 03-10-2006 at 08:47 PM.
 
Old 03-12-2006, 04:10 AM   #15
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Original Poster
Rep: Reputation: 48
Quote:
Originally Posted by kushalkoolwal
Still it does not work. I mean there isn't any package called devfsd installed.

Anyone?????
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mount: unknown filesystem type 'ntfs' when trying to mount windows drive... DiZASTiX Linux - Hardware 12 09-28-2008 08:29 PM
Unknown filesystem devfs ioan123 Linux - Software 4 11-23-2005 08:24 PM
mount: unknown filesystem type 'NTFS' jnorcal Slackware 8 09-07-2005 07:18 PM
mount: unknown filesystem type 'ntfs' lowrida Linux - Newbie 3 08-01-2005 05:02 PM
root (hd 0,0)Filesystem type unknown, partition type 0x7chainloader +1 ece30675 Linux - Distributions 5 07-20-2004 10:04 AM


All times are GMT -5. The time now is 05:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration