LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 01-29-2012, 05:06 PM   #1
menthor
LQ Newbie
 
Registered: Jun 2010
Posts: 4

Rep: Reputation: 0
mount ntfs with fstab dmask=027,fmask=137 but no write access


My /etc/fstab looks like this:
Code:
UUID=XXXXXXXXXXXXXXXX   /media/sda1     ntfs    auto,gid=test,dmask=027,fmask=137      0       0
UUID=XXXXXXXXXXXXXXXX   /media/sda5     ntfs    auto,gid=test,dmask=027,fmask=137      0       0
UUID=XXXXXXXXXXXXXXXX   /media/sda6     ntfs    auto,gid=test,dmask=027,fmask=137      0       0
So far so good but when I do
Code:
ls -l /media
I get:
Code:
dr-xr-x--- 1 root test 4096 Jan  2 23:11 sda1
dr-xr-x--- 1 root test 8192 Apr  2  2011 sda5
dr-xr-x--- 1 root test 4096 Apr  2  2011 sda6
Why does root not receive write access?
Even when I change the dmask and fmask to
Code:
dmask=000,fmask=000
I get:
Code:
dr-xr-xr-x 1 root test 4096 Jan  2 23:11 sda1
But still no write acces. Am I missing something?
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 01-29-2012, 05:16 PM   #2
odiseo77
Senior Member
 
Registered: Dec 2004
Location: London, UK
Distribution: Debian Sid, OpenSUSE 13.1
Posts: 1,016

Rep: Reputation: 314Reputation: 314Reputation: 314Reputation: 314
Hi,

You need to install the ntfs-3g package from the repositories (it's the ntfs read/write driver), and in the file system type column, change "ntfs" for "ntfs-3g" (without the quotes). This way, you will tell fstab to use the ntfs-3g driver, instead of the kernel generic one.

Cheers.
 
2 members found this post helpful.
Old 01-29-2012, 05:35 PM   #3
menthor
LQ Newbie
 
Registered: Jun 2010
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by odiseo77 View Post
Hi,

You need to install the ntfs-3g package from the repositories (it's the ntfs read/write driver), and in the file system type column, change "ntfs" for "ntfs-3g" (without the quotes). This way, you will tell fstab to use the ntfs-3g driver, instead of the kernel generic one.

Cheers.
I did as you said, but now only one of the 3 partitions is mounted with write access.
edit: I just restarted and now all of them have write access.
Thank you
 
Old 01-29-2012, 05:56 PM   #4
widget
Senior Member
 
Registered: Oct 2008
Location: S.E. Montana
Distribution: Debian Testing, Stable, Sid and Manjaro, Mageia 3, LMDE
Posts: 2,297

Rep: Reputation: 388Reputation: 388Reputation: 388Reputation: 388
Mark this puppy solved. You do that in Forum tools at the top of the page.

This is a common problem and anyone smart enough to use a forum search will be happy to find a thread marked Solved.
 
  


Reply

Tags
fstab, mount, ntfs, permission


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HAL and fmask dmask in automounting ntfs-3g drives duryodhan Slackware 2 09-23-2008 03:42 PM
Why is fmask & dmask required to write to a WinXP share mounted on Mdrake SMB client ruscook_oz Linux - Networking 1 02-08-2007 06:50 PM
getting fat32 (Win98SE) part to mount with dmask and fmask options Simon Bridge Linux - General 3 06-22-2005 02:50 AM
dmask=,fmask=,umask= ARGHHHHHHH mickboda Linux - General 1 03-16-2004 05:32 AM
umask,dmask,fmask mmm Linux - General 1 08-14-2003 01:29 AM


All times are GMT -5. The time now is 07:27 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration