LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   mount and umount problem (http://www.linuxquestions.org/questions/debian-26/mount-and-umount-problem-319563/)

salahuddin_66 05-02-2005 11:14 PM

mount and umount problem
 
hello


yesterday while i was writing cd's in k3b when after write i open one file from cd with kaffeine and then kde can't umount the cdrom

then i logoff and try but did now work. So i give umount as root. aftert that users can't mount any thing :(

i wanna know ? is the******* default ****** permission of /bin/mount and /bin/umount

how i can do it with chmod or other that so that all the users can mount and umount my fstab is (should i move the user to users)

Code:

# /etc/fstab: static file system information.
#
# <file system> <mount point>  <type>  <options>      <dump>  <pass>
proc            /proc          proc    defaults        0      0
/dev/hda7      /              reiserfs notail          0      1
/dev/hda6      none            swap    sw              0      0
/dev/hdd        /media/cdrom0  iso9660 ro,user,noauto  0      0
/dev/hdc        /media/cdrom1  iso9660 ro,user,noauto  0      0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0      0
/dev/hda1      /media/c        vfat    rw,user,noauto  0      0
/dev/hda5      /media/d        vfat    rw,user,noauto  0      0

thanx

jonr 05-02-2005 11:40 PM

The default ownership of mount and umount is by root.

If you are the only user, I see no reason not to change ownership and permissions of mount and umount if you really want to, but if you're running a network with more than one user I believe it would be a bad idea.

Another approach would be to set up sudo (see man sudo) so that you can temporarily do things as root, and then fall back into your normal, and safer, user mode after the actions are completed. That's what I generally do.

If you are the only user and want to be able to mount and umount as that normal user, you would do, as root (and assuming here your user name is salahuddin):

Code:

chown salahuddin:salahuddin /bin/mount
(and the same for umount)

then, still as root:

Code:

chmod u+rxw /bin/mount
(and the same for umount)

Sometimes a device is reported to still be in a busy state even when you're through with it, and refuses to unmount. In that case you can issue umount -l [device name] and successfully unmount it. The "l" stands for "lazy." (See man umount.)

I personally would not change the ownership or permissions on mount and umount, but would use sudo instead.

salahuddin_66 05-03-2005 06:11 AM

ya now it is set to root

but still i can't mount any cdrom or other windows drive as user with kde and also

mount /media/c

mount /media/cdrom1 no permission :(

is there any soloution to enable it for user i have give the command but it is still not working

thanx

salahuddin_66 05-03-2005 08:49 AM

solve after give

chmod u+s /bin/umount

thanx to jonr and google


All times are GMT -5. The time now is 08:56 AM.