LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 08-30-2008, 01:59 AM   #1
max_mad
LQ Newbie
 
Registered: Sep 2005
Distribution: SuSE Linux 9.3
Posts: 21

Rep: Reputation: 15
modprobe snd-cs46xx error ALSA 1.0.17 with kernel 2.6.26-1-686


Lenny
alsa-driver-1.0.17
Kernel 2.6.26-1-686
Cirrus Logic cs46xx

Hello

*for the previous kernel 2.6.25-2-686 I could compile the audiodrivers without problems. After kernel-update 2.6.26-1-686 I repeated the same procedure without errors except the last step
modprobe snd-cs46xx

Following errors are given back:

WARNING: Error inserting snd_ac97_codec
(/lib/modules/2.6.26-1-686/kernel/sound/pci/ac97/snd-ac97-codec.ko): Unknown
symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_ac97_codec
(/lib/modules/2.6.26-1-686/kernel/sound/pci/ac97/snd-ac97-codec.ko): Unknown
symbol in module, or unknown parameter (see dmesg)
FATAL: Error inserting snd_cs46xx
(/lib/modules/2.6.26-1-686/kernel/sound/pci/cs46xx/snd-cs46xx.ko): Unknown
symbol in module, or unknown parameter (see dmesg)
FATAL: Error running install command for snd_cs46xx


DMESG reports:

[ *725.576042] snd_ac97_codec: Unknown symbol snd_verbose_printk
[ *725.636698] snd_ac97_codec: Unknown symbol snd_verbose_printk
[ *725.641998] snd_cs46xx: Unknown symbol snd_ac97_write_cache
[ *725.642113] snd_cs46xx: Unknown symbol snd_ac97_resume
[ *725.642533] snd_cs46xx: Unknown symbol snd_ac97_update_bits
[ *725.642585] snd_cs46xx: Unknown symbol snd_ac97_mixer
[ *725.642656] snd_cs46xx: Unknown symbol snd_ac97_bus
[ *725.642762] snd_cs46xx: Unknown symbol snd_verbose_printk
[ *725.642989] snd_cs46xx: Unknown symbol snd_ac97_suspend
[ *725.643912] snd_cs46xx: Unknown symbol snd_ac97_write
[ *725.643964] snd_cs46xx: Unknown symbol snd_ac97_read


In lib/modules/2.6.26-1-686/modules.dep no snd_* is found.

No success with depmod -a 'uname -r', no further messages.

In /lib/modules/2.6.26-1-686 there is a file
!build
but I cannot read it.

What can I do to make my soundcard work with ALSA?


Thank you for helping
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
modprobe snd-usb-audio error abunsair Debian 5 07-08-2005 06:41 PM
ALSA: modprobe: Can't locate module snd eegeerg Slackware 3 04-25-2004 01:14 AM
snd-cs46xx driver loading failure drkfir5 Linux - Software 0 03-01-2004 02:28 AM
alsa : unable to modprobe snd-emu10k1 sanjiv Linux - Hardware 6 11-30-2003 11:31 PM
Installing ALSA and snd-enu10k1 modprobe errors angel666 Linux - Newbie 5 11-16-2003 12:02 PM


All times are GMT -5. The time now is 12:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration