LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 08-04-2004, 03:23 AM   #1
uk_dave
LQ Newbie
 
Registered: Aug 2004
Location: Suffolk, England
Distribution: Debian, Ubuntu
Posts: 21

Rep: Reputation: 15
Unhappy Missing tux logo in Sarge?


Hi,
I have been running Debian Woody for a while now. I had the line "vga=791" in my lilo.conf file so my console was running in 1024x768 and I got a cute Tux logo in the corner as my system booted.

Yesterday though, I did a fresh install Debian Sarge onto the same system and I was rather surprised to find that I no longer get the Tux logo at bootup! I added the "vga=791" line back into /boot/grub/menu.lst to get my nice 1024x768 console back which worked, but I still don't get a Tux logo!

Is there an easy fix for this, or do I need to recompile the kernel and enable some special option? This would seem a little strange though if an experimatal option was enabled in an older version of Debian but not a newer one.

Once I have my tux logo back I then want to install teh boot-icons package which I discovered whilst Googling on how to get my Tux logo back!

- David

Last edited by uk_dave; 08-04-2004 at 03:40 AM.
 
Old 08-04-2004, 05:08 AM   #2
Frustin
Member
 
Registered: May 2002
Location: Essex, UK
Distribution: Debian, Redhat, AIX 5L
Posts: 512

Rep: Reputation: 30
well you will only get the logo if you have framebuffers installed in your kernel.
 
Old 08-04-2004, 09:17 AM   #3
uk_dave
LQ Newbie
 
Registered: Aug 2004
Location: Suffolk, England
Distribution: Debian, Ubuntu
Posts: 21

Original Poster
Rep: Reputation: 15
Well it's switching to 1024x768 when it boots up and the output from dmesg is:

vesafb: framebuffer at 0xe1800000, mapped to 0xc801b000, size 3072k
vesafb: mode is 1024x768x16, linelength=2048, pages=4
vesafb: protected mode interface info at c000:7dac
vesafb: scrolling: redraw
vesafb: directcolor: size=0:5:6:5, shift=0:11:5:0

Also, I installed the boot-icons package anyway and as the system boots the various icons appear at the top of the screen, however the text soon overwrites them and covers them up.
 
Old 08-04-2004, 10:08 AM   #4
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,176

Rep: Reputation: 54
The reason is because the boot logo is disabled in the Debian kernel configuration. To fix it, you will have to recompile your kernel I'm afraid. When you get to configuring the kernel, you will have to enable the boot logo before compiling. I added the Debian boot logo instead of tux on my kernel. I described how I did it here: http://www.linuxquestions.org/questi...hreadid=206992
 
Old 08-04-2004, 11:19 AM   #5
uk_dave
LQ Newbie
 
Registered: Aug 2004
Location: Suffolk, England
Distribution: Debian, Ubuntu
Posts: 21

Original Poster
Rep: Reputation: 15
Cheers for the reply. I was fearing i might have to recompile my kernel (i've had some bad experiences in the past), but I'll have a go and see if I can get it to work.
 
Old 08-04-2004, 06:51 PM   #6
uk_dave
LQ Newbie
 
Registered: Aug 2004
Location: Suffolk, England
Distribution: Debian, Ubuntu
Posts: 21

Original Poster
Rep: Reputation: 15
I started trying to recompile my kernel to get the tux/debian logo. Your guide is for the 2.6 kernel, but I am still using 2.4.25. I managed to download the kernel-source and debian logo patch, and then patch my kernel. I also copied the config file from /boot. Your instructions then say to run "make menuconfig" and go to the frame buffer driver section. I've done this, but I don't see any options for logos, though there are lots of modules for fb console drivers! I've had a hunt around some of the other menus but still cant find anything. Where am I supposed to look for the logo configuration?
 
Old 08-04-2004, 10:17 PM   #7
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,176

Rep: Reputation: 54
I think for the 2.4.x kernels you just need to enable the framebuffer. The boot logo will be there automatically. The configuration is different with the 2.6.x kernels, where you do have an option to turn the boot logo on or off.
 
Old 08-05-2004, 03:07 AM   #8
uk_dave
LQ Newbie
 
Registered: Aug 2004
Location: Suffolk, England
Distribution: Debian, Ubuntu
Posts: 21

Original Poster
Rep: Reputation: 15
Thanks for the reply. I'll try that, however. I am slightly confused - When my system boots up I says stuff about using the Vesa frame buffer (see output of dmesg above), and also I copied the config file from /boot to /usr/src/linux and make menuconfig shows that all the framebuffer support is enabled. I thought the Tux logo was supposed to appear by default with a framebuffer console?

Either way I'll try recompiling and see what happens...

Last edited by uk_dave; 08-05-2004 at 03:12 AM.
 
Old 08-05-2004, 08:25 AM   #9
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,176

Rep: Reputation: 54
Well, I guess my two answers are incongruent. Sorry. I was thinking of the 2.6 kernel which has the option to turn the boot logo on or of in the configuration. The default debian configuration has it turned off. For the 2.4 kernel, I checked and I don't see the same option. Therefore, I think the boot logo should always appear if the framebuffer support is working. Did you notice that the boot messages have smaller font sizes when you increase the resolution?
 
Old 08-05-2004, 04:35 PM   #10
uk_dave
LQ Newbie
 
Registered: Aug 2004
Location: Suffolk, England
Distribution: Debian, Ubuntu
Posts: 21

Original Poster
Rep: Reputation: 15
I am currently recompiling my kernel which I have patched with the debian-logo patch. Apart from that I am using the original config file copied from /boot, so we shall have to wait and see if it works.

Currently I am using the original debian 2.4.25 kernel. When I installed Debian Sarge it used what ever the default console mode is. As not much could be fitted on the screen I added "vga=791" to my grub config and this then gave me a console at 1024x768 so the text was much smaller but there were more lines on the screen.

As I understand it that is a framebuffer console isn't it? Or am I completly misunderstanding this? If this is a framebuffer console then where is Tux? You say the the tux logo should be there by default with a framebuffer console and the help text for the Vesa Framebuffer driver also states that, so I am a bit confused!

Once my kernel has recompiled I'm sure all will be come clear (hopefully).
 
Old 08-05-2004, 04:43 PM   #11
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,176

Rep: Reputation: 54
If your text got a lot smaller upon adding the vga= line, it means the framebuffer is working. As to where tux is, I don't know. Hopefully adding the debian patch will fix things up, or someone else reading this may have an answer. Good luck!
 
Old 08-05-2004, 05:27 PM   #12
littlemidget
Member
 
Registered: Aug 2004
Location: Oslo, Norway.
Distribution: Debian Sarge
Posts: 171

Rep: Reputation: 30
Re: Missing tux logo in Sarge?

Quote:
Originally posted by uk_dave
I added the "vga=791" line back into /boot/grub/menu.lst to get my nice 1024x768 console back which worked, but I still don't get a Tux logo!
.. I tried to put that into my /boot/grub/menu.lst - but it didn't work. I didn't get a nice 1024x768 console. Maybe i put the line in the wrong place? Could you tell me where in /boot/grub/menu.lst you have your "vga=791"? :-)
 
Old 08-05-2004, 05:42 PM   #13
uk_dave
LQ Newbie
 
Registered: Aug 2004
Location: Suffolk, England
Distribution: Debian, Ubuntu
Posts: 21

Original Poster
Rep: Reputation: 15
Here's where's the section from my /boot/grub/menu.lst file:

Code:
title           Debian GNU/Linux, kernel 2.4.25-1-386 
root            (hd0,0)
kernel          /boot/vmlinuz-2.4.25-1-386 root=/dev/hda1 ro vga=791 
initrd          /boot/initrd.img-2.4.25-1-386
savedefault
boot
 
Old 08-05-2004, 05:57 PM   #14
littlemidget
Member
 
Registered: Aug 2004
Location: Oslo, Norway.
Distribution: Debian Sarge
Posts: 171

Rep: Reputation: 30
thanks, uk_dave :-)

If anyone knows how to get tux up in that corner without having to recompile, then i would be really glad to hear about it :-P
 
Old 08-05-2004, 10:00 PM   #15
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,016

Rep: Reputation: 51
in lilo.conf:

# Specifies the VGA text mode at boot time. (normal, extended, ask, <mode>)
#
# vga=ask
# vga=791
vga=normal

Hehe, i'm the opposite, i don't like the framebuffer
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
change tux logo Tuttle General 17 11-27-2005 07:15 PM
Missing Samba in Sarge S.R. Noble Debian 5 11-05-2005 10:50 AM
Change Suse Logo to KDE Logo little_penguin Suse/Novell 2 04-05-2005 06:35 PM
sarge installer - missing udeb? mmboydell Debian 3 07-19-2003 05:31 PM
kernel recompiled successfully... though now tux is missing :( slackfan Slackware 6 02-14-2003 09:07 PM


All times are GMT -5. The time now is 03:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration