LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 03-16-2013, 07:57 AM   #1
blastradius
Member
 
Registered: Oct 2004
Location: Cheshire, England
Distribution: Debian Stable
Posts: 269

Rep: Reputation: 39
Missing hot corner in Wheezy


I installed Squeeze and then upgraded to Wheezy, I had tried Fedora previously (before sanity returned) and I did like the Gnome 3 hot corner but it doesn't seem to be there on my new Debian desktop (see attached), I have 'applications' and 'Places' text top left and hovering over the application text just does nothing
Attached Images
File Type: png Screenshot from 2013-03-16 12:46:53.png (83.6 KB, 21 views)
 
Old 03-16-2013, 12:19 PM   #2
widget
Senior Member
 
Registered: Oct 2008
Location: S.E. Montana
Distribution: Debian Testing, Stable, Sid and Manjaro, Mageia 3, LMDE
Posts: 2,200

Rep: Reputation: 368Reputation: 368Reputation: 368Reputation: 368
Reboot.

At login screen check your session button. I think you are not in Gnome Shell although I could be wrong as I can't stand it and haven't looked at it for sometime.

When you are booting and get to the login screen does the cursor go to the upper left corner of the screen?

Do you have the package firmware-linux-nonfree installed?
 
Old 03-17-2013, 03:06 AM   #3
blastradius
Member
 
Registered: Oct 2004
Location: Cheshire, England
Distribution: Debian Stable
Posts: 269

Original Poster
Rep: Reputation: 39
Weird, the options I have at login are -

Gnome
Gnome Classic
System Default
TWM

I thought 'Gnome' would be the shell. I also thought that Debian would install Gnome Shell by default.

N.b. just checked and the shell is installed so has the hot corner been switched off somehow?
 
Old 03-17-2013, 08:40 AM   #4
goumba
Member
 
Registered: Dec 2009
Location: New Jersey, USA
Distribution: Debian Wheezy (7.0), Jessie (future 8) and Sid (unstable)
Posts: 518
Blog Entries: 3

Rep: Reputation: 55
That is the fallback mode, a.k.a. "GNOME Classic". Try logging in using the "GNOME" session, and if your hardware supports it, you're set. If not, it will throw you back into fallback mode and tell you shell is not supported on your hardware.

I would have assumed that it would have tried to start to Shell as it has for me in the past. I have never been logged into a fallback session without an error message first.

Quote:
Originally Posted by widget View Post
Reboot.
Do you have the package firmware-linux-nonfree installed?
I don't know if firmware-nonfree is necessary, as no hardware was mentioned here.
 
Old 03-18-2013, 01:06 AM   #5
EDDY1
Guru
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 5,242

Rep: Reputation: 466Reputation: 466Reputation: 466Reputation: 466Reputation: 466
Quote:
Originally Posted by blastradius View Post
I installed Squeeze and then upgraded to Wheezy, I had tried Fedora previously (before sanity returned) and I did like the Gnome 3 hot corner but it doesn't seem to be there on my new Debian desktop (see attached), I have 'applications' and 'Places' text top left and hovering over the application text just does nothing
The only time I've had the problem was with the older graphics.
What graphic is your machine running?
 
Old 03-18-2013, 02:12 AM   #6
blastradius
Member
 
Registered: Oct 2004
Location: Cheshire, England
Distribution: Debian Stable
Posts: 269

Original Poster
Rep: Reputation: 39
Problem solved

Hi

I introduced myself to the Debian IRC channel and some very helpful users on there help me sort the problem, I tried restarting the Gnome shell first with a 'replace' command in the terminal but this sent the desktop crazy, turned out that I just had to amend the sources.list and install some additional packages, then restarted the Gnome-shell again and it's all good now.

Thanks for your help and suggestions.

---------- Post added 03-18-13 at 07:13 AM ----------

How do I close this thread?
 
Old 03-18-2013, 04:24 AM   #7
widget
Senior Member
 
Registered: Oct 2008
Location: S.E. Montana
Distribution: Debian Testing, Stable, Sid and Manjaro, Mageia 3, LMDE
Posts: 2,200

Rep: Reputation: 368Reputation: 368Reputation: 368Reputation: 368
A good start would be to tell folks how, exactly, you got it to work.

Then go to "Thread Tools" at the top of the page and mark the thing solved.

Glad you got it fixed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: GNOME 3: Lured into the hot corner LXer Syndicated Linux News 0 12-19-2012 06:50 AM
gnome-3 move hot-corner to top right schneidz Linux - Desktop 3 11-15-2012 12:16 AM
LXer: Cinnamon 1.4 Released: Come With New Settings Applet And Hot Corner Behavior LXer Syndicated Linux News 0 03-18-2012 12:01 PM
LXer: Cinnamon 1.4 Released With New Hot Corner Behaviour, More LXer Syndicated Linux News 0 03-14-2012 07:40 AM
compiz scale: how to change hot corner? make Mandriva 0 10-13-2006 03:19 AM


All times are GMT -5. The time now is 05:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration