LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 04-20-2007, 04:25 AM   #1
rangalo
Member
 
Registered: Jan 2005
Posts: 189

Rep: Reputation: 30
Manage wired and wireless (WPA) internet connections


Hi,

I have recently got my Internet connection which is through DSL. I have also purchased a router which can also be used as wireless access point.

Now, I want to know

1. How can I configure debian testing (for kernel and all, see my signature) to access the internet through wireless conneciont (WPA not WPA2) ?

2. I also have wired connection (hispeed) so when I use wired connection how can I avoid that the dhclient tries needlessly to get ip from wireless access point during booting ?

I have searched LQ and also google for that. On LQ, I found one how-to, using wpasupplicant which is outdated.

Any help ?

[EDIT] I already have a woking wireless connection. I can access unsecured connections without any problem.



regards,
Hardik
 
Old 04-20-2007, 04:53 AM   #2
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
Quote:
1. How can I configure debian testing (for kernel and all, see my signature) to access the internet through wireless conneciont (WPA not WPA2) ?
Use wpa_supplicant.

For pre-shared key WPA (psk):

Quote:
Originally Posted by /etc/nework/interfaces
iface eth1 inet dhcp
wpa-ssid myssid
wpa-key-mgmt WPA-PSK
wpa-psk 089425242100b53bdf5262294cc5c93391704c3c800079389a0068e454737e4d
The line wpa-psk can be encoded with the help of

Code:
 wpa_passphrase myssid myhollys3cr3tkey
If you have a stock kernel, you have the options (crypto mainly)
You need wpa_supplicant packages
aptitude install wpasupplicant

Quote:
2. I also have wired connection (hispeed) so when I use wired connection how can I avoid that the dhclient tries needlessly to get ip from wireless access point during booting ?
In /etc/network/interfaces, do not put
auto eth0
nor
auto eth1

This way, it will never bring up the interfaces unless you ask.

For bringing up ethX:
ifup ethX
Down:
ifdown ethX

You cannot have both on otherwise you will have a default gateway conflict.

Now all this can be automatically detected with ifplugd. This is the next step

Last edited by nx5000; 04-20-2007 at 04:57 AM.
 
Old 04-20-2007, 06:01 AM   #3
rangalo
Member
 
Registered: Jan 2005
Posts: 189

Original Poster
Rep: Reputation: 30
Hi nx5000,

Thanks for the answer. I will give it a try when I am back home. And after I have configured everything, I will ask more abut ifplugd.

thanks and regards,
Hardik
 
Old 04-20-2007, 06:12 AM   #4
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
You are welcome

ifplugd
 
Old 04-20-2007, 03:20 PM   #5
rangalo
Member
 
Registered: Jan 2005
Posts: 189

Original Poster
Rep: Reputation: 30
Hi,

I tried what you suggested, all without success
First I installed wpasupplicant
here is my
/etc/network/interfaces:
Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo 
iface lo inet loopback 
iface eth0 inet dhcp
iface eth2 inet dhcp
wpa-ssid "RangaloNet"
wpa-key-mgmt WPA-PSK
wpa-key d3d09f14d596b029e213537ae53ee8694175f8821c6d387a89600b64e46d32ca
The wired network works well it is eth0.

But the wireless network doesn't work.

when I say
Code:
ifup eth2
it just tries to get the ip, but cannot.

What could be wrong ?

regards,
Hardik

Last edited by rangalo; 04-20-2007 at 05:21 PM.
 
Old 04-21-2007, 02:14 AM   #6
rangalo
Member
 
Registered: Jan 2005
Posts: 189

Original Poster
Rep: Reputation: 30
Sorry, guys..

It was my mistake.

I used wpa-key instead of wpa-psk for the secret key and that's why it failed.

Changing to wpa-psk it worked fine.

Now, coming to the tutorial for ifplugd. As I told, I came across it , it is the old one. They have changed the way of staring wpa_supplicant in the new version. I don't know though what is different and what do I need to change in to this tut.


Can anybody point me to the latest info regarding this. What I want now is just to configure wireless if I don't have the network cable plugged in.

regards,
Hardik
 
Old 04-23-2007, 07:08 AM   #7
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
Currently I use ifplugd + whereami + resolvconf.
In /etc/default/ifplugd, I have put eth0 eth1 as INTERFACES.

Check.
You might have problems with DNS so first try to only ping your router (or google or whatever)

But I haven't fully tested. I'm oldschool, I bring up dhcp on wireless manually


But I'll be happy to hear how it works for you, maybe I'll put this automatic network setting on my laptop.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
WIreless won't surf internet unless wired card has IP even if not plugged in tuxkwb Linux - Wireless Networking 4 12-28-2006 01:07 AM
Network configure linux box to wired router to xp to internet thru wireless usb Max72196 Linux - Wireless Networking 1 09-13-2006 12:04 PM
Wireless and wired connections ComputerErik Slackware 6 09-06-2005 11:07 AM
Wireless Laptop to Wired ethernet via Linux PC (wired/wireless) sambartle Linux - Wireless Networking 0 01-30-2005 04:37 AM
wired and wireless internet connections. levicc00123 Linux - Laptop and Netbook 1 01-14-2005 08:55 PM


All times are GMT -5. The time now is 04:42 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration