LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   low res crap picture (http://www.linuxquestions.org/questions/debian-26/low-res-crap-picture-398523/)

fakie_flip 01-01-2006 11:25 PM

low res crap picture
 
I have trouble after installing Debian 3.1r0. My resolution is very low and picture is poor. Is there a way to fix that? Why would the settings not have been configured properly the first time? The blue and black Debian swirl background looks like it is made up of big dots.

anti.corp 01-02-2006 06:52 AM

Try posting your XF86Config or Xorg.conf file here.

Sounds like it didn't recognize your graphic card. What type of card are you using?

juanjavier_xxx 01-02-2006 06:56 AM

As root, try
Code:

dpkg-reconfigure xserver-xfree86
or
Code:

dpkg-reconfigure xserver-xorg
depending on what video server have you got installed....and follow carefully the steps thru it...

As a rule of thumb, I could suggest you to try with lower values and increasing them up until a good screen configuration can be reached....

Keep posting your progresses so that we could help you (or at least try to....) :p

Cheers!!

fakie_flip 01-02-2006 12:13 PM

Where is the x config file that you are asking about? Is it in my home? What is the name of it, so I know I will be getting the correct one? I'm not sure how to change the settings in it. Maybe it will be easy to do.

lestoil 01-02-2006 12:30 PM

Look in /etc/X11/XF86Config-4. That is the file to edit after running,as root, dpkg-reconfigure xserver-xfree86 is completed. But knowing ur video card and monitor u use wd help most. At top of the forum there is post-install configuration article with great guide. Good luck.

coyopil 01-02-2006 02:50 PM

If you don't know what an X config file is but still want debian I suggest you try MEPIS, an easy to setup 100 % Debian compliant distro. It installs from a LiveCD.

fakie_flip 01-02-2006 02:57 PM

It's been so long since I manually configured x that I forgot where the config file is. Right now I just want to get Debian working before I move to something else. I have Ubuntu 5.10 on my best computer.

fakie_flip 01-06-2006 02:46 PM

http://www.geocities.com/fakie_flip2000/Debian.JPG

http://www.geocities.com/fakie_flip2000/Synaptic.JPG

There is my screen on my computer with Debian. Sometimes I am unable to click on buttons.

Here is my /etc/X11/XF86Config-4:

# XF86Config-4 (XFree86 X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the XF86Config-4 manual page.
# (Type "man XF86Config-4" at the shell prompt.)
#
# This file is automatically updated on xserver-xfree86 package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xfree86
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands as root:
#
# cp /etc/X11/XF86Config-4 /etc/X11/XF86Config-4.custom
# md5sum /etc/X11/XF86Config-4 >/var/lib/xfree86/XF86Config-4.md5sum
# dpkg-reconfigure xserver-xfree86

Section "Files"
FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
Load "GLcore"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "speedo"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "Generic Video Card"
Driver "vga"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
HorizSync 28-50
VertRefresh 43-75
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Generic Video Card"
Monitor "Generic Monitor"
DefaultDepth 4
SubSection "Display"
Depth 1
Modes "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection

fakie_flip 01-06-2006 03:51 PM

My graphics card is:

VGA compatible controller: nVidia Corporation NV6 [Vanta/Vanta LT] (rev 15)

My monitor just says "TOUCH" underneath the screen. I do not know what it is or how to find out.

When I installed Ubuntu 5.10 on the same computer, the graphics were fine. The screens resolution was high too.
In Gnome on Debian, if I goto Applications/Debian Menu/Screen Resolution, there are no other choices to set the resolution different than what it is on, 640x480 and the refresh rate also can not be changed. It is set to 60 Hz. Installing Debian gave me some choices. I choose vga for my video card. I did not do the autodetection because the instructions said not to if I had an nvidia card. I did not know how to set up my monitor. I had a choice between low, medium, and advanced. I choose advanced and pushed enter to accept the values that were already put in there.

dastrike 01-06-2006 03:56 PM

You are using the vga driver. That is not exactly optimal for any situation really.
  • What graphics card do you have? The manufacturer and model of the graphics chip more specifically.
  • Show us the output of the lspci command while you are at it
  • What monitor do you have, what are the horizontal sync and vertical refresh ranges for it? If you don't know, look them up in the manual of your monitor, if you don't have the manual for your monitor, look on the website of the monitor manufacturer, if you can't find them there, use some prominent web search engine to find them.

Once you provide that, (well the two first ones), we can tell you what driver you should specify in the X configuration
And after that you can just reconfigure the X Window System by
Code:

dpkg-reconfigure xserver-xfree86 --priority=medium
and supply the correct values to these things.


//edit: gah, you posted the graphics card above now...
Anyways, you should use the nv driver with that for now, and put in some more effort into identifying your monitor and finding out the ranges for the horizontal sync and vertical refresh that it can handle. You can let dpkg-reconfigure to detect the monitor too but in my opinion it is not always that reliable.

fakie_flip 01-06-2006 04:03 PM

Where I said:

"My graphics card is:

VGA compatible controller: nVidia Corporation NV6 [Vanta/Vanta LT] (rev 15)"

was output from lspci. I am not sure how to find out about my monitor. The only words I can find on it is TOUCH, select, and degauss in caps. I got the computer used, so I do not have the manual. Can this monitor still be used?

davcefai 01-06-2006 04:24 PM

The nv driver should improve the situation a lot.

On the other hand you should note the the Vanta is an old card, 16MB RAM if I remember correctly. I'm not sure if the NVIDIA driver still supports it, if it does than you can download the driver from nvidia.com. If it doesn't you may be able to find an old version of the driver that does but you'll probably have a problem when the installer comes to compile the driver.

With regards to the monitor, you could always "cheat" by plugging it into a Windows box and seeing what it is detected as. You might want to set the Windows display to not more than 800x600, 60Hz as, if the monitor is the same vintage as the card, it may have limited capabilities.

efi360 01-06-2006 10:43 PM

Nvidia Vanta still supported
 
I am using that same card nvidia vanta lt with Mepis linux and it works great I run it at 1024x768 resolution and no problems it will do even higher but then again I have a good monitor. And by the way davcefai you do remember right it does have only 16MB ram and yes nvidia driver does still support it I can run tuxracer and tuxkart it has good 3D.

fakie_flip 01-09-2006 08:00 AM

I changed the driver from "vga" to "nv" after my friend suggested to me. I hit control + alt + backspace to restart x. X would not come up anymore, so I had to change "nv" back to "vga" to get x to run again. Then I installed Fedora Core release 4 with KDE on the computer and the graphics are fine again.

davcefai 01-09-2006 11:41 AM

Did you kill the graphics server as well? I suggest you try rebooting after changing the driver.


All times are GMT -5. The time now is 08:46 AM.