LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 10-19-2005, 04:09 PM   #1
davcefai
Member
 
Registered: Dec 2004
Location: Malta
Distribution: Debian Sid
Posts: 764

Rep: Reputation: 32
Lost my Ctrl-Alt-Fx


After upgrading Sarge to KDE 3.4 and updating about 300 packages (many from unstable) I can no longer usr Ctrl-Alt-Fx to switch to tty mode when KDE is running. The key combos work OK if I boot to text mode.

I found some references to keymap but could not understand what I had to do.

Help appreciated (as usual). Thanks.
 
Old 10-20-2005, 02:15 AM   #2
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 53
Sorry if obvious, but do you really mean kde or kdm? I've noticed that kdm locks the ttys until kde is fully running.
 
Old 10-20-2005, 10:03 AM   #3
davcefai
Member
 
Registered: Dec 2004
Location: Malta
Distribution: Debian Sid
Posts: 764

Original Poster
Rep: Reputation: 32
Obvious it's not. I may be missing something here. KDM loads during boot. That's the graphics manager right? Then the GUI comes up and calls itself KDE 3.4.

Everything then run normally (for a given value of "normally", bearing in mind that we are dealing with computers here

Am I missing out on something?
 
Old 10-20-2005, 10:57 AM   #4
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 53
right, so kdm is the login manager where you type username and password. This seems to lock the ttys until kde has started, then you can hit ctrl-alt-fn. I added a ConsoleTTYs line to /etc/kde3/kdm/kdmrc so the general section now looks like:

[General]
ConfigVersion=2.1
PidFile=/var/run/kdm.pid
ServerVTs=-7
Xservers=/etc/kde3/kdm/Xservers
ConsoleTTYs=tty1,tty2,tty3,tty4,tty5,tty6

This gives an option "Console login" to the kdm "menu"-button, but for some reason it goes back to gui if the console is inactive for a minute :|

If you get no ttys even when kde is fully running you might want to check that the gettys are running in the first place:
ps fax|grep getty
6155 tty2 Ss+ 0:00 /sbin/getty 38400 tty2
6156 tty3 Ss+ 0:00 /sbin/getty 38400 tty3
6157 tty4 Ss+ 0:00 /sbin/getty 38400 tty4
6158 tty5 Ss+ 0:00 /sbin/getty 38400 tty5
15672 tty1 Ss+ 0:00 /sbin/getty 38400 tty1

Next have a look at /etc/inittab . There you set the gettys with lines like:
1:12345:respawn:/sbin/getty 38400 tty1
2:2345:respawn:/sbin/getty 38400 tty2
3:2345:respawn:/sbin/getty 38400 tty3
4:2345:respawn:/sbin/getty 38400 tty4
5:2345:respawn:/sbin/getty 38400 tty5
6:2345:respawn:/sbin/getty 38400 tty6

The 12345 and 2345 define on which runlevels they are active. If at the top of the same file in the line:
# The default runlevel.
id:5:initdefault:
you also have 5, the gettys should also have a 5 in them.
 
Old 10-20-2005, 02:44 PM   #5
davcefai
Member
 
Registered: Dec 2004
Location: Malta
Distribution: Debian Sid
Posts: 764

Original Poster
Rep: Reputation: 32
Thanks for the detailed reply. Everything matches what you posted except that I do not have
Quote:
Xservers=/etc/kde3/kdm/Xservers
Nor does the file /etc/kde3/kdm/Xservers exist. Could this be the problem?

Other people seem to have this problem, for example:

http://www.slackplanet.org/index.php?topic=734.msg4861

but nothing there helped either.
 
Old 10-20-2005, 03:08 PM   #6
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 53
I don't see how that file could affect vt's. Have you tried another login manager just to check if kdm is at fault?
You probably have xdm installed but kdm as default. I don't know on which runlevels you want x running but you can probably decide that. This will switch to xdm on bootup:
update-rc.d -f kdm remove
update-rc.d xdm start 99 5 . stop 01 0 1 2 3 4 6 .
You can check what you have now with: ls -l /etc/rc[0-6].d|grep [gkx]dm

If you want to try Xservers file this is the only uncommented line there:
:0 local@tty1 /usr/X11R6/bin/X -br -nolisten tcp vt7

EDIT:
Did a google and it's possibly your xkbd setting. Have a look here http://lists.debian.org/debian-x/2005/09/msg00446.html

Last edited by makuyl; 10-20-2005 at 03:22 PM.
 
Old 10-22-2005, 07:30 AM   #7
davcefai
Member
 
Registered: Dec 2004
Location: Malta
Distribution: Debian Sid
Posts: 764

Original Poster
Rep: Reputation: 32
I've been researching xkbd and discovered that I do not have an /etc/sysconfig/ directory, although a configuration howto on the Debian website refers to it.

This might be a topic for a new post, I thought sysconfig was an integral pert of any distribution.
 
Old 10-22-2005, 09:38 AM   #8
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 53
I don't have /etc/sysconfig either on a sarge box.
Which howto? Or rather post the relevant part.
 
Old 10-22-2005, 12:11 PM   #9
davcefai
Member
 
Registered: Dec 2004
Location: Malta
Distribution: Debian Sid
Posts: 764

Original Poster
Rep: Reputation: 32
Debian Configuration Howto, section 2.3:

Quote:
2.3. Keyboard

If you missed this step during installation or have changed your keyboard, you'll have to:

*

look for a suitable key table starting from /usr/lib/kbd/keymaps/i386; for example, querty/it-latin1.kmap.gz supports the Italian keyboard;
*

edit the file /etc/sysconfig/keyboard so as it reads: KEYTABLE="it-latin1";
*

to set up the keyboard repeat rate and delay time, add this line to /etc/rc.d/rc.sysinit:

/sbin/kbdrate -s -r 16 -d 500 # or whatever you like
I cannot find any keyboard files!
 
Old 10-22-2005, 12:19 PM   #10
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 53
That you can do by looking for a suitable keymap in /usr/share/keymaps/i386/qwerty/
I install a finnish one with: install-keymap fi-latin1.kmap.gz
But you set it within x from xorg.conf or XF86Config or XF86Config-4 depending on what you use.

From my xorg.conf:
Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fi-latin1"
EndSection

XF86Config-4:
Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "fi-latin1"
EndSection

As you can see, only the driver differs.
 
Old 10-24-2005, 12:09 PM   #11
davcefai
Member
 
Registered: Dec 2004
Location: Malta
Distribution: Debian Sid
Posts: 764

Original Poster
Rep: Reputation: 32
I've spent a lot of time playing with this - learning a lot in the process - and essentally discovered this:

If I do not load a keymap then Ctrl-Alt-Fx, Ctrl-Alt-+/- work as advertised. However I get what I think is a US keyboard where "|" and "\" come out as ">" and "<" (the key next to the left hand shift).

Loading any other keymap including fi-latin disables Ctrl-Alt-Fx. However Ctrl-Alt-Backspace (Kill X) always works.

In xorg.conf I have

Code:
Section "InputDevice"
	Identifier	"Generic Keyboard"
# 	Driver		"keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"uk"
	Option		"CustomKeycodes"	"on"

EndSection
and I've also played with

Code:
Section "ServerFlags"
	Option "DontVTSwitch" "false"
	Option "DontZoom"  "false"
	Option "HandleSpecialKeys" "Always"
EndSection
As far as I can tell I have tried all possible combinations, disabling and enabling combinations of the above.

It looks like my problem is linked to the presence of XkbLayout, which is why I tried using HandleSpecialKeys.

So near, yet so far! Incidentally if I boot into text mode, or kill the X Server, then Ctrl-Alt-Fx work just fine.

Suggestions appreciated. Thanks
 
Old 10-24-2005, 02:49 PM   #12
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 53
This is strange. Run "xev" in a konsole under kde, press one by one, ctrl, alt and F1 and see if they are mapped correctly.
If you want some more reading, try this /usr/share/doc/x11-common/FAQ.xhtml
 
Old 10-24-2005, 03:16 PM   #13
zuralin
Member
 
Registered: Sep 2003
Distribution: Debian testing/unstable
Posts: 225

Rep: Reputation: 30
Thought I should add that I am having the exact same problem on a testing/unstable box and have had the problem since xfree86 and continue to have it with xorg. Also I am using GDM as my login manager and Gnome as my DE.
 
Old 11-15-2005, 11:46 PM   #14
davcefai
Member
 
Registered: Dec 2004
Location: Malta
Distribution: Debian Sid
Posts: 764

Original Poster
Rep: Reputation: 32
SOLVED IT!!!

I found out that KDE believed that I had a US layout Keyboard not a UK one. Or at least that's what the KDE Control Centre showed.

I changed it and can now switch to alternate TTYs.

Looks like KDE doesn't check what Linux has installed when it installs.

Thanks mahuyl for the help. Good luck to those who are still struggling.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No alt-ctrl-F7/F8 spotslayer Suse/Novell 3 04-26-2005 07:50 PM
dark screen when pressing Ctrl + Alt + Backspace or Ctrl + Alt F1-F6 in Gnome or KDE trinoo Slackware 5 01-28-2005 08:13 AM
Switching window focus (like alt+tab in windows) and Ctrl+Alt+F1 X windows problem... DiZASTiX Linux - Software 3 01-20-2005 04:56 PM
Ctrl Alt Delete What? Brother Michael Linux - Newbie 2 12-09-2003 09:38 AM
Ctrl-Alt-F* Fiskarn Mandriva 2 10-15-2003 02:44 AM


All times are GMT -5. The time now is 12:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration