LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 02-22-2005, 03:16 PM   #1
TuxToaster
Member
 
Registered: May 2003
Location: UK
Distribution: Debian
Posts: 127

Rep: Reputation: 15
Login Menu


I have been messing around with the Debian Sarge Installer, i 1st installed it with just the Desktop environment "net installer, 500mb or so dl" then i reinstalled with just the base xserver and kde "100mb or so dl".
Everything works but the login menu on the 2nd install is very basic, only the option to login and thats it unlike on the 1st install.
Any way i can get this to get the login menu to the same as the 1st install or some other login menu with the more options ie session etc.
 
Old 02-22-2005, 03:19 PM   #2
mjrich
Senior Member
 
Registered: Dec 2001
Location: New Zealand
Distribution: Debian
Posts: 1,046

Rep: Reputation: 45
Depending on your preferences, either
Code:
apt-get update
apt-get install kdm             -or
apt-get install gdm
Cheers,

mj
 
Old 02-22-2005, 04:23 PM   #3
TuxToaster
Member
 
Registered: May 2003
Location: UK
Distribution: Debian
Posts: 127

Original Poster
Rep: Reputation: 15
Thanks.
 
Old 04-29-2005, 09:53 PM   #4
Fice
Member
 
Registered: Feb 2005
Location: Monterrey, Mexico
Distribution: Sabayon
Posts: 75

Rep: Reputation: 15
KDM install

Ive got kind of the same problem except my solution does not seem to be so simple. Im running Arch 0.7 on the 2.6.11 kernel using KDE and I know im supposed to use pacman instead of apt-get but still Ive already looked on all the repositories of pacman with a querry and there is no such thing as kdm or gdm and every time I try to install it by pacman -S kdm or pacman -Su kdm or any other way it just says kdm not found. So then how can I install kdm? Am I just stuck with the console login and then doing the startx thing myself?

Fice
 
Old 05-02-2005, 05:01 PM   #5
mjrich
Senior Member
 
Registered: Dec 2001
Location: New Zealand
Distribution: Debian
Posts: 1,046

Rep: Reputation: 45
Gdm has been compiled for Arch -- see http://www.archlinux.org/packages.php?id=3140. Kdm may already have been installed as part of kdebase (what happens if you attempt to run kdm from the command line ?), otherwise you'll probably have to install it from source (see http://www.kde.org/download and the Konstruct tool).

Cheers,

mj
 
Old 05-03-2005, 09:28 PM   #6
microsoft/linux
Senior Member
 
Registered: May 2004
Location: Sebec, ME, USA
Distribution: Debian Etch, Windows XP Home, FreeBSD
Posts: 1,445
Blog Entries: 9

Rep: Reputation: 45
ok, not really related to getting a login menu, but how do I get gdm to match the widget(or theme or whatever it's called) that gnome uses?
 
Old 05-03-2005, 11:47 PM   #7
mjrich
Senior Member
 
Registered: Dec 2001
Location: New Zealand
Distribution: Debian
Posts: 1,046

Rep: Reputation: 45
Use gdmconfig (or gdmsetup, as root).

Cheers,

mj
 
Old 05-08-2005, 11:02 PM   #8
Fice
Member
 
Registered: Feb 2005
Location: Monterrey, Mexico
Distribution: Sabayon
Posts: 75

Rep: Reputation: 15
ok turns out you where right kdm was already installed or at least I think, although nothing happens when i put kdm on the konsole it doesnt say not found nor anything. From what I know i can configure it through kconfig or something like that as root and then going to the login menu but no matter how much i change there I always boot to the console login. And as far as I know i have the kdm set up in the bootup script or if not still shouldnt it boot to xdm instead?

thanks for all your help
 
Old 05-08-2005, 11:14 PM   #9
mjrich
Senior Member
 
Registered: Dec 2001
Location: New Zealand
Distribution: Debian
Posts: 1,046

Rep: Reputation: 45
You could have a look at which runlevel kdm is expected to be started from (grep -r kdm /etc/rc*.d), and then see if that is before or after your default runlevel (in /etc/inittab). You could also reconfigure kdm, a la
Code:
dpkg-reconfigure kdm
Cheers,

mj
 
Old 05-08-2005, 11:37 PM   #10
Fice
Member
 
Registered: Feb 2005
Location: Monterrey, Mexico
Distribution: Sabayon
Posts: 75

Rep: Reputation: 15
ok whenever I run

Code:
grep -r kdm /etc/rc*.d
I get

Code:
/etc/rc.d/kdm:PID=`pidof -o %PPID /opt/kde/bin/kdm`
/etc/rc.d/kdm:    [ -z "$PID" ] && /opt/kde/bin/kdm &>/dev/null
/etc/rc.d/kdm:      echo $PID > /var/run/kdm.pid
/etc/rc.d/kdm:      add_daemon kdm
/etc/rc.d/kdm:      rm_daemon kdm
Im not sure what im supposed to get but I cant find any run level there.

The other code for the reconfigure thing didnt work, it told me the comand did not exist.

I also noticed that during bootup theres an error sometimes it comes out several times saying

INIT cannot execute "/usr/X11R6/bin/kdm"

I suppose this has something to do with it?
 
Old 05-09-2005, 12:12 AM   #11
mjrich
Senior Member
 
Registered: Dec 2001
Location: New Zealand
Distribution: Debian
Posts: 1,046

Rep: Reputation: 45
Quote:
INIT cannot execute "/usr/X11R6/bin/kdm"

I suppose this has something to do with it?
Quite possibly. If it's a bug in the init script for kdm, then you may want to run an update on your system to make sure you have all the current packages. Otherwise, you could check your startup scripts for that command above, and replace it with the correct location of kdm. On my system, it's at /usr/bin/kdm (running whereis kdm should tell you).

I'm not sure how your rc.d directories are setup as - obviously not as the old style /etc/rc0.d -- through to /etc/rc6.d, so you may want to have a poke around your /etc directory and then re-run a modified version of the above grep command. Though my hunch is that you've hit the nail on the head with the error above - so as soon as you can change that path to the correct one, it'll probably run normally.

Good luck !

Cheers,

mj
 
Old 05-09-2005, 12:24 AM   #12
mjrich
Senior Member
 
Registered: Dec 2001
Location: New Zealand
Distribution: Debian
Posts: 1,046

Rep: Reputation: 45
Actually, if you want to be excessively lazy, then you could always just check that /usr/X11R6/bin/kdm doesn't indeed exist, and then just make a symlink from there to the real kdm binary. Something along the lines of
Code:
ln -s /usr/bin/kdm /usr/X11R6/bin/kdm
should do it.

Cheers,

mj
 
Old 05-09-2005, 12:53 AM   #13
Fice
Member
 
Registered: Feb 2005
Location: Monterrey, Mexico
Distribution: Sabayon
Posts: 75

Rep: Reputation: 15
Ok it seems we are getting there but not quite yet.
I did the link thing and now when I do the whereis kdm command it shows it works and tell me its in /usr/X11R6/bin/kdm and /opt/kde/bin/kdm where it was originally and this helped eliminate the error at bootup but still I get the console log in and another error that goes
"INIT Id "x" respawining too fast: disabled for 5min"

as far as my rc.d directories there seems to be only one of them located at /etc/rc.d with a bunch of stuff inside of it but there is no rc0.d or rc6.d

where would the INIT script that is constantly running up with errors be?
 
Old 05-09-2005, 03:08 PM   #14
mjrich
Senior Member
 
Registered: Dec 2001
Location: New Zealand
Distribution: Debian
Posts: 1,046

Rep: Reputation: 45
Right, after a bit of reading it appears that Arch follows the *BSD style of boot scripts, rather than the usual rc0.d, rc1.d, ... rc6.d runlevel directories. So, that explains why you couldn't find the symlink with the grep command above.

The "respawning too fast" error could be due to any number of things (simply says that some process in the current runlevel is either missing or misconfigured -- see http://www.unixguide.net/linux/faq/09.24.shtml). Try booting into single user mode and see what happens - if you get kdm coming up normally, then check the differences between /etc/rc.single and /etc/rc.multi.

The other likely option is that you've recently attempted to install or remove something crucial to the current runlevel - if so, then you may want to try reinstalling it, at least for the moment.

Cheers,

mj
 
Old 05-19-2005, 03:14 AM   #15
Fice
Member
 
Registered: Feb 2005
Location: Monterrey, Mexico
Distribution: Sabayon
Posts: 75

Rep: Reputation: 15
Hi sorry for the late post, I was in exams and wasnt really able to continue with my linux config. I solved the INIT: x respawning too fast error thanks to your link. I basically just nanoed into the inittab script and commented the line wich had kdm on it which was the one with trouble or so I found out later as now everything seems to be working fine; Im guessing it was directed wrongly to where kdm was or something Im not sure, I tried correcting it but didnt work so I just decided to comment it out. Kdm is now working since whenever I run kdm on console a login screen appears, before it basically did nothing. It still isnt coming up at bootup but Im going for the lazy way of solving it, adding the kdm command to the boot up script hehehe. Except I forgot where the bootup script is otherwise I would have tested it already but Im sure I will find it in a while.

Thanks for all your help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
enlightenment: login menu ccin1492 Linux - Software 5 05-25-2005 10:12 AM
Session menu in xdm login screen? Bowman Slackware 7 12-09-2004 07:58 PM
help: Mandrake login menu doesn't appear xiongnu Mandriva 8 10-07-2004 05:41 PM
GDM graphical login menu nuzzy Linux - General 1 10-31-2003 11:50 AM
How logout from login-menu bash script? MikHud Linux - General 0 04-12-2002 12:01 PM


All times are GMT -5. The time now is 07:58 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration