LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 11-29-2012, 09:25 AM   #1
john50
LQ Newbie
 
Registered: Nov 2012
Posts: 2

Rep: Reputation: Disabled
locale error messages


Hi,

I have a Debian server which I've just upgraded from lenny to squeeze using apt-get. During the upgrade, I got the following error lots of times:

PHP Code:
manconvcant set the localemake sure $LC_* and $LANG are correct 
Afterwards, proftp wouldn't start. I did various things (including dpkg-reconfigure locales, local-gen) which eventually got it to start, but I am still getting error messages about locales.

When I log in via ssh I get:

PHP Code:
-bashwarningsetlocaleLC_ALLcannot change locale (en_US.UTF-8
When I run apache2ctl status I get:

PHP Code:
perlwarningSetting locale failed.
perlwarningPlease check that your locale settings:
    
LANGUAGE = (unset),
    
LC_ALL "en_GB.utf8",
    
LANG "en_GB.UTF-8"
    
are supported and installed on your system.
perlwarningFalling back to the standard locale ("C").
                                   
Forbidden 
The /etc/environment file contains:
PHP Code:
LC_ALL="en_GB.utf8" 
How do I fix this?
 
Old 11-29-2012, 10:08 AM   #2
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374
I do believe that /etc/environment is for Debian versions that pre-date Squeeze.

Try removing the locale entries from /etc/environment and have a look at /etc/default/locale

Depending of the language choice it should look something like this:
Quote:
# File generated by update-locale
LANG="en_US.UTF-8"
LANGUAGE="en_US:en"
You can add specific entries to it which are recognized system-wide. Example:
Quote:
# File generated by update-locale
LANG="en_US.UTF-8"
LANGUAGE="en_US:en"
LC_COLLATE=POSIX
LC_MEASUREMENT="nl_NL.utf8"
LC_PAPER="nl_NL.utf8"
LC_TIME="nl_NL.utf8"
Did a search and came up with this: Debian locale
 
1 members found this post helpful.
Old 11-29-2012, 12:23 PM   #3
john50
LQ Newbie
 
Registered: Nov 2012
Posts: 2

Original Poster
Rep: Reputation: Disabled
Hi druuna.

Thanks for your help. I cleared out my /etc/environment and had a read through that link. The commands suggested seemed to throw various errors up but after mucking around with the files mentioned on that Wiki page, I managed to get rid of the errors I was getting.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
after-Installation errors. locale error. unsupported locale settings and two more gh0st Fedora 1 05-02-2008 06:06 AM
Postfix: User messages are okay; but error messages themselves seem to be bouncing jgombos Linux - Server 3 03-03-2007 03:21 PM
what RPM for perl(Locale::Messages)? c0ldshadow Fedora 3 07-08-2005 05:10 PM
From where am i getting error messages to /var/log/messages? prabhuacsp Programming 3 02-16-2005 09:59 AM
From where am i getting error messages to /var/log/messages? prabhuacsp Linux - Networking 1 02-16-2005 01:34 AM


All times are GMT -5. The time now is 06:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration