LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Loading, please wait (http://www.linuxquestions.org/questions/debian-26/loading-please-wait-4175429283/)

qrange 09-27-2012 06:44 AM

Loading, please wait
 
there is a long delay on my computer (Debian, amd64, testing) after "Loading, please wait" message. On the other, older computer, delay is much shorter. could it be because of software raid or scsi card? is there way to speed it up?

suttiwit 09-27-2012 11:08 AM

I guess it is unsupported hardware...

el chapulín 09-28-2012 07:40 AM

It could be due to the size of the /boot or / partition.

Without knowing all of the details of the software raid setup or the scsi card and configuration of the drives, number of drives, partitioning scheme, bootloader, etc... it's not going to be easy for anyone to help you.

qrange 09-28-2012 10:38 AM

boot and / are on same partition, its size is 25Gb on SSD drive. raid0 is on 3 hdds. bootloader is grub2.
looking at dmesg, biggest delay seems to be here:
..
[ 4.004172] usbhid: USB HID core driver
[ 16.148458] scsi2 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 7.0
..


edit: I think I've found the solution, nut sure how to use it:



> This sounds like a user configuration error. The adaptec has a bus
> settle time in its initialisation path. Originally it was 20s, hence
> for a D card (twin channel) it would take about 50s to come online
> (extra 5s to scan per channel). There was a lot of argument about this,
> and the value was finally made configurable as
>
> CONFIG_AIC79XX_RESET_DELAY_MS
>
> I suspect you have this set to around 15000. You can make the boot
> sequence shorter by reducing this value. I believe Red Hat configures
> it down to the default 5000.

VDP76 10-03-2012 08:45 AM

it looks like a grub parameter, imo...
where did you find that piece of information?

el chapulín 10-03-2012 09:19 AM

It's in the kernel configuration, so to change that you would need to rebuild the kernel.

Apparently this was fixed upstream quite some time ago - but it is a only a configuration option, so it could have been configured to the old value in Debian's kernels. You should first check if this is a possible cause:
Code:

$ grep CONFIG_AIC79XX_RESET_DELAY_MS /boot/config-`uname -r`
I have squeeze running here in a virtual machine and the result is:
Code:

CONFIG_AIC79XX_RESET_DELAY_MS=15000
As you're running testing with a 3.2 kernel, I would imagine this would have been fixed...

qrange 10-03-2012 05:10 PM

nope, after running that command its the same here, on 3.2.0-3-amd64 (Debian 3.2.23-1):

CONFIG_AIC79XX_RESET_DELAY_MS=15000

I only seldom use scsi for old scanner, is there an option to disable it temporary?
thanks.

el chapulín 10-03-2012 05:11 PM

apt-get the debianised source change the value to 5000 and rebuild the kernel.

qrange 10-04-2012 02:08 AM

thanks, but that is beyond my linux knowledge. besides, I'd have to do it after every kernel update.
I'll just live with it.

el chapulín 10-04-2012 08:08 AM

I doubt it's beyond your linux knowledge, but you're right in that rebuilding the kernel whenever there's an update can be a pain - but for many users a necessary one. I tend to just choose a kernel from kernel.org and stick with it, patching and rebuilding only when something relevant (and/or security related) turns up.

qrange 10-18-2014 04:49 PM

sorry to reply to this old thread. I (finally) recompiled kernel into new .deb and installed it, like 'el chapulín' said, so boot time is 15 sec faster now.


All times are GMT -5. The time now is 05:50 PM.