LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 07-02-2007, 09:16 AM   #1
meshcurrent
Member
 
Registered: Oct 2002
Posts: 38

Rep: Reputation: 15
LILO Installation Fails on Machine with 4 SATA Disks


Installing Etch on a machine with 4 SATA disks proceeds smoothly until it reaches the LILO boot loader installation. The boot loader installation screen offers the choice to install LILO on /dev/sdd or /dev/sda5, the root partition. It seems odd that the installer offers /dev/sdd in place of /dev/sda as a choice. Regardless, attempting to install on /dev/sdd, /dev/sda5, or /dev/sda by typing it in the "other choice" dialog fails with a warning in syslog: "configuring lilo-installer failed with error code 1." Switching to a shell, I indeed see no sbin/lilo and no etc/lilo.conf under /target. If I physically disconnect all but the first SATA disk--which is the only disk I am actually partitioning during the installation--the installation completes successfully. This behavior persists with XFS as well as JFS, the two file systems I tried installing on. I am wondering if someone could suggest how I could debug this further.

Youssef Eldakar
Bibliotheca Alexandrina
 
Old 07-03-2007, 08:17 AM   #2
emi_ramo
Member
 
Registered: Apr 2007
Location: Barcelona, Spain
Distribution: Debian, KUbuntu
Posts: 213

Rep: Reputation: 36
Advice: Use GRUB instead of LILO.
Either you use LILO or GRUB, it should be on /dev/sda, not /dev/sdaX nor /dev/sdd*. It's because the BIOS will look for a bootable sector on the device, not on the partition, and it will look at the first HD, /dev/sda. It's filesystem independent: this is BIOS functionality, not linux neither LILO nor GRUB.
 
Old 07-04-2007, 01:57 AM   #3
meshcurrent
Member
 
Registered: Oct 2002
Posts: 38

Original Poster
Rep: Reputation: 15
I would like to use XFS, and GRUB is known to freeze with XFS partitions. The installer does warn about this.

Youssef Eldakar
Bibliotheca Alexandrina
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help Needed on Installation of Etch on SATA Hard Disks royski_it2004 Debian 4 07-02-2007 09:12 AM
Core 6 installation: Grub does not work on SATA hard disks juan_conejero Fedora - Installation 3 11-08-2006 06:30 AM
SUSE USB installation boot up fails dep. on IDE or SATA oozie Linux - Kernel 0 10-23-2006 06:00 PM
Suse 10 installation on system w/2 Sata disks itwasburke Linux - Newbie 1 04-05-2006 01:25 AM
After adding ide to SATA(via) machine, boot fails - Fedora core 2 Jemsquash Linux - Hardware 6 09-21-2004 09:41 AM


All times are GMT -5. The time now is 06:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration