DebianThis forum is for the discussion of Debian Linux.
Welcome to LinuxQuestions.org, a friendly and active Linux Community.
You are currently viewing LQ as a guest. By joining our community you will have the ability to post topics, receive our newsletter, use the advanced search, subscribe to threads and access many other special features. Registration is quick, simple and absolutely free. Join our community today!
Note that registered members see fewer ads, and ContentLink is completely disabled once you log in.
If you have any problems with the registration process or your account login, please contact us. If you need to reset your password, click here.
Having a problem logging in? Please visit this page to clear all LQ-related cookies.
Introduction to Linux - A Hands on Guide
This guide was created as an overview of the Linux Operating System, geared toward new users as an exploration tour and getting started guide, with exercises at the end of each chapter.
For more advanced trainees it can be a desktop reference, and a collection of the base knowledge needed to proceed with system and network administration. This book contains many real life examples derived from the author's experience as a Linux system and network administrator, trainer and consultant. They hope these examples will help you to get a better understanding of the Linux system and that you feel encouraged to try out things on your own.
Click Here to receive this Complete Guide absolutely free.
I use the woody stable build on my server. And a few months ago I decided to try php5 RC1. But to do so I had to have a newer libc6 and so on. I foolishly installed libc6 from the unstable release, and some other packages needed too. It still didn't work very well, but I did manage to compile it. Installing it afterwards was no big success however and so I dropped it.
Now a few months later I want to restore the old libc6 2.2.5-11.5 (current version is glibc-2.3.2.ds1-11). However the new libc6 depends on libdb1-compat (2.1.3-7 is installed), which is incompatible with libc6 prior to 2.2.5-13.
When I try to install the old libc6 with apt-get it says I have the newest version. I then try dpkg instead and it fails trying to overwrite /lib/libdb1-2.2.5.so which is supplied by libdb1-compat too.
And so the question:
Is it safe to remove libdb1-compat with dpkg and then install libc6 without incident? Or is there possibly some option to remove libdb1-compat and install libc6 at the same time that I may have overlooked?