LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Lenny will not autoconfigure X (http://www.linuxquestions.org/questions/debian-26/lenny-will-not-autoconfigure-x-707742/)

Leon W. Malinofsky 02-26-2009 11:25 AM

Lenny will not autoconfigure X
 
Can't figure this one out. I've reconfigured xserver-xorg, tried dexconf (though not sure if I ran it right), and still my xorg.conf file in /etc/X11 is basically bare. I can find no logfile in /var/log after X crashes on startup. I use an ATI Radeon 1600 card which I understand later may need a special driver, but for now, what can I do to get X to autoconfigure? Many thanks for any help.

farslayer 02-26-2009 11:43 AM

The xorg.conf file is basically empty on the system now as everything is handled by autodetection.

I'm surprised there is no log file though it should be /var/log/Xorg.0.log

When you ran dpkg-reconfigre xserver-xorg what did you choose as your display driver ? Have you tried selecting vesa ?

http://wiki.debian.org/ATIProprietary



.
.

Leon W. Malinofsky 02-26-2009 11:56 AM

Right, there was no log.

When I did the reconfigure there was just a pause and return to the command line.

I used Debian 500 Stable DVD1 to install and selected Desktop as my installation type.

I wonder whether I installed the whole darn thing wrong?

farslayer 02-26-2009 03:26 PM

Well first check what is installed for X

Code:

user@it-lenny:~$ aptitude search ~i | grep xorg

i  xorg                            - X.Org X Window System                   
i  xorg-docs                      - Miscellaneous documentation for the X.Org
i A xserver-xorg                    - the X.Org X server                       
i A xserver-xorg-core              - Xorg X server - core server             
i  xserver-xorg-input-all          - the X.Org X server -- input driver metapac
i A xserver-xorg-input-evdev        - X.Org X server -- evdev input driver     
i A xserver-xorg-input-kbd          - X.Org X server -- keyboard input driver 
i A xserver-xorg-input-mouse        - X.Org X server -- mouse input driver     
i A xserver-xorg-input-synaptics    - Synaptics TouchPad driver for X.Org/XFree8
i A xserver-xorg-input-wacom        - X.Org X server -- Wacom input driver     
i  xserver-xorg-video-ati          - X.Org X server -- ATI display driver wrapp
i A xserver-xorg-video-dummy        - X.Org X server -- dummy display driver   
i A xserver-xorg-video-fbdev        - X.Org X server -- fbdev display driver   
i A xserver-xorg-video-mach64      - X.Org X server -- ATI Mach64 display drive
i A xserver-xorg-video-r128        - X.Org X server -- ATI r128 display driver
i A xserver-xorg-video-radeon      - X.Org X server -- ATI Radeon display drive
i A xserver-xorg-video-v4l          - X.Org X server -- Video 4 Linux display dr
i A xserver-xorg-video-vesa        - X.Org X server -- VESA display driver   
i A xserver-xorg-video-vga          - X.Org X server -- VGA display driver     
i A xserver-xorg-video-vmware      - X.Org X server -- VMware display driver

Manually edit your xorg.conf and change the Device section so the driver is vesa

Code:

Section "Device"
        Identifier        "ATI Technologies Inc RC410 [Radeon Xpress 200]"
        Driver                "vesa"
EndSection

Lets see if we can get some basic graphics up on the screeen start up the xserver (startx)

Leon W. Malinofsky 02-26-2009 05:17 PM

Well, I am wondering whether my install included xorg at all? I thought I told the installer to do a full desktop installation, but when I do

aptitude search i~ |grep xorg

the response is nothing. Therefore I am guessing it is unsurprising adding Driver "vesa" to my xorg.conf was useless.

Could this be because xorg is on DVD2 and I scanned only DVD1? Or would it help to add some repositories. Really puzzled here.

Many thanks,

Leon Malinofsky

Telemachos 02-26-2009 05:29 PM

Quote:

Originally Posted by Leon W. Malinofsky (Post 3458667)
Well, I am wondering whether my install included xorg at all? I thought I told the installer to do a full desktop installation, but when I do

aptitude search i~ |grep xorg

the response is nothing. Therefore I am guessing it is unsurprising adding Driver "vesa" to my xorg.conf was useless.

Could this be because xorg is on DVD2 and I scanned only DVD1? Or would it help to add some repositories. Really puzzled here.

Many thanks,

Leon Malinofsky

Two things:
  • You're not scanning the dvds, you're checking if a package is installed on your system.
  • The command is this:
    Code:

    aptitude search ~i | grep xorg
    The order of ~ and i matters.
Try that command again, or try this (same thing but briefer):
Code:

aptitude search ~ixorg

Leon W. Malinofsky 02-26-2009 06:21 PM

Here it is: (I wish I knew how to use a scroll window for code like I see you doing.)

i xorg - X.Org X Window System
i A xserver-xorg - the X.Org X server
i A xserver-xorg-core - Xorg X server - core server
i xserver-xorg-input-all - the X.Org X server -- input driver metapac
i A xserver-xorg-input-evdev - X.Org X server -- evdev input driver
i A xserver-xorg-input-kbd - X.Org X server -- keyboard input driver
i A xserver-xorg-input-mouse - X.Org X server -- mouse input driver
i A xserver-xorg-input-synaptics - Synaptics TouchPad driver for X.Org/XFree8
i A xserver-xorg-input-wacom - X.Org X server -- Wacom input driver
i xserver-xorg-video-all - the X.Org X server -- output driver metapa
i A xserver-xorg-video-apm - X.Org X server -- APM display driver
i A xserver-xorg-video-ark - X.Org X server -- ark display driver
i A xserver-xorg-video-ati - X.Org X server -- ATI display driver wrapp
i A xserver-xorg-video-chips - X.Org X server -- Chips display driver
i A xserver-xorg-video-cirrus - X.Org X server -- Cirrus display driver
i A xserver-xorg-video-cyrix - X.Org X server -- Cyrix display driver
i A xserver-xorg-video-dummy - X.Org X server -- dummy display driver
i A xserver-xorg-video-fbdev - X.Org X server -- fbdev display driver
i A xserver-xorg-video-glint - X.Org X server -- Glint display driver
i A xserver-xorg-video-i128 - X.Org X server -- i128 display driver
i A xserver-xorg-video-i740 - X.Org X server -- i740 display driver
i A xserver-xorg-video-imstt - X.Org X server -- IMSTT display driver
i A xserver-xorg-video-intel - X.Org X server -- Intel i8xx, i9xx display
i A xserver-xorg-video-mach64 - X.Org X server -- ATI Mach64 display drive
i A xserver-xorg-video-mga - X.Org X server -- MGA display driver
i A xserver-xorg-video-neomagic - X.Org X server -- Neomagic display driver
i A xserver-xorg-video-nsc - X.Org X server -- NSC Geode GX1 display dr
i A xserver-xorg-video-nv - X.Org X server -- NV display driver
i A xserver-xorg-video-openchrome - X.Org X server -- VIA display driver
i A xserver-xorg-video-r128 - X.Org X server -- ATI r128 display driver
i A xserver-xorg-video-radeon - X.Org X server -- ATI Radeon display drive
i xserver-xorg-video-radeonhd - X.Org X server -- AMD/ATI r5xx, r6xx displ
i A xserver-xorg-video-rendition - X.Org X server -- Rendition display driver
i A xserver-xorg-video-s3 - X.Org X server -- legacy S3 display driver
i A xserver-xorg-video-s3virge - X.Org X server -- S3 ViRGE display driver
i A xserver-xorg-video-savage - X.Org X server -- Savage display driver
i A xserver-xorg-video-siliconmotio - X.Org X server -- SiliconMotion display dr
i A xserver-xorg-video-sis - X.Org X server -- SiS display driver
i A xserver-xorg-video-sisusb - X.Org X server -- SiS USB display driver
i A xserver-xorg-video-tdfx - X.Org X server -- tdfx display driver
i A xserver-xorg-video-tga - X.Org X server -- TGA display driver
i A xserver-xorg-video-trident - X.Org X server -- Trident display driver
i A xserver-xorg-video-tseng - X.Org X server -- Tseng display driver
i A xserver-xorg-video-v4l - X.Org X server -- Video 4 Linux display dr
i A xserver-xorg-video-vesa - X.Org X server -- VESA display driver
i A xserver-xorg-video-vga - X.Org X server -- VGA display driver
i A xserver-xorg-video-vmware - X.Org X server -- VMware display driver
i A xserver-xorg-video-voodoo - X.Org X server -- Voodoo display driver

Leon W. Malinofsky 02-26-2009 06:29 PM

I thought ahead a bit and believed you might find it valuable to see the xorg.conf that is in my /etc/X11 directory. (I see how to insert code now.)

Code:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#  sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
        Identifier        "Generic Keyboard"
        Driver                "kbd"
        Option                "XkbRules"        "xorg"
        Option                "XkbModel"        "pc104"
        Option                "XkbLayout"        "us"
EndSection

Section "InputDevice"
        Identifier        "Configured Mouse"
        Driver                "mouse"
EndSection

Section "Device"
        Identifier        "Configured Video Device"
        Driver                "vesa"
EndSection

Section "Monitor"
        Identifier        "Configured Monitor"
EndSection

Section "Screen"
        Identifier        "Default Screen"
        Monitor                "Configured Monitor"
EndSection


Leon W. Malinofsky 02-26-2009 06:54 PM

Aha!
 
I found Xlog.

Code:



(==) Log file: "/var/log/Xorg.0.log", Time: Thu Feb 26 17:14:29 2009
(==) Using config file: "/etc/X11/xorg.conf"
(==) No Layout section.  Using the first Screen section.
(**) |-->Screen "Default Screen" (0)
(**) |  |-->Monitor "Configured Monitor"
(==) No device specified for screen "Default Screen".
        Using the first device section listed.
(**) |  |-->Device "Configured Video Device"
(==) |-->Input Device "Configured Mouse"
(==) |-->Input Device "Generic Keyboard"
(==) The core pointer device wasn't specified explicitly in the layout.
        Using the first mouse device.
(==) The core keyboard device wasn't specified explicitly in the layout.
        Using the first keyboard device.
(==) Automatically adding devices
(==) Automatically enabling devices
(==) No FontPath specified.  Using compiled-in default.
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
        Entry deleted from font path.
(==) FontPath set to:
        /usr/share/fonts/X11/misc,
        /usr/share/fonts/X11/100dpi/:unscaled,
        /usr/share/fonts/X11/75dpi/:unscaled,
        /usr/share/fonts/X11/Type1,
        /usr/share/fonts/X11/100dpi,
        /usr/share/fonts/X11/75dpi,
        /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType
(==) RgbPath set to "/etc/X11/rgb"
(==) ModulePath set to "/usr/lib/xorg/modules"
(II) Open ACPI successful (/var/run/acpid.socket)
(II) Loader magic: 0x81e38c0
(II) Module ABI versions:
        X.Org ANSI C Emulation: 0.3
        X.Org Video Driver: 2.0
        X.Org XInput driver : 2.0
        X.Org Server Extension : 0.3
        X.Org Font Renderer : 0.5
(II) Loader running on linux
(II) LoadModule: "pcidata"
(II) Loading /usr/lib/xorg/modules//libpcidata.so
(II) Module pcidata: vendor="X.Org Foundation"
        compiled for 1.4.2, module version = 1.0.0
        ABI class: X.Org Video Driver, version 2.0
(++) using VT number 7

(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 1106,0308 card 1849,0308 rev 00 class 06,00,00 hdr 80

[lines deleted by submitter]

(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
        compiled for 1.4.2, module version = 1.0.0
        Module class: X.Org Server Extension
        ABI class: X.Org Server Extension, version 0.3
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
        compiled for 1.4.2, module version = 1.0.0
        Module class: X.Org Server Extension
        ABI class: X.Org Server Extension, version 0.3
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="X.Org Foundation"
        compiled for 1.4.2, module version = 1.0.0
        ABI class: X.Org Server Extension, version 0.3
(==) AIGLX enabled
(II) Loading extension GLX
(II) LoadModule: "freetype"
(II) Loading /usr/lib/xorg/modules//fonts/libfreetype.so
(II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
        compiled for 1.4.2, module version = 2.1.0
        Module class: X.Org Font Renderer
        ABI class: X.Org Font Renderer, version 0.5
(II) Loading font FreeType
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions//librecord.so
(II) Module record: vendor="X.Org Foundation"
        compiled for 1.4.2, module version = 1.13.0
        Module class: X.Org Server Extension
        ABI class: X.Org Server Extension, version 0.3
(II) Loading extension RECORD
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
        compiled for 1.4.2, module version = 1.0.0
        ABI class: X.Org Server Extension, version 0.3
(II) Loading extension XFree86-DRI
(II) LoadModule: "vesa"
(II) Loading /usr/lib/xorg/modules/drivers//vesa_drv.so
(II) Module vesa: vendor="X.Org Foundation"
        compiled for 1.4.0, module version = 1.3.0
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 2.0
(II) LoadModule: "mouse"
(II) Loading /usr/lib/xorg/modules/input//mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
        compiled for 1.4.0.90, module version = 1.3.0
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 2.0
(II) LoadModule: "kbd"
(II) Loading /usr/lib/xorg/modules/input//kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"
        compiled for 1.4.0.90, module version = 1.3.1
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 2.0
(II) VESA: driver for VESA chipsets: vesa
(II) Primary Device is: PCI 02:00:0
(--) Assigning device section with no busID to primary device
(--) Chipset vesa found
(II) resource ranges after xf86ClaimFixedResources() call:
        [0] -1        0        0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
        [1] -1        0        0x000f0000 - 0x000fffff (0x10000) MX[B]
        [2] -1        0        0x000c0000 - 0x000effff (0x30000) MX[B]
        [3] -1        0        0x00000000 - 0x0009ffff (0xa0000) MX[B]
        [4] -1        0        0xff5fc000 - 0xff5fffff (0x4000) MX[B]
        [5] -1        0        0xff6ffc00 - 0xff6ffcff (0x100) MX[B]
        [6] -1        0        0xff6ff800 - 0xff6ff8ff (0x100) MX[B]
        [7] -1        0        0xff6fe000 - 0xff6fefff (0x1000) MX[B]
        [8] -1        0        0xf8000000 - 0xf7ffffff (0x0) MX[B]O
        [9] -1        0        0xff4e0000 - 0xff4effff (0x10000) MX[B](B)
        [10] -1        0        0xff4c0000 - 0xff4dffff (0x20000) MX[B](B)
        [11] -1        0        0xff4f0000 - 0xff4fffff (0x10000) MX[B](B)
        [12] -1        0        0xc0000000 - 0xcfffffff (0x10000000) MX[B](B)
        [13] -1        0        0x0000ffff - 0x0000ffff (0x1) IX[B]
        [14] -1        0        0x00000000 - 0x000000ff (0x100) IX[B]
        [15] -1        0        0x0000e800 - 0x0000e8ff (0x100) IX[B]
        [16] -1        0        0x0000ec00 - 0x0000ec1f (0x20) IX[B]
        [17] -1        0        0x0000e480 - 0x0000e49f (0x20) IX[B]
        [18] -1        0        0x0000e400 - 0x0000e41f (0x20) IX[B]
        [19] -1        0        0x0000e080 - 0x0000e09f (0x20) IX[B]
        [20] -1        0        0x0000fc00 - 0x0000fc0f (0x10) IX[B]
        [21] -1        0        0x0000d000 - 0x0000d0ff (0x100) IX[B]
        [22] -1        0        0x0000d480 - 0x0000d48f (0x10) IX[B]
        [23] -1        0        0x0000d800 - 0x0000d803 (0x4) IX[B]
        [24] -1        0        0x0000d880 - 0x0000d887 (0x8) IX[B]
        [25] -1        0        0x0000dc00 - 0x0000dc03 (0x4) IX[B]
        [26] -1        0        0x0000e000 - 0x0000e007 (0x8) IX[B]
        [27] -1        0        0x0000c000 - 0x0000c0ff (0x100) IX[B](B)
(II) resource ranges after probing:
        [0] -1        0        0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
        [1] -1        0        0x000f0000 - 0x000fffff (0x10000) MX[B]
        [2] -1        0        0x000c0000 - 0x000effff (0x30000) MX[B]
        [3] -1        0        0x00000000 - 0x0009ffff (0xa0000) MX[B]
        [4] -1        0        0xff5fc000 - 0xff5fffff (0x4000) MX[B]
        [5] -1        0        0xff6ffc00 - 0xff6ffcff (0x100) MX[B]
        [6] -1        0        0xff6ff800 - 0xff6ff8ff (0x100) MX[B]
        [7] -1        0        0xff6fe000 - 0xff6fefff (0x1000) MX[B]
        [8] -1        0        0xf8000000 - 0xf7ffffff (0x0) MX[B]O
        [9] -1        0        0xff4e0000 - 0xff4effff (0x10000) MX[B](B)
        [10] -1        0        0xff4c0000 - 0xff4dffff (0x20000) MX[B](B)
        [11] -1        0        0xff4f0000 - 0xff4fffff (0x10000) MX[B](B)
        [12] -1        0        0xc0000000 - 0xcfffffff (0x10000000) MX[B](B)
        [13] 0        0        0x000a0000 - 0x000affff (0x10000) MS[B]
        [14] 0        0        0x000b0000 - 0x000b7fff (0x8000) MS[B]
        [15] 0        0        0x000b8000 - 0x000bffff (0x8000) MS[B]
        [16] -1        0        0x0000ffff - 0x0000ffff (0x1) IX[B]
        [17] -1        0        0x00000000 - 0x000000ff (0x100) IX[B]
        [18] -1        0        0x0000e800 - 0x0000e8ff (0x100) IX[B]
        [19] -1        0        0x0000ec00 - 0x0000ec1f (0x20) IX[B]
        [20] -1        0        0x0000e480 - 0x0000e49f (0x20) IX[B]
        [21] -1        0        0x0000e400 - 0x0000e41f (0x20) IX[B]
        [22] -1        0        0x0000e080 - 0x0000e09f (0x20) IX[B]
        [23] -1        0        0x0000fc00 - 0x0000fc0f (0x10) IX[B]
        [24] -1        0        0x0000d000 - 0x0000d0ff (0x100) IX[B]
        [25] -1        0        0x0000d480 - 0x0000d48f (0x10) IX[B]
        [26] -1        0        0x0000d800 - 0x0000d803 (0x4) IX[B]
        [27] -1        0        0x0000d880 - 0x0000d887 (0x8) IX[B]
        [28] -1        0        0x0000dc00 - 0x0000dc03 (0x4) IX[B]
        [29] -1        0        0x0000e000 - 0x0000e007 (0x8) IX[B]
        [30] -1        0        0x0000c000 - 0x0000c0ff (0x100) IX[B](B)
        [31] 0        0        0x000003b0 - 0x000003bb (0xc) IS[B]
        [32] 0        0        0x000003c0 - 0x000003df (0x20) IS[B]
(II) Setting vga for screen 0.
(II) Loading sub module "vbe"
(II) LoadModule: "vbe"
(II) Loading /usr/lib/xorg/modules//libvbe.so
(II) Module vbe: vendor="X.Org Foundation"
        compiled for 1.4.2, module version = 1.1.0
        ABI class: X.Org Video Driver, version 2.0
(II) Loading sub module "int10"
(II) LoadModule: "int10"
(II) Loading /usr/lib/xorg/modules//libint10.so
(II) Module int10: vendor="X.Org Foundation"
        compiled for 1.4.2, module version = 1.0.0
        ABI class: X.Org Video Driver, version 2.0
(II) VESA(0): initializing int10
(II) VESA(0): Primary V_BIOS segment is: 0xc000
(II) VESA(0): VESA BIOS detected
(II) VESA(0): VESA VBE Version 3.0
(II) VESA(0): VESA VBE Total Mem: 16384 kB
(II) VESA(0): VESA VBE OEM: ATI ATOMBIOS
(II) VESA(0): VESA VBE OEM Software Rev: 9.12
(II) VESA(0): VESA VBE OEM Vendor: (C) 1988-2005, ATI Technologies Inc.
(II) VESA(0): VESA VBE OEM Product: RV530
(II) VESA(0): VESA VBE OEM Product Rev: 01.00
(II) VESA(0): Creating default Display subsection in Screen section
        "Default Screen" for depth/fbbpp 16/16
(==) VESA(0): Depth 16, (--) framebuffer bpp 16
(==) VESA(0): RGB weight 565
(==) VESA(0): Default visual is TrueColor
(==) VESA(0): Using gamma correction (1.0, 1.0, 1.0)
(II) Loading sub module "ddc"
(II) LoadModule: "ddc"(II) Module "ddc" already built-in
(II) VESA(0): VESA VBE DDC supported
(II) VESA(0): VESA VBE DDC Level 2
(II) VESA(0): VESA VBE DDC transfer in appr. 1 sec.
(II) VESA(0): VESA VBE DDC read successfully
(II) VESA(0): Manufacturer: KVM  Model: 2004  Serial#: 16843009
(II) VESA(0): Year: 2004  Week: 21
(II) VESA(0): EDID Version: 1.3
(II) VESA(0): Digital Display Input
(II) VESA(0): Max H-Image Size [cm]: horiz.: 30  vert.: 23
(II) VESA(0): Gamma: 2.20
(II) VESA(0): DPMS capabilities: Off; RGB/Color Display
(II) VESA(0): First detailed timing is preferred mode
(II) VESA(0): redX: 0.600 redY: 0.342  greenX: 0.295 greenY: 0.571
(II) VESA(0): blueX: 0.148 blueY: 0.112  whiteX: 0.313 whiteY: 0.329
(II) VESA(0): Supported VESA Video Modes:
(II) VESA(0): 720x400@70Hz
(II) VESA(0): 640x480@60Hz
(II) VESA(0): 640x480@67Hz
(II) VESA(0): 640x480@72Hz
(II) VESA(0): 640x480@75Hz
(II) VESA(0): 800x600@56Hz
(II) VESA(0): 800x600@60Hz
(II) VESA(0): 800x600@72Hz
(II) VESA(0): 800x600@75Hz
(II) VESA(0): 832x624@75Hz
(II) VESA(0): 1024x768@60Hz
(II) VESA(0): 1024x768@70Hz
(II) VESA(0): 1024x768@75Hz
(II) VESA(0): Manufacturer's mask: 0
(II) VESA(0): Supported Future Video Modes:
(II) VESA(0): #0: hsize: 1024  vsize 768  refresh: 60  vid: 16481
(II) VESA(0): #1: hsize: 640  vsize 400  refresh: 60  vid: 49
(II) VESA(0): Supported additional Video Mode:
(II) VESA(0): clock: 65.0 MHz  Image Size:  304 x 228 mm
(II) VESA(0): h_active: 1024  h_sync: 1048  h_sync_end 1184 h_blank_end 1344 h_border: 0
(II) VESA(0): v_active: 768  v_sync: 771  v_sync_end 777 v_blanking: 806 v_border: 0
(II) VESA(0): Serial No: 20040507V100
(II) VESA(0): Ranges: V min: 50  V max: 75 Hz, H min: 30  H max: 62 kHz, PixClock max 90 MHz
(II) VESA(0): Monitor name: KVM Monitor
(II) VESA(0): EDID (in hex):
(II) VESA(0):        00ffffffffffff002ecd042001010101
(II) VESA(0):        150e0103801e17782aa93599574b9226
(II) VESA(0):        1c5054bfee0061403100010101010101
(II) VESA(0):        01010101010164190040410026301888
(II) VESA(0):        360030e410000018000000ff00323030
(II) VESA(0):        3430353037563130300a000000fd0032
(II) VESA(0):        4b1e3e09000a202020202020000000fc
(II) VESA(0):        004b564d204d6f6e69746f720a20009c
(II) VESA(0): EDID vendor "KVM", prod id 8196
(II) VESA(0): Using EDID range info for horizontal sync
(II) VESA(0): Using EDID range info for vertical refresh
(II) VESA(0): Printing DDC gathered Modelines:
(II) VESA(0): Modeline "1024x768"x0.0  65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz)
(II) VESA(0): Modeline "800x600"x0.0  40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz)
(II) VESA(0): Modeline "800x600"x0.0  36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz)
(II) VESA(0): Modeline "640x480"x0.0  31.50  640 656 720 840  480 481 484 500 -hsync -vsync (37.5 kHz)
(II) VESA(0): Modeline "640x480"x0.0  31.50  640 664 704 832  480 489 491 520 -hsync -vsync (37.9 kHz)
(II) VESA(0): Modeline "640x480"x0.0  30.24  640 704 768 864  480 483 486 525 -hsync -vsync (35.0 kHz)
(II) VESA(0): Modeline "640x480"x0.0  25.20  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz)
(II) VESA(0): Modeline "720x400"x0.0  28.32  720 738 846 900  400 412 414 449 -hsync +vsync (31.5 kHz)
(II) VESA(0): Modeline "1024x768"x0.0  78.80  1024 1040 1136 1312  768 769 772 800 +hsync +vsync (60.1 kHz)
(II) VESA(0): Modeline "1024x768"x0.0  75.00  1024 1048 1184 1328  768 771 777 806 -hsync -vsync (56.5 kHz)
(II) VESA(0): Modeline "1024x768"x0.0  65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz)
(II) VESA(0): Modeline "832x624"x0.0  57.28  832 864 928 1152  624 625 628 667 -hsync -vsync (49.7 kHz)
(II) VESA(0): Modeline "800x600"x0.0  49.50  800 816 896 1056  600 601 604 625 +hsync +vsync (46.9 kHz)
(II) VESA(0): Modeline "800x600"x0.0  50.00  800 856 976 1040  600 637 643 666 +hsync +vsync (48.1 kHz)
(II) VESA(0): Modeline "1024x768"x59.9  63.50  1024 1072 1176 1328  768 771 775 798 -hsync +vsync (47.8 kHz)
(II) VESA(0): Modeline "640x400"x60.0  20.00  640 664 720 800  400 403 409 417 -hsync +vsync (25.0 kHz)
(II) VESA(0): Searching for matching VESA mode(s):

Mode: 105 (1024x768)
        ModeAttributes: 0xbb
        WinAAttributes: 0x7
        WinBAttributes: 0x0
        WinGranularity: 64
        WinSize: 64
        WinASegment: 0xa000
        WinBSegment: 0x0
        WinFuncPtr: 0xc0004f6f
        BytesPerScanline: 1024
        XResolution: 1024
        YResolution: 768
        XCharSize: 8
        YCharSize: 16
        NumberOfPlanes: 1
        BitsPerPixel: 8
        NumberOfBanks: 1
        MemoryModel: 4
        BankSize: 0
        NumberOfImages: 18
        RedMaskSize: 0
        RedFieldPosition: 0
        GreenMaskSize: 0
        GreenFieldPosition: 0
        BlueMaskSize: 0
        BlueFieldPosition: 0
        RsvdMaskSize: 0
        RsvdFieldPosition: 0
        DirectColorModeInfo: 0
        PhysBasePtr: 0xc0000000
        LinBytesPerScanLine: 1024
        BnkNumberOfImagePages: 18
        LinNumberOfImagePages: 18
        LinRedMaskSize: 0
        LinRedFieldPosition: 0
        LinGreenMaskSize: 0
        LinGreenFieldPosition: 0
        LinBlueMaskSize: 0
        LinBlueFieldPosition: 0
        LinRsvdMaskSize: 0
        LinRsvdFieldPosition: 0
        MaxPixelClock: 400000000
(Lots of other modes deleted here by submitter.)

(II) VESA(0): Total Memory: 256 64KB banks (16384kB)
(II) VESA(0): Configured Monitor: Using hsync range of 30.00-62.00 kHz
(II) VESA(0): Configured Monitor: Using vrefresh range of 50.00-75.00 Hz
(II) VESA(0): Configured Monitor: Using maximum pixel clock of 90.00 MHz
(WW) VESA(0): Unable to estimate virtual size
(--) VESA(0): Virtual size is 1920x1440 (pitch 1920)
(**) VESA(0): *Built-in mode "1920x1440"
(**) VESA(0): *Built-in mode "1856x1392"
(**) VESA(0): *Built-in mode "1600x1200"
(**) VESA(0): *Built-in mode "1400x1050"
(**) VESA(0): *Built-in mode "1280x1024"
(**) VESA(0): *Built-in mode "1280x1024"
(**) VESA(0): *Built-in mode "1152x864"
(**) VESA(0): *Built-in mode "1024x768"
(**) VESA(0): *Built-in mode "800x600"
(**) VESA(0): *Built-in mode "640x480"
(**) VESA(0): *Built-in mode "720x400"
(**) VESA(0): *Built-in mode "640x400"
(**) VESA(0): *Built-in mode "640x400"
(**) VESA(0): *Built-in mode "640x350"
(**) VESA(0): *Built-in mode "512x384"
(**) VESA(0): *Built-in mode "320x240"
(**) VESA(0): *Built-in mode "320x200"
(**) VESA(0): Display dimensions: (300, 230) mm
(**) VESA(0): DPI set to (162, 159)
(II) VESA(0): Attempting to use 75Hz refresh for mode "1024x768" (117)
(II) VESA(0): Attempting to use 72Hz refresh for mode "800x600" (114)
(II) VESA(0): Attempting to use 73Hz refresh for mode "640x480" (111)
(II) VESA(0): Attempting to use 70Hz refresh for mode "720x400" (135)
(**) VESA(0): Using "Shadow Framebuffer"
(II) Loading sub module "shadow"
(II) LoadModule: "shadow"
(II) Loading /usr/lib/xorg/modules//libshadow.so
(II) Module shadow: vendor="X.Org Foundation"
        compiled for 1.4.2, module version = 1.1.0
        ABI class: X.Org ANSI C Emulation, version 0.3
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules//libfb.so
(II) Module fb: vendor="X.Org Foundation"
        compiled for 1.4.2, module version = 1.0.0
        ABI class: X.Org ANSI C Emulation, version 0.3
(II) do I need RAC?  No, I don't.
(II) resource ranges after preInit:
        [0] -1        0        0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
        [1] -1        0        0x000f0000 - 0x000fffff (0x10000) MX[B]
        [2] -1        0        0x000c0000 - 0x000effff (0x30000) MX[B]
        [3] -1        0        0x00000000 - 0x0009ffff (0xa0000) MX[B]
        [4] -1        0        0xff5fc000 - 0xff5fffff (0x4000) MX[B]
        [5] -1        0        0xff6ffc00 - 0xff6ffcff (0x100) MX[B]
        [6] -1        0        0xff6ff800 - 0xff6ff8ff (0x100) MX[B]
        [7] -1        0        0xff6fe000 - 0xff6fefff (0x1000) MX[B]
        [8] -1        0        0xf8000000 - 0xf7ffffff (0x0) MX[B]O
        [9] -1        0        0xff4e0000 - 0xff4effff (0x10000) MX[B](B)
        [10] -1        0        0xff4c0000 - 0xff4dffff (0x20000) MX[B](B)
        [11] -1        0        0xff4f0000 - 0xff4fffff (0x10000) MX[B](B)
        [12] -1        0        0xc0000000 - 0xcfffffff (0x10000000) MX[B](B)
        [13] 0        0        0x000a0000 - 0x000affff (0x10000) MS[B]
        [14] 0        0        0x000b0000 - 0x000b7fff (0x8000) MS[B]
        [15] 0        0        0x000b8000 - 0x000bffff (0x8000) MS[B]
        [16] -1        0        0x0000ffff - 0x0000ffff (0x1) IX[B]
        [17] -1        0        0x00000000 - 0x000000ff (0x100) IX[B]
        [18] -1        0        0x0000e800 - 0x0000e8ff (0x100) IX[B]
        [19] -1        0        0x0000ec00 - 0x0000ec1f (0x20) IX[B]
        [20] -1        0        0x0000e480 - 0x0000e49f (0x20) IX[B]
        [21] -1        0        0x0000e400 - 0x0000e41f (0x20) IX[B]
        [22] -1        0        0x0000e080 - 0x0000e09f (0x20) IX[B]
        [23] -1        0        0x0000fc00 - 0x0000fc0f (0x10) IX[B]
        [24] -1        0        0x0000d000 - 0x0000d0ff (0x100) IX[B]
        [25] -1        0        0x0000d480 - 0x0000d48f (0x10) IX[B]
        [26] -1        0        0x0000d800 - 0x0000d803 (0x4) IX[B]
        [27] -1        0        0x0000d880 - 0x0000d887 (0x8) IX[B]
        [28] -1        0        0x0000dc00 - 0x0000dc03 (0x4) IX[B]
        [29] -1        0        0x0000e000 - 0x0000e007 (0x8) IX[B]
        [30] -1        0        0x0000c000 - 0x0000c0ff (0x100) IX[B](B)
        [31] 0        0        0x000003b0 - 0x000003bb (0xc) IS[B]
        [32] 0        0        0x000003c0 - 0x000003df (0x20) IS[B]
(II) Loading sub module "int10"
(II) LoadModule: "int10"
(II) Reloading /usr/lib/xorg/modules//libint10.so
(II) VESA(0): initializing int10
(II) VESA(0): Primary V_BIOS segment is: 0xc000
(II) VESA(0): VESA BIOS detected
(II) VESA(0): VESA VBE Version 3.0
(II) VESA(0): VESA VBE Total Mem: 16384 kB
(II) VESA(0): VESA VBE OEM: ATI ATOMBIOS
(II) VESA(0): VESA VBE OEM Software Rev: 9.12
(II) VESA(0): VESA VBE OEM Vendor: (C) 1988-2005, ATI Technologies Inc.
(II) VESA(0): VESA VBE OEM Product: RV530
(II) VESA(0): VESA VBE OEM Product Rev: 01.00
(==) VESA(0): Write-combining range (0xc0000000,0x1000000)
(II) VESA(0): virtual address = 0xb692d000,
        physical address = 0xc0000000, size = 16777216
(==) VESA(0): Default visual is TrueColor
(==) VESA(0): Backing store disabled
(II) VESA(0): DPMS enabled
(==) RandR enabled
(II) Setting vga for screen 0.
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension XAccessControlExtension
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(II) AIGLX: Screen 0 is not DRI capable
(II) Loading sub module "GLcore"
(II) LoadModule: "GLcore"
(II) Loading /usr/lib/xorg/modules/extensions//libGLcore.so
(II) Module GLcore: vendor="X.Org Foundation"
        compiled for 1.4.2, module version = 1.0.0
        ABI class: X.Org Server Extension, version 0.3
(II) GLX: Initialized MESA-PROXY GL provider for screen 0
(WW) Configured Mouse: No Device specified, looking for one...
(II) Configured Mouse: Setting Device option to "/dev/input/mice"
(--) Configured Mouse: Device: "/dev/input/mice"
(==) Configured Mouse: Protocol: "Auto"
(**) Option "CorePointer"
(**) Configured Mouse: always reports core events
(==) Configured Mouse: Emulate3Buttons, Emulate3Timeout: 50
(**) Configured Mouse: ZAxisMapping: buttons 4 and 5
(**) Configured Mouse: Buttons: 9
(**) Configured Mouse: Sensitivity: 1
(**) Option "CoreKeyboard"
(**) Generic Keyboard: always reports core events
(**) Option "Protocol" "standard"
(**) Generic Keyboard: Protocol: standard
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xorg"
(**) Generic Keyboard: XkbRules: "xorg"
(**) Option "XkbModel" "pc104"
(**) Generic Keyboard: XkbModel: "pc104"
(**) Option "XkbLayout" "us"
(**) Generic Keyboard: XkbLayout: "us"
(**) Option "CustomKeycodes" "off"
(**) Generic Keyboard: CustomKeycodes disabled
(II) evaluating device (Configured Mouse)
(II) XINPUT: Adding extended input device "Configured Mouse" (type: MOUSE)
(II) evaluating device (Generic Keyboard)
(II) XINPUT: Adding extended input device "Generic Keyboard" (type: KEYBOARD)
(--) Configured Mouse: PnP-detected protocol: "ExplorerPS/2"

It is really easy to see now why the CODE tags are useful.

Leon W. Malinofsky 02-26-2009 07:07 PM

Under the present circumstances, when I try starting kde I get

Code:

kpersonalizer:  cannot connect to X server
and when I try gnome-session I get


Code:

(gnome-session: 3044): Gtk-WARNING **:  cannot open display:

farslayer 02-26-2009 10:16 PM

how are you trying to start Gnome and KDE ?

I don't see any Errors in your xorg.log that would prevent X from working properly.

Leon W. Malinofsky 02-26-2009 11:07 PM

Then may be it is a monitor issue-- my monitor is 1920 x 1200 resolution. Oh well, I'll keep trying to puzzle this out. I wonder if connecting the monitor via a vga plug rather than a digital interface would make a difference. Funny thing is when I boot the Lenny Live CD I get X to work just fine. Could it be something to do with my KVM switch? But then Lenny Live would not have started, I'm thinking.

To start kde I did startkde I think, and just gnome-session for gnome. If I start kdm or gdm (or startx) the screen goes black and stays that way and the trick to stop the x-server (I think it is ctrl-alt-F1 -- I usually fumble around for it) does not bring back the command line.

Thanks. I'll welcome any ideas...

Leon Malinofsky

Leon W. Malinofsky 02-27-2009 03:42 PM

Well, a VGA plug interface makes no difference, and it probably can't be a monitor issue since Lenny Live works right. Can't be KVM for the same reason. Really puzzled and would love to solve this.

Thanks,

Leon Malinofsky

Leon W. Malinofsky 02-27-2009 04:25 PM

Have discovered my video card is notorious for not working with X. Will start new thread to address. Thank you, FarSlayer, for your help, sincerely! (How does one "Thank" another?"

farslayer 02-27-2009 04:57 PM

You would click the thubs up button in the lower right corner of the helpful post..

CTRL+ALT+BACKSPACE is the command you were looking for to kill X

That is odd you would get a black screen and yet have no errors in the log.. Hmmm

When all esle fails you might want to go ahead and give the proprietary driver a shot. I've had instances where nothing but the proprietary driver works.. the link to the Debian directions are in my first response..


All times are GMT -5. The time now is 12:29 AM.