LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 09-27-2004, 02:37 AM   #1
SiLiCoN
Member
 
Registered: Sep 2004
Location: India
Distribution: Solaris 9, FreeBSD 4.10, Slackware, RedHat, Knoppix,
Posts: 84

Rep: Reputation: 15
knoppix 3.2 installation


hey everyone,
I m an absolute newbie when i m talking knoppix. the thing is i wanted to load knoppix 3.2 on my HD. i tried knx-hdinstall but its not in english (i even booted using "knopix lang=en" and also "knoppix lang=us") but the prompts still does not appear as english alphabets. So i tried the other way round

1)
made a 150MB partition (ext3) (hda5) ---- boot
made a 200MB swap partiton (hda6) ---- swap
made a 3GB partion (hda7 - ext3) ---- root

i also have win 2000 loaded on hda1

2)
copied KNOPPIX/* to hda7
(mount /dev/hda7 /mnt/hda7
cp -R /KNOPPIX/* /mnt/hda7/ )

---fine the files are all copied---

Now, this is where i m stuck up
Tried looking for grub/ under boot/ ----- did not find one
even tried looking for grub under /mnt/hda7/boot/ ----did not find it

So, as far as i understand, i am done with 70% of the process and all i need to do is set the hda5 (made it active) to boot, but what do i have to place in hda5 and where do i find those files...and what all do i have to configure after that...is there a document for it?

PS: i dont want to go for "knx-hdinstall" as i think the above process is more fun

Thanks for your help in advance
 
Old 09-27-2004, 03:31 AM   #2
Geronimo
Member
 
Registered: Aug 2004
Location: Zurich, Switzerland
Distribution: Gentoo
Posts: 52

Rep: Reputation: 15
Hi SiLiCoN

You mounted root, but I think you forgot to mount /boot...

do the following (hope I got your partitionning right...)
Code:
rm /mnt/hda7/boot/* -R
mount /dev/hda5 /mnt/hda7/boot/
cp -R /KNOPPIX/boot/* /mnt/hda7/boot/
That sould fix your problem

Greets
G.
 
Old 09-27-2004, 03:49 AM   #3
SiLiCoN
Member
 
Registered: Sep 2004
Location: India
Distribution: Solaris 9, FreeBSD 4.10, Slackware, RedHat, Knoppix,
Posts: 84

Original Poster
Rep: Reputation: 15
Hi! Geronimo,

Thanks for the help...
what u said is the 3rd step.....to copy the boot files from KNOPPIX/boot/ to /dev/hda5...ok got it!

but dont i have to modify any settings inside the new /boot (on /dev/hda5)....
I already made the partition (/dev/hda5) active

Now that leaves me with two questions :

how do i get the bootloader to give me an option of windows too? (hd0,0) or (/dev/hda1)

is it possible for /dev/hda5 to be in logical partition? i mean if the /boot files are in logical partition will there be any problem - i am talking about (/dev/hda5)...

thanks
 
Old 09-27-2004, 05:27 AM   #4
Geronimo
Member
 
Registered: Aug 2004
Location: Zurich, Switzerland
Distribution: Gentoo
Posts: 52

Rep: Reputation: 15
I cant remember if I tried that already... but I think it should work...

My netry for Windows in /boot/grub/menu.lst:
Code:
title=Windows XP
root (hd0,1)
chainloader +1
Change title=Windows XP to title=<What ever you like>
Change root (hd0,1) to root (hd0,0)... thats grub syntacs

As for the rest I am not sure... For linux you should have something like
Code:
title=<Linux>
kernel (hd0,4)/<Linux-kernel> root=/dev/hda5
Those two lines are nescessary, if there are more then its ok

Greets
G.

PS. If you are not sure, if everyting is fine, post your menu.lst here
 
Old 09-27-2004, 04:05 PM   #5
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,016

Rep: Reputation: 51
"i even booted using "knopix lang=en"

shouldn't the cheatcode be:

knoppix lang=en

when i installed 3.2 to the hd, it worked perfectly, according to their website, it only installs the partitions root and swap, no boot or home.

check the article in distrowatch.com:

Knoppix: Instant Gratification

Last edited by macondo; 09-27-2004 at 04:10 PM.
 
Old 09-28-2004, 01:16 AM   #6
SiLiCoN
Member
 
Registered: Sep 2004
Location: India
Distribution: Solaris 9, FreeBSD 4.10, Slackware, RedHat, Knoppix,
Posts: 84

Original Poster
Rep: Reputation: 15
oh sorry it was "knoppix lang=en"
but the annoying fact is that when i do "knx-hdinstall" it still does not display the prompts in english (?)
also i am trying to set up the system by my own to know the details of the working process of linux - is that bad ? (j/k)

well this is where i m

i installed grub in /dev/hda5

#mount /dev/hda8 /mnt/hda8
#mount /dev/hda5 /mnt/hda8/boot/
# grub --root-directory=/mnt/hda8 /dev/hda

-----> fine, grub gets installed in /mnt/hda5 or /dev/hda5
now, in /mnt/hda5/grub/, there is no grub.conf or menu.lst (?) but all the other files needed. I manually created the grub.conf

now when i start my computer....BIOS comes up and then it lands up in a grub prompt...
grub>
this is what i do
_________________________________________________
grub> kernel (hd0,4)/vmlinuz init=(hd0,6)/etc/init
(it finds and loads the kernel)
grub>boot
_________________________________________________

it starts booting up (thank God!)
but ends up saying

kernel panic: No init process found try passing the init= option to the kernel

i swear i did specify the init=(hd0,6)/etc/init as a kernel option, am i passing the right path or do i need to refer to some other "init"?

thanks
 
Old 09-28-2004, 04:27 AM   #7
Geronimo
Member
 
Registered: Aug 2004
Location: Zurich, Switzerland
Distribution: Gentoo
Posts: 52

Rep: Reputation: 15
init load a specific a runlevel....
So i think you could leave it out

typical runlevels are
5: normal start up with X
3: normal start up without X
0: Shutdown
6: Reboot
S: Single User Mode (maintanence only)

So; to start you Linux-box
Code:
grub> kernel (hd0,4)/vmlinuz
grub> boot
should be enough

grub.conf is a link to menu.lst (normally)...

Greets
G.
 
Old 09-28-2004, 05:09 AM   #8
SiLiCoN
Member
 
Registered: Sep 2004
Location: India
Distribution: Solaris 9, FreeBSD 4.10, Slackware, RedHat, Knoppix,
Posts: 84

Original Poster
Rep: Reputation: 15
hi Geronimo,

that's exactly what i did
grub> kernel (hd0,4)/vmlinuz
grub> boot

and it starts booting....
locates my HDD
located CD drive (mounts it)...everything goes fine until it comes up with the messege

kernel panic: No init process found try passing the init= option to the kernel

any clues (?)

i even tried

grub>kernel (hd0,4)/vmlinuz init=(hd0,6)/etc/init

but still it ends up in the same error messege

am i loading the wrong init or do i have to pass the kernel option in a different way or is it some other problem all together?

oh just forgot: when i load knoppix from the CD (i mean when i boot it from the CD and run it from the CD)
i did check

#dmesg | grub init

i do get
init=/etc/init
so i guess /etc/init is the init i want to send as an option to the kernel....that's why i tried

grub>kernel (hd0,4)/vmlinuz init=(hd0,6)/etc/init

but still no luck...

thanks
 
Old 09-28-2004, 05:37 AM   #9
SiLiCoN
Member
 
Registered: Sep 2004
Location: India
Distribution: Solaris 9, FreeBSD 4.10, Slackware, RedHat, Knoppix,
Posts: 84

Original Poster
Rep: Reputation: 15
oh one more thing,

when i checked
dmesg| grub init

it also gave me

initrd=miniboot.gz

now how do i set that from the grub prompt.....
i tried locating miniboot.gz file on my hD but couldnt find it....

is the problem because i m not setting initrd to miniboot.gz
and if i have to , then please let me know the path

thanks
 
Old 09-28-2004, 08:36 AM   #10
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,016

Rep: Reputation: 51
"also i am trying to set up the system by my own to know the details of the working process of linux - is that bad ? (j/k)"

Remember: Knoppix is NOT Debian, knoppix has a compilation of sources.list repositories (woody, sarge, sid, experimental, marillat, et.al)

so do not expect it to behave as a regular Debian, the fstab is different, is supposed to be a live cd to introduce you to debian, to mount partitions and solve problems, etc.

you should try MEPIS or Kanotix, that are based on Sid exclusively.

Last edited by macondo; 09-29-2004 at 10:10 AM.
 
Old 09-28-2004, 05:26 PM   #11
psisquare
Member
 
Registered: Sep 2004
Location: Germany
Distribution: Gentoo
Posts: 164

Rep: Reputation: 31
hi SiLiCoN

Linux kernel needs to know the root device (from where it loads /sbin/init by default).
Try:
grub> root (hd0,6)
grub> kernel (hd0,4)/vmlinuz
grub> boot

By the way, you might be interested in reading Greg O'Keefe's From-PowerUp-To-Bash-Prompt-HOWTO (install one of the doc-linux-* packages once you're running or visit http://www.tldp.org/HOWTO/From-Power...mpt-HOWTO.html)
 
Old 09-29-2004, 01:12 AM   #12
SiLiCoN
Member
 
Registered: Sep 2004
Location: India
Distribution: Solaris 9, FreeBSD 4.10, Slackware, RedHat, Knoppix,
Posts: 84

Original Poster
Rep: Reputation: 15
hi psisquare,

i figured out the problem....it was due to NOT setting the "initrd" had to do a lot of research just to findout to extract boot.img to floppy and then copy miniroot.gz to (hd0,4).
Ok, well here i m

i get grub well and fine with options to load Linux or windows
windows loads up fine
linux also starts loading up
the init starts up, mounts the drives (i did modify /etc/fstab)
and i get the messege "Welcome to KNOPPIX Live on CD"
and then does a scan on my HDD and CDROM
and ends up saying (in RED)
"Can'f find KNOPPIX filesystem
Dropping you to a (very limited) shell
Press restart to reboot"

and leaves me with a shell which can do nothing ....

Any clues about where i m going wrong?
 
Old 09-29-2004, 05:23 AM   #13
psisquare
Member
 
Registered: Sep 2004
Location: Germany
Distribution: Gentoo
Posts: 164

Rep: Reputation: 31
i'm not 100% sure about knoppix's boot-up procedure, but miniroot.gz seems to contain a minimal file system which gets loaded into ram and is meant to enable Linux to access your cdrom. I don't think this is the way you want to go, since booting from HD is generally much easier than from CD.
you definitely don't _need_ an initrd for this, as long as your kernel recognizes your HD and has built-in support for ext3 (I think Knoppix standard kernels have).

i just checked my own grub setup and found some extra kernel options. check that you've got /sbin/init on hda7 and run

grub> root (hd0,6)
grub> kernel (hd0,4)/vmlinuz root=/dev/hda7 ro
grub> boot

successfully tested this on my system (with my partitions of course)
 
Old 09-30-2004, 02:04 AM   #14
SiLiCoN
Member
 
Registered: Sep 2004
Location: India
Distribution: Solaris 9, FreeBSD 4.10, Slackware, RedHat, Knoppix,
Posts: 84

Original Poster
Rep: Reputation: 15
hi psisquare,
Bingo! u were right..... miniroot.gz points to the init which is located in the KNOPPIX filesystem in the CD - so i WAS going the wrong way...
deleted "initrd = miniroot.gz" entry from grub.conf and
grub> root (hd0,6)
grub> kernel (hd0,4)/vmlinuz root=/dev/hda7 ro init=/etc/init lang=en
grub> boot

is my present grub configuration - boots up fine but the root filesystem mounts as read only --- i cant change anything in it?

i changed my grub.conf to
kernel (hd0,4)/vmlinuz rw root=/dev/hda7 init=/etc/init lang=en

now it does boot up fine and i CAN change the root file system

the last problem (i guess...GOD please!!!) is that i cant mount any thing other than root (/) from /etc/fstab (?)

when i do /etc/fstab it says
mount: permission denied
mount: permission denied
mount: permission denied

--------------------------/etc/fstab------------------------
LABEL=/ / ext3 default 1 1
LABEL=/boot /boot ext3 default 1 2
/dev/hda6 swap swap default 1 0
none /proc auto default 0 0
none /dev/shm auto default 0 0
____________________________________
(forget about windows partition now)

when i mount them maually (from shell) it does fine
but not during bootup from fstab

i guess there is something wrong with fstab
someone please help me ... its been 3 days now installing KNOPPIX from scratch...

thanks in advance
 
Old 09-30-2004, 06:17 AM   #15
psisquare
Member
 
Registered: Sep 2004
Location: Germany
Distribution: Gentoo
Posts: 164

Rep: Reputation: 31
hm.. that LABEL= stuff looks a bit weird. the first column of fstab should contain the partitions, so changing the first two lines to

/dev/hda7 / ext3 default 1 1
/dev/hda5 /boot ext3 default 1 2

should help. this should also make the root partition be re-mounted writable on startup; it's meant to be mounted read-only first so that it can be fsck'd automatically.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
X quits during Knoppix installation Kilahchris Linux - Newbie 4 11-08-2005 06:40 PM
Knoppix hardware installation davholla Linux - General 2 06-05-2005 03:05 PM
knoppix 3.6 installation ilyq_b Debian 2 05-16-2005 02:17 PM
webmin installation on Knoppix 3.6 hensonliu Linux - Software 1 01-13-2005 05:03 AM
Knoppix: Installation... COOLER_KING Linux - Newbie 5 03-29-2004 03:51 PM


All times are GMT -5. The time now is 09:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration