LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 11-21-2005, 09:14 AM   #1
arobic
Member
 
Registered: Jul 2003
Location: Geneva, Switzerland
Distribution: Debian 3.1, SLC3 (based on RHEL)
Posts: 84

Rep: Reputation: 15
Question Keyboard settings for xdm


I just installed Debian sarge on a Dell laptop (Inspiron 2200). It's mostly ok, except for some tuning and settings I still have to manage. One of them is the keyboard. I have a Swiss French keyboard which is recognized without problems by the command line. When I tried to start X manually (i.e. startx), I discover the setting was actually azerty (while the Swiss French keyboard is qwertz). This wasn't a big deal since xkeycaps helped me find the right key mapping and I saved it in a file which is loaded by xmodmap (in .bashrc) everytime I log in.

Now, here is the problem. X needs me to log in to recognize the keyboard. So if I use xdm to login (which I would like to do), xdm uses the azerty keyboard settings. My questions are:

- Why is it so? If the prompt is set to qwertz, it means that it most be some general setting.

- How and where can I set the keyboard (which config file or files) once and for all such that every application or package I use will use the same mapping, namely qwertz?

Thanks!
 
Old 11-21-2005, 09:17 AM   #2
fouldsy
Senior Member
 
Registered: Jan 2002
Location: St Louis, MO
Distribution: Ubuntu
Posts: 1,284

Rep: Reputation: 47
Within your xorg.conf, is there not an option to declare keyboard mappings? For example, my console would be UK, but not in X11 until I set my inputdevices section to be:
Code:
Section "InputDevice"
     Identifier "Keyboard1"
     Driver "kbd"

     Option "XkbModel" "pc104"
     Option "XkbLayout" "uk"
EndSection
 
Old 11-21-2005, 03:26 PM   #3
arobic
Member
 
Registered: Jul 2003
Location: Geneva, Switzerland
Distribution: Debian 3.1, SLC3 (based on RHEL)
Posts: 84

Original Poster
Rep: Reputation: 15
Yes indeed there is ( I just didn't think of checking there...). Since I am using Xfree86, I changed XF86.Config-4 accordingly:
Option "XkbModel" "pc105"
Option "XkbLayout" "fr-ch/latin1"

and then it works!

Thanks a lot!
 
Old 11-21-2005, 04:19 PM   #4
michapma
Member
 
Registered: Oct 2003
Location: Zürich
Distribution: Debian
Posts: 537

Rep: Reputation: 39
Since you are using X-server, the general command to reset the X settings is:

#dpkg-reconfigure xserver-xfree86

It will remember the last settings you gave. Glad it works. You might consider gathering info on the rest of your hardware (monitor, mouse, etc.) and giving more detailed settings for them, too.

See the sticky "Debian Configuration Post-Install" at the top of this forum for more good info.

Meilleures salutations de Zurich
 
Old 11-21-2005, 04:38 PM   #5
fouldsy
Senior Member
 
Registered: Jan 2002
Location: St Louis, MO
Distribution: Ubuntu
Posts: 1,284

Rep: Reputation: 47
Glad it worked! As pointed out by the previous poster, dpkg-reconfigure can be used instead, but this fires up the whole configuration for xfree86 (didn't realise you hadn't moved to xorg), which is a bit overkill for simply changing the keymap IMHO if everything else is working fine (which seems to be the case).

Enjoy being able to login properly
 
Old 11-21-2005, 04:45 PM   #6
michapma
Member
 
Registered: Oct 2003
Location: Zürich
Distribution: Debian
Posts: 537

Rep: Reputation: 39
Quote:
Originally posted by fouldsy
Glad it worked! As pointed out by the previous poster, dpkg-reconfigure can be used instead, but this fires up the whole configuration for xfree86 (didn't realise you hadn't moved to xorg), which is a bit overkill for simply changing the keymap IMHO if everything else is working fine (which seems to be the case).

Enjoy being able to login properly

He didn't move to xorg: "Since I am using Xfree86, I changed XF86.Config-4 accordingly."

Manually editing XF86Config-4 is a fine way to make changes. (Make sure you keep this file thoroughly backed up.) However, my thought was that running dpkg-reconfigure would show him some of the other settings he could optimize.
 
Old 11-22-2005, 01:31 AM   #7
arobic
Member
 
Registered: Jul 2003
Location: Geneva, Switzerland
Distribution: Debian 3.1, SLC3 (based on RHEL)
Posts: 84

Original Poster
Rep: Reputation: 15
Thanks for your comments. I actually knew about the
#dpkg-reconfigure xserver-xfree86
command (I used it to configure X for my graphics card since I had to change the driver), but that wasn't the problem here, only the keyboard in a very specific way (for xdm) was going crazy and I was going anyway for a manual edit, I just didn't remember which file it was... :-)

Quote:
Originally posted by michapma
He didn't move to xorg: "Since I am using Xfree86, I changed XF86.Config-4 accordingly."
No offense, but I am a girl... :-)

Thanks for all your input (both of you!)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Keyboard settings dagurg Linux - Newbie 1 08-10-2005 06:10 AM
keyboard settings hyperriven Mandriva 1 02-19-2005 07:48 AM
Keyboard settings VincentB Fedora 0 01-24-2005 03:07 PM
Changing US keyboard settings to Spain (SP) settings or Mexico. zLinuxz Linux - General 4 12-01-2002 01:49 AM
keyboard settings raven Linux - General 1 06-10-2002 08:00 AM


All times are GMT -5. The time now is 09:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration