LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 03-15-2014, 02:27 PM   #1
Battus
LQ Newbie
 
Registered: Aug 2011
Location: Eindhoven Netherlands
Distribution: Debian Wheezy
Posts: 15

Rep: Reputation: Disabled
Keyboard layout variant: (US, international with dead keys)


Hello,

I am using XFCE 4.8 with Debian Wheezy.

I like this setup but have one difficulty.

I cannot specify the keyboard layout variant: English (US, international with dead keys), which I want for letters like .

In XFCE, Settings | Keyboard | (Layouts tab) the bottom window allows keyboard layouts to be added, but you can only
choose from a list which does not have the one I want, and none of them have a variant filled in.
There is a column for "Variant" but it is always empty.

I don't mind editing conf files and have already found:
/etc/default/keyboard
which contains an empty XKBVARIANT="" parameter.
I have tried altering this to "intl" and lo and behold!
It works but only outside of XFCE (e.g. on say, terminal tty2)

As soon as I'm back in XFCE it doesn't work anymore so presumably the
value I changed gets overridden...

Does anyone know if XFCE does this? (I've heard GNOME and KDE do)

If anyone could throw any light on this I would much appreciate it.
Meanwhile I'll just keep searching...

Thanks,

Battus.
 
Old 03-15-2014, 07:20 PM   #2
banned alan_ri
LQ Newbie
 
Registered: Mar 2014
Distribution: Debian GNU/Linux
Posts: 4

Rep: Reputation: Disabled
https://wiki.debian.org/Keyboard

Should do. Post if does not.
 
Old 03-16-2014, 07:51 AM   #3
Battus
LQ Newbie
 
Registered: Aug 2011
Location: Eindhoven Netherlands
Distribution: Debian Wheezy
Posts: 15

Original Poster
Rep: Reputation: Disabled
[Solved] Keyboard layout: English (US, international with dead keys)

Quote:
Originally Posted by banned alan_ri View Post
https://wiki.debian.org/Keyboard

Should do. Post if does not.
Thanks. Yes that article had already helped. It led me to the /etc/default/keyboard file
which I edited to include the variant I wanted. Works a treat! but as I said earlier,
only outside of XFCE. As soon as that is restarted it's back to the old default setting for XFCE
with no variant.

But not to worry! Late last night I found a reference in the Arch Linux wiki which put me on to the answer:
"The most obvious and easiest way (to modify Xconf settings) is to go to "Settings" in the main menu and
select the category you want to customize.
However, not all customization options are available this way.
Customization can be done completely from the command line using the program xfconf-query. See the XFCE online documentation. http://docs.xfce.org/xfce/xfconf/xfconf-query".
...and they're right. It's all there. Just a question of finding it !

Dig.
 
Old 03-20-2014, 07:06 PM   #4
banned alan_ri
LQ Newbie
 
Registered: Mar 2014
Distribution: Debian GNU/Linux
Posts: 4

Rep: Reputation: Disabled
Just remember, there's always the Debian way.
 
Old 03-21-2014, 05:36 AM   #5
Battus
LQ Newbie
 
Registered: Aug 2011
Location: Eindhoven Netherlands
Distribution: Debian Wheezy
Posts: 15

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by banned alan_ri View Post
Just remember, there's always the Debian way.
You've got me there...

Please don't keep us in suspense.
Tell us all about it, so everyone can benefit...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] US International Keyboard w/Dead Keys th1bill Ubuntu 5 05-29-2011 06:31 PM
Changing non-printing keys in keyboard layout dotancohen Linux - General 8 05-13-2011 08:18 AM
International language keyboard layout tables for remapping - Where are they? richard.robin Linux - General 1 09-13-2008 05:44 PM
international keyboard layout in Xfce4 d00bid00b Linux - Desktop 0 08-17-2006 04:16 PM
Eterm doesn't like the international keyboard layout drj000 Linux - Software 1 01-19-2005 11:57 AM


All times are GMT -5. The time now is 11:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration