LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 06-03-2004, 11:38 AM   #1
ShadowLeo
LQ Newbie
 
Registered: Mar 2004
Location: Long Island, New York
Distribution: Debian
Posts: 6

Rep: Reputation: 0
Kernel Panic, unable mount root fs


Hello! I'm still a relative newbie to Linux and Debian in general, but I have managed to do quite a bit in the few months I've had it. I recently wanted to use a pair of SCSI drives, but was told by a friend that I didn't have the modules and needed to compile my own kernel with them. I used apt-get install to get the source for kernel version 2.4.18. I followed the instrucitons at the debian website for compiling a kenel under debian using the [Debian Standard Method. Afterwards I ran lilo and rebooted. The boot ran smoothly untill I was promptly greeted with the error Kenel Panic: VFS: Unable to mount root fs on 01:00 I inserted the Debian install disk and am able to get back in by using rescue. Now, 2 days and 15 kernel remakes later I am finally giving up. I have searched these forums and elsewhere and have found problems similar to mine, but were either not resolved or didn't solve my problem. Any help would be greatly GREATLY appreciated.

Charlie the


Here is some of my info.

Distro: Debian
Working Kernel: 2.2.20(?)
Attempted Kernel: 2.4.18
Root disk fs: ext2
Last few lines of boot:

NET4: Unix domain sockets 1.0/SMP for Linux Net4.0.
ds: no socket drivers loaded!
RAMDISK: cramfs filesystem found at block 0
RAMDISK: Loading 1000 blocks [1 disk] into ram disk... done.
Freeing initrd memory: 1000k freed
Kernel Panic: VFS: Unable to mount root fs on 01:00

Here is my lilo.conf file contents:

boot=/dev/hda
root=/dev/hda1
compact
install=/boot/boot.b
default=Linux
map=/boot/map
vga=normal
delay=20
timeout=50
image=/vmlinuz
label = Linux
read-only
initrd=/initrd.img

image=/vmlinuz.old
label = LinuxOLD
read-only


The two files the image lines are pointing are symlinks pointing to the /boot folder and the files they point to do exist. I also checked make menuconfig several times to make sure I was loading support for the IDE controller and for the correct filesystem (ext2) This was all the info I could think of putting.
 
Old 06-03-2004, 11:51 AM   #2
Ron77
LQ Newbie
 
Registered: Jun 2004
Posts: 4

Rep: Reputation: 0
I have had similar problems when trying to boot my own custom Debian CD. The cd burner works through SCSI emulation so it is similar.

Try the SCSI support linked into the kernel instead of modules,
(*) instead of (M)

Try both with and without "initrd" when compiling the kernel.

I remember playing with these options helped me sort it out...
 
Old 06-03-2004, 12:54 PM   #3
ShadowLeo
LQ Newbie
 
Registered: Mar 2004
Location: Long Island, New York
Distribution: Debian
Posts: 6

Original Poster
Rep: Reputation: 0
Thank you very much for your reply. You gave me an idea with initrd. I remember reading that if you load a module, or is built into the kernel, and initrd loads it again, it could cause kernel confusion. Also, when I first installed Debian and the kernel off of Debian's Boot Floppies, I remember seeing no such option for initrd in the original lilo.conf. I'm going to remove the initrd options from lilo.conf. After that I will try the included SCSI support. I wouldn't think that SCSI support would make a difference however though, due to the fact that the root fs is on an ide disk. I only recently added the SCSI disks to the system. I was also told that I could just type
Code:
modprobe aic7xxx
and get the support that way. However, I will try what you recomended.

Regards!
Charlie the
 
Old 06-03-2004, 01:03 PM   #4
ShadowLeo
LQ Newbie
 
Registered: Mar 2004
Location: Long Island, New York
Distribution: Debian
Posts: 6

Original Poster
Rep: Reputation: 0
Haha! Success!
It turns out that it WAS my lilo.conf. I removed the line about initrd from the image=/vmlinuz line and it booted great. I'm going to test the SCSI support right now. Thanks you so much for your help. I really appreciate it.

Sincerely
Charlie the
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel Panic! Unable to mount root fs... DarkNebula Linux - General 7 10-24-2004 06:38 PM
2.2 --> 2.65: Kernel panic, unable to mount root. gaea Debian 5 04-28-2004 01:10 PM
Unable to mount root fs -- Kernel panic tijs Linux - Newbie 6 02-07-2004 05:55 PM
kernel panic: VFS: unable to mount root fs on 09:02 x2000koh Linux - General 8 07-07-2002 07:40 AM
Kernel panic - unable to mount root fs felecha Linux - General 3 06-17-2002 08:57 AM


All times are GMT -5. The time now is 01:44 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration