LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 11-12-2008, 11:04 AM   #1
danospv
LQ Newbie
 
Registered: Feb 2007
Posts: 21

Rep: Reputation: 15
kernel-PAE


I have a server with 16Gb of RAM, but default debian installation is only utilizing 4Gb. I read that kernel-PAE solves this problem, but I am unable to find it as a package through apt.

Anyone know what its called?
 
Old 11-12-2008, 11:19 AM   #2
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
You're looking for "bigmem".

apt-cache search linux-image |grep bigmem
 
Old 11-12-2008, 12:40 PM   #3
danospv
LQ Newbie
 
Registered: Feb 2007
Posts: 21

Original Poster
Rep: Reputation: 15
Thanks,

I installed the bigmem package, but the memory is still capped at 4Gb...
 
Old 11-12-2008, 01:17 PM   #4
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,240

Rep: Reputation: 121Reputation: 121
PAE is only enabled in a HIGHMEM64 kernel. Whether there is one available from debian, I don't know. Unless someone can say yes and point you to the exact one you need, then you will be stuck with building it from source. Can you confirm that you are running Debian or Ubuntu, or whatever? And can you show the output of the following. Note the backquotes. And, are you running an AMD64 kernel, or what?
Code:
grep HIGHMEM /boot/config-`uname -r`
 
Old 11-12-2008, 02:17 PM   #5
danospv
LQ Newbie
 
Registered: Feb 2007
Posts: 21

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Quakeboy02 View Post
PAE is only enabled in a HIGHMEM64 kernel. Whether there is one available from debian, I don't know. Unless someone can say yes and point you to the exact one you need, then you will be stuck with building it from source. Can you confirm that you are running Debian or Ubuntu, or whatever? And can you show the output of the following. Note the backquotes. And, are you running an AMD64 kernel, or what?
Code:
grep HIGHMEM /boot/config-`uname -r`
The server has a Xeon quadcore processor.

Here is the output:
Code:
# CONFIG_NOHIGHMEM is not set
CONFIG_HIGHMEM4G=y
# CONFIG_HIGHMEM64G is not set
CONFIG_HIGHMEM=y
How would I change these settings?
 
Old 11-12-2008, 02:26 PM   #6
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,240

Rep: Reputation: 121Reputation: 121
Quote:
Originally Posted by danospv View Post
The server has a Xeon quadcore processor.
I guess it's just easiest to have you enter the following so we can see which kernel you're running (32-bit or 64-bit etc). And are you running Sarge, Etch, Lenny, or what? My apologies for not asking in the first place.
Code:
uname -a
Quote:
Here is the output:
Code:
# CONFIG_NOHIGHMEM is not set
CONFIG_HIGHMEM4G=y
# CONFIG_HIGHMEM64G is not set
CONFIG_HIGHMEM=y
How would I change these settings?
You can't directly change them to any effect. These are the settings that were in effect when your kernel was compiled.

I really wish I could just point you to the kernel you need, but I've never tried to find a Debian PAE enabled stock kernel.
 
Old 11-12-2008, 02:40 PM   #7
danospv
LQ Newbie
 
Registered: Feb 2007
Posts: 21

Original Poster
Rep: Reputation: 15
Linux www3 2.6.18-6-686 #1 SMP Mon Oct 13 16:13:09 UTC 2008 i686 GNU/Linux

I also have initrd.img-2.6.18-5-686-bigmem in the /boot folder - I don't think it rebooted into the correct one...

I'll try to reboot it, and see if it fixes it.

Forgot to mention - I'm running etch

Last edited by danospv; 11-12-2008 at 02:41 PM. Reason: adding
 
Old 11-12-2008, 02:52 PM   #8
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,240

Rep: Reputation: 121Reputation: 121
Quote:
Originally Posted by danospv View Post
Linux www3 2.6.18-6-686 #1 SMP Mon Oct 13 16:13:09 UTC 2008 i686 GNU/Linux

I also have initrd.img-2.6.18-5-686-bigmem in the /boot folder - I don't think it rebooted into the correct one...

I'll try to reboot it, and see if it fixes it.

Forgot to mention - I'm running etch
OK, here's where I'm hoping someone in the peanut gallery will step in and correct me if I'm wrong.

You are running a 32-bit kernel, so I don't think you can actually use anything above 32-bits, which is 4GB. I'm assuming your Xeon is a 64-bit processor. In order to access the rest, you need to go to a 64-bit system. All things considered, this will probably need a reinstall, and you should probably install Lenny while you're at it. So, is this a production server? Is it critical; does it need to be reliably up? Does it have data that cannot be lost that isn't backed up or not on the root drive? IOW, can you reinstall this machine to a 64-bit OS?
 
Old 11-12-2008, 03:34 PM   #9
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,201

Rep: Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015
Peanut reporting for duty ...
PAE is a hardware function - the motherboard must support it, and it may need to be activated in the BIOS. At which point the extra RAM can be addressed by additional address lines. Any OS then needs to be PAE aware - Linux (of course) has been for years.
When you get all the ducks lined up, everything should "just work". Processes (as distinct from processors) will still be limited to 4 Gig virtual address range - under the covers Linux will use the extra RAM as it sees fit.
 
Old 11-12-2008, 03:42 PM   #10
Dutch Master
Senior Member
 
Registered: Dec 2005
Posts: 1,674

Rep: Reputation: 122Reputation: 122
Correct. This is a 32 bit kernel that can't handle more then 4 GB of RAM.
Code:
Linux {machine-name} 2.6.25.9 #1 SMP Mon Jun 30 23:10:15 CEST 2008 x86_64 GNU/Linux
This is the same uname command on my Lenny system, with a scratchbuild kernel (2.6.25.9) with SMP enabled (multi-core support), compiled on June 30, very late at night as a 64 bit kernel (x86_64). But, in order to compile (build) a 64 bit kernel, you'll need a 64 bit build-environment. For that, you'd need to install a 64 bit Linux OS first (yes, I know cross-compiling can be done, but let's not make this more complicated for new kernel builders then it already is for them). Address that first, keeping in mind the above suggestions from Quakeboy02 on data backup and availability in production environments.
 
Old 11-12-2008, 03:50 PM   #11
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,240

Rep: Reputation: 121Reputation: 121
Quote:
Originally Posted by syg00 View Post
Peanut reporting for duty ...
PAE is a hardware function - the motherboard must support it, and it may need to be activated in the BIOS. At which point the extra RAM can be addressed by additional address lines. Any OS then needs to be PAE aware - Linux (of course) has been for years.
When you get all the ducks lined up, everything should "just work". Processes (as distinct from processors) will still be limited to 4 Gig virtual address range - under the covers Linux will use the extra RAM as it sees fit.
So, just to verify for my own knowledge: with a 32-bit PAE enabled kernel, he can keep a 32-bit operating system and access all of his 16GB of RAM with the one caveat that any single running process will be limited to a 4GB footprint. Thanks!
 
Old 11-12-2008, 04:43 PM   #12
danospv
LQ Newbie
 
Registered: Feb 2007
Posts: 21

Original Poster
Rep: Reputation: 15
I just rebooted the server into the bigmem kernel, and the system now has all 16Gb of RAM available.

I was not the one who originally installed the system - how can I check that its 64 or 32 bit? Is the fact that its using 16Gb already tell you its 64bit?

Last edited by danospv; 11-12-2008 at 04:47 PM. Reason: meant to say bit - long day
 
Old 11-12-2008, 04:53 PM   #13
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,240

Rep: Reputation: 121Reputation: 121
Quote:
Originally Posted by danospv View Post
I just rebooted the server into the bigmem kernel, and the system now has all 16Gb of RAM available.

I was not the one who originally installed the system - how can I check that its 64 or 32 bit? Is the fact that its using 16Gb already tell you its 64bit?
You're fine now that you're booted to the bigmem kernel! The "i686" in the output of "uname -a" says it's a 32-bit system. But, as syg00 explained, that doesn't matter to you unless you actually *need* to have a 64-bit system to run some program(s) that is compiled to run as 64-bit. Your system will utilise all the memory as needed. So, unless you run into some specific problem, you're good to go. Just remember which kernel you need to boot to.

My thanks to the peanut gallery!
 
Old 11-12-2008, 04:59 PM   #14
danospv
LQ Newbie
 
Registered: Feb 2007
Posts: 21

Original Poster
Rep: Reputation: 15
Got it. Thanks a lot everyone!!!
 
Old 11-12-2008, 06:23 PM   #15
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,201

Rep: Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015
If this is a server that has survived on 4 Gig real I'd be inclined to just "go with the flow". Conversion to 64-bit (where available) is "simple" enough, but the consequences (in a production environment) can be painful if not planned for in advance. To determine if your CPUs are 64-bit capable, run "grep -o lm /proc/cpuinfo" from a command line. If you get anything back (one line per processor), it has the support. If you just get a prompt back, nogo.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 9, PAE kernel panics on boot NX-01 Fedora 1 09-13-2008 01:29 AM
KERNEL PANIC: Cannot execute a PAE-enabled kernel on a PAE-less CPU! ovais370 Linux - Laptop and Netbook 7 10-13-2007 05:49 PM
PAE Kernel stumpedguy_frustrate Fedora 5 07-22-2007 09:46 PM
New update Kernel-bigsmp-Kernel with PAE Support raylhm Suse/Novell 2 07-15-2007 03:42 PM
Kernel-PAE stumpedguy_frustrate Fedora 0 04-08-2007 12:02 PM


All times are GMT -5. The time now is 03:49 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration