LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 09-10-2004, 11:03 AM   #1
muted
LQ Newbie
 
Registered: Sep 2004
Distribution: debian sid / freebsd 5.x
Posts: 5

Rep: Reputation: 0
kernel 2.6 sarge no sound -- maybe alsa problem


Hi all, question I hope someone has the ability to answer.

I have a machine installed with Sarge, but sound was not working with the alsa driver. My machine has the i810 Intel sound card. I have read about there being issues with that card in particular, though I have to say, I had no problems under 2.4 with the card. Now running 2.6.7.

To sum up, I searched for answers to the problem to no avail. I installed the alsa-sources, built the modules, and now I am unable to get sound even using OSS. I'm fairly sure that the alsa modules install changes the /dev devices/links, but I am unsure as to what to change them back to.

/dev/mixer -> /dev/mixer0
/dev/dsp -> /dev/dsp0
and so on..

Can anyone help me get alsa running, or get me back to OSS?


here is lsmod:

radeon 109860 2
vmnet 26896 12
parport_pc 27584 1
vmmon 43224 0
ds 12804 4
lp 7876 0
parport 30920 2 parport_pc,lp
iptable_filter 2304 0
ip_tables 14336 1 iptable_filter
genrtc 7688 0
snd_ac97_codec 56196 0
snd_pcm 71844 0
snd_timer 18564 1 snd_pcm
snd_page_alloc 8328 1 snd_pcm
gameport 3584 0
snd_mpu401_uart 5376 0
snd_rawmidi 17984 1 snd_mpu401_uart
snd_seq_device 6152 1 snd_rawmidi
snd 41444 6 snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
hw_random 4372 0
uhci_hcd 25488 0
shpchp 65620 0
pciehp 63572 0
pci_hotplug 25904 2 shpchp,pciehp
intel_agp 15388 1
agpgart 24616 2 intel_agp
ehci_hcd 24068 0
usbcore 85344 4 uhci_hcd,ehci_hcd
i810_audio 27284 0
ac97_codec 15116 1 i810_audio
soundcore 6880 2 snd,i810_audio
e1000 70276 0
yenta_socket 15744 0
pcmcia_core 50756 2 ds,yenta_socket
ath_pci 49188 0
wlan 92380 2 ath_pci
ath_hal 128208 2 ath_pci
ide_cd 34308 0
cdrom 32288 1 ide_cd
tsdev 5248 0
mousedev 7820 3
joydev 7488 0
evdev 6656 0
psmouse 15880 0
ext3 96104 6
jbd 46104 1 ext3
ide_disk 13696 8
ide_generic 1280 0
piix 10656 1
ide_core 107864 4 ide_cd,ide_disk,ide_generic,piix
unix 20272 570
 
Old 09-10-2004, 11:26 PM   #2
RunLevelZero
Member
 
Registered: Jun 2004
Distribution: Debian
Posts: 46

Rep: Reputation: 15
hmm

looks like it's loaded and ready to use.... are you a member of the audio group? If not add yourself and make sure that the volume is NOT muted, because by default it is. Turn up PCM... it's like the "wav" in the MS Windows mixer. Hope this helps. Sounds too simple though..... Did sound ever work?
 
Old 09-11-2004, 05:41 PM   #3
muted
LQ Newbie
 
Registered: Sep 2004
Distribution: debian sid / freebsd 5.x
Posts: 5

Original Poster
Rep: Reputation: 0
does not recognize the device

I am a member of the audio group, so I have permissions to use the device. I mostly get errors that the device is not found.

ex:

"alsamixer: function snd_ctl_open failed for default: No such device"

is returned when trying to run alsamixer.

"sorry no mixer elements and/or devices found"

is returned when i try to run any other mixer or volume control.

"your sound card isn't properly configured or something is blocking it"

is returned from xmms.


I did have sound with OSS running before, though after doing the alsa setup, I have nothing.


Thanks for responding.
 
Old 09-21-2004, 01:05 AM   #4
faustobp
LQ Newbie
 
Registered: Sep 2004
Posts: 1

Rep: Reputation: 0
OSS module x ALSA module

Your system is detecting your soundcard and loading the OSS module (i810_audio) so its unable to load the ALSA driver (snd_intel8x0).

I don't know why the OSS sound is not working (since its module is loaded), so I think the bether solution is to fix the ALSA. To do this you have to prevent the OSS module from been loaded so the system can load the ALSA. Try adding the folling line on your /etc/discover.conf
Code:
skip i810_audio
It must work.

Fausto Bottin Piovesan

Last edited by faustobp; 09-21-2004 at 01:07 AM.
 
Old 09-21-2004, 01:20 AM   #5
the_shaman
Member
 
Registered: Sep 2004
Distribution: Debian Sid
Posts: 34

Rep: Reputation: 15
yeah, muted do a 'lsmod | grep soundcore', I'm very sure both OSS and ALSA will show up. Anything that is snd_xxx is ALSA and anything else that's not is OSS. Do as faustobp has suggested i.e. insert 'skip i810_audio' into your /etc/discover.conf and maybe as an added precaution add i810_audio to /etc/hotplug/blacklist and /etc/hotplug/blacklist.d/alsa-base. The culprit loading the OSS is I suspect discover though.

I suggest you also visit www.alsa-project.org i.e. this page in particular >
http://www.alsa-project.org/alsa-doc...odule=intel8x0

scroll down and zoom in on the portion "Note to debian users' i.e.
Note to debian users: You need to save this information into a file in the /etc/modutils/ directory (Eg. /etc/modutils/alsa) and run update-modules

# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-intel8x0
# module options should go here

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

Do as the folks at ALSA Project has instructed. and REMEMBER to run 'update-modules'. Afterwards, run alsamixer (you have to UNMUTE sound i.e. type M) or alsamixergui or gamix or whatever other mixer. ALSA setup in Debian is really that plain EASY.
 
Old 09-25-2004, 03:07 AM   #6
dun_noe
Member
 
Registered: Sep 2004
Location: Singapore
Distribution: Debian unstable
Posts: 31

Rep: Reputation: 15
Hi,

Thank you for the suggestions to skip the i810 oss driver when booting, It's works on my machine! The alsa driver seems to work correctly, I can use alsamixer to set the sound, and I can play mp3 with my xmms or noatun. But I still have a problem, I can't use my microphone, I've set the volume of the mic, but still can't record any sound.

I tried with the command: arecord -f cd test.wav, and when I try to play the file with: aplay test.wav, I can't hear anything.

lsmod | grep snd produces:
snd_intel8x0 36140 3
snd_ac97_codec 69572 1 snd_intel8x0
snd_pcm 97480 3 snd_intel8x0
snd_page_alloc 11720 2 snd_intel8x0,snd_pcm
gameport 4736 1 snd_intel8x0
snd_mpu401_uart 8000 1 snd_intel8x0
snd_seq_midi_emul 8064 0
snd_seq_virmidi 7680 0
snd_seq_midi 8608 0
snd_rawmidi 25380 3 snd_mpu401_uart,snd_seq_virmidi,snd_seq_midi
snd_seq_oss 34368 0
snd_seq_midi_event 7936 3 snd_seq_virmidi,snd_seq_midi,snd_seq_oss
snd_seq 53776 7 snd_seq_midi_emul,snd_seq_virmidi,snd_seq_midi,snd_seq_oss,snd_seq_midi_event
snd_timer 25540 2 snd_pcm,snd_seq
snd_seq_device 8264 4 snd_seq_midi,snd_rawmidi,snd_seq_oss,snd_seq
snd 57380 16 snd_intel8x0,snd_ac97_codec,snd_pcm,snd_mpu401_uart,snd_seq_virmidi,snd_seq_midi,snd_rawmidi,snd_seq _oss,snd_seq_midi_event,snd_seq,snd_timer,snd_seq_device
soundcore 10400 1 snd

Anyone can help?
Any suggestion will be appreciated...

Thank you very much
 
Old 10-19-2004, 02:31 PM   #7
muted
LQ Newbie
 
Registered: Sep 2004
Distribution: debian sid / freebsd 5.x
Posts: 5

Original Poster
Rep: Reputation: 0
sweet

may thanks to all of you. the steps of skip in discover.conf as well as a line in modprobe.conf:

Code:
remove snd-intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
did the trick.


thx,
muted
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ALSA problem, 3.1 sarge, nvidia onboard audio 2.6.8 kernel tsiMental Debian 2 01-19-2006 05:12 PM
sound not working, sarge with alsa installed yoyoguy2 Debian 12 07-03-2005 07:19 PM
sarge debian alsa sound problem lvgandhi Debian 3 06-11-2005 01:35 PM
weird sound problem - alsa, kernel 2.6, SB Live 5.1 Ben2210 Slackware 7 10-31-2004 03:36 AM
Sound Problem in Kernel 2.6.2 with ALSA Drivers vardhman Linux - General 6 03-21-2004 06:26 PM


All times are GMT -5. The time now is 06:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration