LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 01-15-2005, 01:33 PM   #1
Royle
Member
 
Registered: Apr 2004
Posts: 112

Rep: Reputation: 15
Just compiled a custom kernel no sound.


I configured alsa for my sound card to be built into the kernel but there is no sound. I heard there may be a problem with this. Can someone help me with this? Thanks in advance for your help.
 
Old 01-16-2005, 05:21 AM   #2
Moloko
Member
 
Registered: Mar 2004
Location: Netherlands
Distribution: Debian
Posts: 729

Rep: Reputation: 30
Did you run alsaconf?
 
Old 01-16-2005, 10:14 AM   #3
zuralin
Member
 
Registered: Sep 2003
Distribution: Debian testing/unstable
Posts: 225

Rep: Reputation: 30
Do you have all the correct modules loaded?
 
Old 01-20-2005, 04:33 PM   #4
Gorgon
LQ Newbie
 
Registered: Dec 2004
Posts: 10

Rep: Reputation: 0
Help No Sound for long time now!

Hey, I have exactly same problem... my soundcard does load everytime when i start up my computer, because I build it into my kernel... when I run alsaconf I get this message:

No supported PnP or PCI card found.
Would you like to probe legacy ISA sound cards/chips??

when I say yes it doesn't find any and just stops... I am using SiS 7012 soundcard(as I have a laptop)...

and will it help if I load sound as a module?? cause what differents will it make...

any help will be preciated thanks!
 
Old 01-22-2005, 10:20 PM   #5
kdogksu
Member
 
Registered: Dec 2004
Location: Kansas, United States
Distribution: Ubuntu
Posts: 52

Rep: Reputation: 16
I had trouble with this myself. I believe I fixed it by building my soundcard driver as a module and then alsaconf was able to find it. You might give this a try.
 
Old 01-23-2005, 05:10 AM   #6
Gorgon
LQ Newbie
 
Registered: Dec 2004
Posts: 10

Rep: Reputation: 0
Thank's for advice... But for the moment what I did was downloaded .config from Knoppix and compiled it, and it works perfectly cool.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
kernel-headers and custom compiled kernels jaakkop Slackware 2 11-22-2005 11:21 AM
After i compiled a new kernel, no sound djgerbavore Linux - Newbie 6 02-14-2005 11:07 AM
Custom kernel vulnerabilities verus Slack pre-compiled tank728 Slackware 1 09-04-2004 01:22 PM
Updating a custom-compiled kernel mooreted Linux - Software 2 03-01-2004 09:55 AM
Compiled Custom Kernel booting problem _flaab_ Mandriva 3 11-13-2003 06:34 AM


All times are GMT -5. The time now is 06:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration