LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 04-06-2004, 06:25 AM   #1
davidas
Member
 
Registered: Mar 2004
Distribution: Debian 'Sarge'
Posts: 168

Rep: Reputation: 30
Is there any way to make xhost settings remain unchange with each reboot?


I open a xterm with a normal user account, and do a su. But make xconfig can't run with root cos my xhost access control is enabled. So I did a xhost +local: with my normal user account and su again. This time make xconfig runs without error. However, when I reboot the system, my xhost setting (+local has been reset back to the original. I have to re-add +local:. Is there any way to make the settings stay after each reboot?

Thanks!
 
Old 04-06-2004, 05:24 PM   #2
waster
Member
 
Registered: Jan 2004
Location: London
Distribution: Debian
Posts: 33

Rep: Reputation: 15
for KDE,

/etc/kde3/kdm/Xaccess

might be the answer. If you use gnome, the equivalent will exist. for xdm, it's in /etc/X11/xdm/Xaccess
 
Old 04-06-2004, 06:43 PM   #3
davidas
Member
 
Registered: Mar 2004
Distribution: Debian 'Sarge'
Posts: 168

Original Poster
Rep: Reputation: 30
I'm using xdm. However, when I make some changes to xhost setting, those changes are not reflected in /etc/X11/xdm/Xaccess.

Quote:
Originally posted by waster
for KDE,

/etc/kde3/kdm/Xaccess

might be the answer. If you use gnome, the equivalent will exist. for xdm, it's in /etc/X11/xdm/Xaccess
 
Old 04-06-2004, 06:59 PM   #4
waster
Member
 
Registered: Jan 2004
Location: London
Distribution: Debian
Posts: 33

Rep: Reputation: 15
executing an xhost command will only take effect until X is restarted. I think, but don't quote me, you'll need to change the default permissions in the Xaccess file. Google it,

Xaccess seems to be for allowing other terminals to connect to this server, which is kind of what you want.

man xhost suggest a file /etc/X*.hosts should be used (???)
maybe you have to create it.
 
Old 04-07-2004, 11:11 PM   #5
davidas
Member
 
Registered: Mar 2004
Distribution: Debian 'Sarge'
Posts: 168

Original Poster
Rep: Reputation: 30
The problem I have is that all the xhost setting done in one session is gone with each server reboot.

Eg. make xconfig must be run as root. When I su into root account, I can't run make xconfig unless I have done a "xhost +local:" or "xhost +" on my normal user account before su into the root account. After each reboot, I have to redo the xhost +local: command before going into root account for the application to run.

Is there any configuration file for xhost to save all the settings, so that I don't have to redo the setting after each reboot?

Thanks !
PS. Cant' seem to find any help on X*.hosts

Quote:
Originally posted by waster
executing an xhost command will only take effect until X is restarted. I think, but don't quote me, you'll need to change the default permissions in the Xaccess file. Google it,

Xaccess seems to be for allowing other terminals to connect to this server, which is kind of what you want.

man xhost suggest a file /etc/X*.hosts should be used (???)
maybe you have to create it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
fstab remain unchanged at reboot ago.homer Linux - Newbie 1 04-20-2005 05:24 AM
Settings get reset on reboot xymian Debian 3 02-23-2005 04:53 AM
hdparm settings after reboot Crashed_Again Linux - General 1 03-04-2004 06:43 AM
Can't get xawtv to keep settings on reboot BlankFrank Linux - Software 0 02-27-2004 01:53 PM
can't make SUSE remember IP settings after reboot...#$% roflash Linux - Networking 0 05-27-2002 09:18 AM


All times are GMT -5. The time now is 09:28 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration