LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 12-08-2009, 12:30 AM   #1
TristanDee
Member
 
Registered: Nov 2007
Location: Dhaka, Bangladesh
Distribution: Ubuntu 14.04 LTS
Posts: 75

Rep: Reputation: 15
Invisible mouse pointer


Here's another problem hope someone can explain and fix.

I had performed a net-install after which I upgraded to Squeeze. Then I installed xorg, gnome-core, and gdm. I logged in to the fresh GUI environment, changed the screen resolution to 1280x1024, and then the mouse pointer was gone! Changing back to the previous resolution, restarting the machine - nothing restored the mouse pointer. Any ideas?
I can, however, select items on desktop with the mouse basing on guess! So, the title should rather read "invisible mouse pointer".

Last edited by TristanDee; 12-08-2009 at 01:07 AM.
 
Old 12-09-2009, 03:23 AM   #2
TristanDee
Member
 
Registered: Nov 2007
Location: Dhaka, Bangladesh
Distribution: Ubuntu 14.04 LTS
Posts: 75

Original Poster
Rep: Reputation: 15
Some interesting updates I didn't notice earlier:

The mouse pointer is there in the GDM log-in prompt. It disappears with logging in to desktop. However, it appears again after I somehow manage to open the terminal and start writing something!

Why is this happening? Anybody, please!
 
Old 12-09-2009, 06:31 AM   #3
jim_p
Member
 
Registered: Aug 2009
Distribution: Debian testing
Posts: 497

Rep: Reputation: 112Reputation: 112
Maybe add this inside your xorg.conf
Code:
Section "ServerFlags"
	Option		"AutoAddDevices"		"False"
EndSection
 
Old 12-09-2009, 09:37 AM   #4
TristanDee
Member
 
Registered: Nov 2007
Location: Dhaka, Bangladesh
Distribution: Ubuntu 14.04 LTS
Posts: 75

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by jim_p View Post
Maybe add this inside your xorg.conf
Code:
Section "ServerFlags"
    Option        "AutoAddDevices"        "False"
EndSection
I'll have to check this when i get home. I'll let you know when I've done. Thanks.
 
Old 12-09-2009, 02:25 PM   #5
TristanDee
Member
 
Registered: Nov 2007
Location: Dhaka, Bangladesh
Distribution: Ubuntu 14.04 LTS
Posts: 75

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by jim_p View Post
Maybe add this inside your xorg.conf
Code:
Section "ServerFlags"
    Option        "AutoAddDevices"        "False"
EndSection
Hello there, I don't have an xorg.conf file!
Code:
oracle:/etc/X11# ls
app-defaults         rgb.txt  xinit       Xsession        XvMCConfig
default-display-manager  twm      xkb          Xsession.d    Xwrapper.config
fonts             X      Xresources  Xsession.options
Is this normal? Why wasn't the file created at all?
 
Old 12-09-2009, 03:03 PM   #6
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Testing/Unstable Amd64
Posts: 1,476

Rep: Reputation: Disabled
Quote:
Is this normal? Why wasn't the file created at all?
Yes,this is quite normal now.
The newer versions of X don't need and hence don't create an xorg.conf by default anymore.
Check the link in my sig for how to generate one.
 
Old 12-15-2009, 01:55 AM   #7
TristanDee
Member
 
Registered: Nov 2007
Location: Dhaka, Bangladesh
Distribution: Ubuntu 14.04 LTS
Posts: 75

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by jim_p View Post
Maybe add this inside your xorg.conf
Code:
Section "ServerFlags"
    Option        "AutoAddDevices"        "False"
EndSection
Hello jim_p, are you sure about this "False" flag?

'Cause this locked my input devices--the keyboard and mouse simply didn't work. I booted into recovery mode with a view to deleting the ServerFlags section or maybe changing "False" to "True" (although I didn't know whether it would work) but couldn't because it said the filesystem was in read-only mode .

I didn't know what to do, so I reinstalled Debian. The invisible-mouse problem is still with me!


@trooper: Thanks for the help in creating xorg.conf.
 
Old 12-15-2009, 04:48 AM   #8
jim_p
Member
 
Registered: Aug 2009
Distribution: Debian testing
Posts: 497

Rep: Reputation: 112Reputation: 112
Regarding AutoAddDevices (from the xorg page in arhlinux wiki)
Quote:
Input hot-plugging
Note: This will disable Xorg hot-plugging for all input devices and revert to the same behavior as xorg-server 1.4. It is much more convenient to configure devices through HAL instead of xorg.conf. See: Xorg Input Hotplugging

Normally, Xorg tries to configure your keyboard using the xf86-input-evdev driver (which in turn uses dbus and HAL) instead of using your configuration settings in xorg.conf. This may result in an undesired auto-configured keyboard layout. The fastest workaround is to disable the hot-plugging mechanism by adding the following section to your xorg.conf:
Code:
Section "ServerFlags"
    Option "AutoAddDevices" "False"
EndSection
So yes, I am sure it works. I have it on both my debian testing installs at home.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
missing mouse pointer after unlocking screen leximorph19 Ubuntu 2 11-25-2007 07:54 PM
Mouse pointer missing edwal Fedora - Installation 6 10-22-2006 06:39 PM
disconnect USB mouse data from the mouse pointer Yeronimo Programming 0 04-07-2005 04:26 AM
Mouse pointer missing in Unreal Tournament jenna_h Linux - Games 2 01-14-2004 10:52 PM
The you have a Mouse Pointer Problem(mouse stick top left)here is the solution. dr4ven Linux - Hardware 0 05-25-2003 06:53 PM


All times are GMT -5. The time now is 01:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration