LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Invisible mouse pointer (http://www.linuxquestions.org/questions/debian-26/invisible-mouse-pointer-774133/)

TristanDee 12-07-2009 11:30 PM

Invisible mouse pointer
 
Here's another problem hope someone can explain and fix.

I had performed a net-install after which I upgraded to Squeeze. Then I installed xorg, gnome-core, and gdm. I logged in to the fresh GUI environment, changed the screen resolution to 1280x1024, and then the mouse pointer was gone! Changing back to the previous resolution, restarting the machine - nothing restored the mouse pointer. Any ideas?
I can, however, select items on desktop with the mouse basing on guess! So, the title should rather read "invisible mouse pointer".

TristanDee 12-09-2009 02:23 AM

Some interesting updates I didn't notice earlier:

The mouse pointer is there in the GDM log-in prompt. It disappears with logging in to desktop. However, it appears again after I somehow manage to open the terminal and start writing something!

Why is this happening? Anybody, please!

jim_p 12-09-2009 05:31 AM

Maybe add this inside your xorg.conf
Code:

Section "ServerFlags"
        Option                "AutoAddDevices"                "False"
EndSection


TristanDee 12-09-2009 08:37 AM

Quote:

Originally Posted by jim_p (Post 3785298)
Maybe add this inside your xorg.conf
Code:

Section "ServerFlags"
    Option        "AutoAddDevices"        "False"
EndSection


I'll have to check this when i get home. I'll let you know when I've done. Thanks.

TristanDee 12-09-2009 01:25 PM

Quote:

Originally Posted by jim_p (Post 3785298)
Maybe add this inside your xorg.conf
Code:

Section "ServerFlags"
    Option        "AutoAddDevices"        "False"
EndSection


Hello there, I don't have an xorg.conf file!
Code:

oracle:/etc/X11# ls
app-defaults        rgb.txt  xinit      Xsession        XvMCConfig
default-display-manager  twm      xkb          Xsession.d    Xwrapper.config
fonts            X      Xresources  Xsession.options

Is this normal? Why wasn't the file created at all?

the trooper 12-09-2009 02:03 PM

Quote:

Is this normal? Why wasn't the file created at all?
Yes,this is quite normal now.
The newer versions of X don't need and hence don't create an xorg.conf by default anymore.
Check the link in my sig for how to generate one.

TristanDee 12-15-2009 12:55 AM

Quote:

Originally Posted by jim_p (Post 3785298)
Maybe add this inside your xorg.conf
Code:

Section "ServerFlags"
    Option        "AutoAddDevices"        "False"
EndSection


Hello jim_p, are you sure about this "False" flag?

'Cause this locked my input devices--the keyboard and mouse simply didn't work. I booted into recovery mode with a view to deleting the ServerFlags section or maybe changing "False" to "True" (although I didn't know whether it would work) but couldn't because it said the filesystem was in read-only mode :(.

I didn't know what to do, so I reinstalled Debian. The invisible-mouse problem is still with me!


@trooper: Thanks for the help in creating xorg.conf.

jim_p 12-15-2009 03:48 AM

Regarding AutoAddDevices (from the xorg page in arhlinux wiki)
Quote:

Input hot-plugging
Note: This will disable Xorg hot-plugging for all input devices and revert to the same behavior as xorg-server 1.4. It is much more convenient to configure devices through HAL instead of xorg.conf. See: Xorg Input Hotplugging

Normally, Xorg tries to configure your keyboard using the xf86-input-evdev driver (which in turn uses dbus and HAL) instead of using your configuration settings in xorg.conf. This may result in an undesired auto-configured keyboard layout. The fastest workaround is to disable the hot-plugging mechanism by adding the following section to your xorg.conf:
Code:

Section "ServerFlags"
    Option "AutoAddDevices" "False"
EndSection


So yes, I am sure it works. I have it on both my debian testing installs at home.


All times are GMT -5. The time now is 12:07 AM.