LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 01-21-2007, 11:33 AM   #1
Indiestory
Member
 
Registered: Aug 2006
Location: Aberdeen, Scotland
Distribution: OpenBSD
Posts: 164
Blog Entries: 1

Rep: Reputation: 30
Internet seems to be blocked with latest etch


I set up a netinstall yesterday, and i did some very basic setting changes such as grabbing my self a firewall tool. I got guarddog and at the time it seemed to block all http traffic after configuration. Even with all file transfer options set. I booted up again today having forgotten this and now im unable to connect to the internet. I a get connected to the wired network message but i seem unable to use this, i get strange operation not allowed style messages with pings and traceroutes, and im unable to connect to my routers admin features to test the connection. Anyone got a clue whats happened here?
 
Old 01-21-2007, 02:29 PM   #2
Indiestory
Member
 
Registered: Aug 2006
Location: Aberdeen, Scotland
Distribution: OpenBSD
Posts: 164
Blog Entries: 1

Original Poster
Rep: Reputation: 30
wait i got it, it was guarddog and i still dont know why ,but i managed to get connected by removing guarddog with apt-get --purge remove guarddog.
 
Old 01-21-2007, 04:17 PM   #3
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 60
I trust you are still running a firewall of some sort. I use Firestarter myself since I use Gnome, but I'm sure Guarddog includes similar tools for opening the ports you need to connect to the internet.
 
Old 07-07-2007, 04:28 PM   #4
zero061099
LQ Newbie
 
Registered: Jul 2007
Posts: 1

Rep: Reputation: 0
Help

Well maybe i messed up maybe but I uninstalled Guarddog using package manager after I had no internet connection also....BUT....I still have no inernet!! What happened?? Is there a config file i have to edit??

It says im connected but everthing is blocked!
 
Old 07-07-2007, 11:46 PM   #5
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Have you verified your Network settings ?

ifconfig -a
cat /etc/resolv.conf
cat /etc/network/interfaces
route -n



have you checked to see if the firewall rules are still in place ?
iptables -L
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No internet after Etch upgrade erpe Debian 5 10-30-2006 04:23 PM
latest Etch update broke my wifi... JaseP Debian 5 09-26-2006 12:56 AM
Problem updating to latest Kernal using up2date, internet stops working corepuncher Linux - Software 2 01-19-2006 10:16 AM
No Internet After Updating to Latest Kernel poochdog Linux - Networking 6 10-17-2005 10:26 PM
Internet browser problems with latest MAndrake turnback Linux - Networking 1 06-30-2004 01:34 PM


All times are GMT -5. The time now is 12:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration