LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Closed Thread
 
Search this Thread
Old 06-11-2007, 09:25 AM   #1
joffa
LQ Newbie
 
Registered: Aug 2004
Location: Melbourne AUS
Distribution: Debian testing (I try others but always come back - it is the best)
Posts: 24

Rep: Reputation: 15
Internal usb multi card reader won't load on reboot


Any one able to suggest what I need to do to get an internal usb 16 in 1 multi card reader (CF/MD, SD/MMC/MS/SMC, 2 x USB, 1 x 1394, mic, line in, line out) working using debian sid 2.6.21-1-amd64.

I have udev hal & pmount installed (so no line in /etc/fstab needed). It works if I unplug it from the usb port of the motherboard, shutdown, replug and then start up. If I reboot, they don't appear (in gnome 'Computer'). Is it something as simple as a module? (I've tried usb-storage and autofs using modconf - didn't work)

It worked in the past (I haven't used it for about 3 months and have done a fresh install since).
The following is what I get when it's not detected.
lsusb:
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
lsmod gives a long list and I don't see any usb mentioned.
lspci gives (part of):
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
Thanks all.
 
Old 06-13-2007, 06:16 AM   #2
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
Udev is a bit over me but I remembered reading an interesting article here that could be worth reading (about udev, if it's your problem?)

 
Old 06-13-2007, 11:15 PM   #3
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Please post your thread in only one forum. Posting a single thread in the most relevant forum will make it easier for members to help you and will keep the discussion in one place. This thread is being closed because it is a duplicate.
 
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Internal multi card reader not loading on reboot joffa Debian 3 01-02-2008 04:28 AM
USB Multi card reader in linux sjmgeezer Linux - Hardware 2 07-21-2005 07:15 AM
multi-card usb reader support MikTheUser Linux - Hardware 1 02-14-2005 04:53 PM
USB multi-card reader; only one card can be mounted in Slack 10. KidsWriter71 Linux - Hardware 6 09-11-2004 07:24 PM
USB multi-card reader woes bgnrsmnd Linux - Newbie 1 11-06-2003 06:36 PM


All times are GMT -5. The time now is 08:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration