LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 06-26-2011, 12:57 PM   #16
mpyusko
Member
 
Registered: Oct 2003
Location: Rochester, NY, USA
Distribution: Salckware ver 10.1 - 14.1, Debian too.
Posts: 371
Blog Entries: 1

Original Poster
Rep: Reputation: 38

Quote:
Originally Posted by business_kid View Post
Have you a kernel source? run make -j10 in the kernel and see if the cpu sweats. If it does, relax. You have 'enough' cpu.
I guess I should be a little more specific. When it slows to 600MHz, sometimes it's idle but other times it's not. The throttle should kick up when it gets busy, but in this case it's not. It's like there is a rogue script somewhere that as soon as the fan kicks on to cool the CPU down, all thresholds are fixed to 600 MHz Min /600 MHz Max and the whole system becomes nearly unusable. At one point it to me over 20 minutes to reload this page in Iceweasel running in KDE. I'm spent many hours Googling and rebooting but I can't seem to find the culprit. All I know is when the system boots, I get a line to the tune of "Loading cpufreqd...... failed." But if the system is cool it is throttling properly. Once the fan needs to kick on the system gets stuck at 600MHz and is never released without a reboot.
 
Old 06-27-2011, 12:16 PM   #17
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,615

Rep: Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585
NOW we have a clear definition of the problem. Cpufreqd sounds awfully like something that may be at the heart of a cpu frequency problem, so I would try installing Cpufreqd

Have you a heat problem? The cpu won't speed up unless it's adequately cooled.
 
Old 06-27-2011, 02:00 PM   #18
mpyusko
Member
 
Registered: Oct 2003
Location: Rochester, NY, USA
Distribution: Salckware ver 10.1 - 14.1, Debian too.
Posts: 371
Blog Entries: 1

Original Poster
Rep: Reputation: 38
I never had this problem with Lenny. As noted in the OP, it all started during the Install of squeeze.

cpufreqd only shows "failed" during the boot sequence. However, cpufreq-utils loads properly (as far as I can tell) and sets the system to ondemand. Immediately following boot (and not loading X) cpufreq-info shows proper configuration. "./etc/init.d/cpufreqd resart" also will load without an error. The error it encounters during boot is unknown since I can't seem to find it in any /var/log files.

I'm seriously about to beat my head against the wall. My laptop has been out of service for ~6mo because the screen died. I just spent $60 on a new backlight and invertor and installed them. I hope not for nothing.
 
Old 06-27-2011, 02:32 PM   #19
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,615

Rep: Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585
cpufreqd is not part of cpufreq-utils. I have slackware-13.37 here. I do suggest you read instead of freaking. There are several things with a finger on cpu frequency: The cpu being too hot; Battery low; governor saving power; and then all the clever little daemons, utilities and knacky bits. If you have kde, all this could be running in triplicate (kde always seems that slow).
 
Old 06-27-2011, 02:59 PM   #20
mpyusko
Member
 
Registered: Oct 2003
Location: Rochester, NY, USA
Distribution: Salckware ver 10.1 - 14.1, Debian too.
Posts: 371
Blog Entries: 1

Original Poster
Rep: Reputation: 38
Quote:
Originally Posted by business_kid View Post
cpufreqd is not part of cpufreq-utils. I have slackware-13.37 here. I do suggest you read instead of freaking.
Correct. And I also have Slackware 13.37 running on my destop (listed in my signature) but Squeeze and Slackware configure, display, and log things very differently. I have cpufreqd installed and cpufreq-utils. They are both loaded by 2 init.d scripts (actually cpufreqd is loaded by 2, making 3 but...). I'm starting to think this is a BIOS issue. Because I finally managed to figure out how to get GRUB2 to boot my XP partition again (though I have to create a "menuentry...." at each boot to do it) and it's happening there too, but XP has always been a pain on it.

I've re-flashed the BIOS like 6 times. Not sure what else to try. Is it possible that the MB's hardware monitor is faulty and locking out the OS's?

I like Slackware for my Desktop because it's rock-solid, stable and versatile. I put Debian on my laptops because in a mobile environment the Apt repository is priceless. With Slackware i can compile and configure anything to run on it. But in a mobile environment, ease and a speedy install win out.

I installed Debian with the multi-arch disc and added KDE after. I think I'm going to use the i386-KDE disc and see how that runs. I also have a USB hard drive running Lenny I can pop in and double-check with.

Last edited by mpyusko; 06-27-2011 at 03:01 PM.
 
Old 06-27-2011, 03:20 PM   #21
widget
Senior Member
 
Registered: Oct 2008
Location: S.E. Montana
Distribution: Debian Testing, Stable, Sid and Manjaro, Mageia 3, LMDE
Posts: 2,345

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
I know nothing about the cpu problem but as for grub you need t oput that menu entry you create in /etc/grub/grub.d.40_custom and run, as root;
Code:
update-grub
This will put the menu entry on your grub.cfg file and have it at the end of your screen menu. If you want it first, rename the file to "06_custom" before running update-grub.
 
Old 06-27-2011, 03:33 PM   #22
mpyusko
Member
 
Registered: Oct 2003
Location: Rochester, NY, USA
Distribution: Salckware ver 10.1 - 14.1, Debian too.
Posts: 371
Blog Entries: 1

Original Poster
Rep: Reputation: 38
Quote:
Originally Posted by widget View Post
I know nothing about the cpu problem but as for grub you need t oput that menu entry you create in /etc/grub/grub.d.40_custom and run, as root;
Code:
update-grub
This will put the menu entry on your grub.cfg file and have it at the end of your screen menu. If you want it first, rename the file to "06_custom" before running update-grub.
Doh! And like a fool I've been wondering why grub-update wasn't found. LOL!
It would be nice if 'man grub' actually returned a result.
 
Old 06-27-2011, 05:06 PM   #23
widget
Senior Member
 
Registered: Oct 2008
Location: S.E. Montana
Distribution: Debian Testing, Stable, Sid and Manjaro, Mageia 3, LMDE
Posts: 2,345

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
Yes it would. It should actually be "man grub-pc" but that doesn't get you anything either. The best documentation on grub is now at;
http://ubuntuforums.org/showthread.php?t=1195275
and;
https://help.ubuntu.com/community/Gr...20the%20LiveCD

The perpetrator of the first is guilty of most of the second. He was one of us in Ubuntu 9.10 testing when grub-pc was dropped on us at A2 time with NO documentation worth a damn that we could find.

Spent 2 weeks editing the grub.cfg file before we started to find hints here and there. Drs305 put all our discoveries, along with a vast amount of experimentation on his part, into the thread over there. He keeps it up to date very well.

There are a lot of links at the bottom of that first entry that are just great.

One thing that is good to run when you make a change in anything to do with grub, after you run update-grub, is "grub-mkconfig". This will, in terminal, print out the grub.cfg file so you can check it and make any corrections right then by editing the right script and then running update-grub again followed by grub-mkconfig again to check it.

Custom menu entries are very handy and, I believe, what you are intended to use after the first boot to your installation. Using them you can disable all other scripts in grub.d above 05 except for your ??_custom file. This makes the load time of the grub menu a lot quicker as there is so much less grub.cfg file to read.

This is the entry for the OS I am on right now. It will load any Debian based OS that is on this partition. I could install a version of Mint or Ubuntu here tomorrow and use the same entry unedited, as it just calls for the partition and boots the newest kernel there.
Code:
echo "Adding Squeezy on sda7" >&2 
cat << EOF
menuentry "Squeezy on sda7" {
    set root=(hd0,7)
        linux /vmlinuz root=/dev/sda7 ro quiet splash 
        initrd /initrd.img
}
EOF
You can put any nonsense in between the "" that you want. The first is what you see when you run update-grub and the second what you see on your screen menu.

I actually have this in the instruction string so that bootchart works on boot up, it comes after a space past "splash";
Code:
initcall_debug printk.time=y quiet init=/sbin/bootchartd ... rdinitrd=/sbin/bootchartd
When editing your grub menu entries make sure that text wrapping is NOT enabled.

Last edited by widget; 06-27-2011 at 05:07 PM.
 
1 members found this post helpful.
Old 06-27-2011, 10:28 PM   #24
mpyusko
Member
 
Registered: Oct 2003
Location: Rochester, NY, USA
Distribution: Salckware ver 10.1 - 14.1, Debian too.
Posts: 371
Blog Entries: 1

Original Poster
Rep: Reputation: 38
I booted up Lenny off the USB hard drive and it face a similar issue, but felt different. i.e. The CPU dropped to 600, locked 600/600MHz (min max) with the fan on, but stayed around 11% CPU. It got up to 55% doing a couple tasks, and even 100% for a couple seconds but remained snappy and responsive. On the other hand, with Squeeze, it would drop to 600 lock 600/600 and remain @100% cpu and would be practically unusable. Remember how in the OP I said the istall was running @600MHz? well I'm running the debian-6.0.1a-i386-kde-CD-1.iso install CD right now and it's zipping along at 1.8GHz and yes the fan is running, and the fan has even been changing speeds. 'lsmod |grep cpu' returns zero results but fan, thermal, and therrmal_sys are running. cpufreq is not running.

Last edited by mpyusko; 06-27-2011 at 11:19 PM. Reason: source CD version/link
 
Old 09-15-2011, 10:47 PM   #25
mpyusko
Member
 
Registered: Oct 2003
Location: Rochester, NY, USA
Distribution: Salckware ver 10.1 - 14.1, Debian too.
Posts: 371
Blog Entries: 1

Original Poster
Rep: Reputation: 38
Talking Solved???

Update....

The laptop was running for a while and then I shelved it because it is practically unusable at 600MHz. It inadvertently got unplugged and the batteries died. I just pulled it off the shelf and booted it up to get some files off it and it was still experiencing the same issue. I dove into it with a fresh mind and started reading the /etc/init.d files and a whole slew of others (gotta love Linux and the programmers/developers who put so many comments in their code and files.) I tracked it down to the /etc/init.d/cpufrequtils file. Namely the top where the default lines are
Code:
MAX_SPEED="0"
MIN_SPEED="0"
This wasn't working and after changing them to:
Code:
MAX_SPEED="1800000"
MIN_SPEED="600000"
Everything seems to be running fine. It's been running for over 32 hours and properly scaling anyway. Now I can actually use it, Woo-hoo! This is actually pretty important to me since I had just upgraded the HD from 60GB - 80GB, the RAM from 512MB to 2GB, replaced the primary battery, the LCD back-light and inverter, and I have a pair of hinges waiting to go in it. (All that cost less than a netbook and it blows away any Atom.)
 
1 members found this post helpful.
Old 09-15-2011, 11:51 PM   #26
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,651
Blog Entries: 2

Rep: Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095
Thanks for posting back your solution. Please mark the thread as solved using the thread tools at the top of the thread.
 
  


Reply

Tags
debian, install, speedstep


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
slow web page loading in squeeze edhe1 Debian 5 05-25-2011 04:43 AM
Slow performance on wine (Squeeze) habl Debian 6 03-28-2011 12:06 AM
[SOLVED] Waiting for Squeeze stable vs installing Squeeze right now and keeping it up to date alanv Linux - Newbie 2 11-03-2010 03:43 AM
Why remote X is slow (squeeze client, lenny server)? kaz2100 Debian 1 08-21-2010 04:27 AM
[SOLVED] network-manager, vpn: no/slow connection, options not saved (debian squeeze) mike11 Linux - Networking 2 01-23-2010 10:43 PM


All times are GMT -5. The time now is 02:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration