LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 06-23-2011, 11:15 PM   #1
mpyusko
Member
 
Registered: Oct 2003
Location: Rochester, NY, USA
Distribution: Salckware ver 10.1 - 14.1, Debian too.
Posts: 360
Blog Entries: 1

Rep: Reputation: 38
Exclamation Installing Squeeze. CPU slow?


I'm upgrading from Lenny to Squeeze and during the installation process I noticed the CPU is operating at 600MHz. Is it normal for the lowest Speedstep setting to be used during installation? The laptop is a Pentium M @ 1.8GHz.

Last edited by mpyusko; 06-26-2011 at 12:40 AM.
 
Old 06-24-2011, 03:14 AM   #2
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,375

Rep: Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557
I don't think there is a normal speed for laptop cpus, especially if working from battery.

Installs are not cpu intensive. What kernel governor is in use? 'performance' uses full speed, all the others vary.
 
Old 06-24-2011, 07:27 AM   #3
mpyusko
Member
 
Registered: Oct 2003
Location: Rochester, NY, USA
Distribution: Salckware ver 10.1 - 14.1, Debian too.
Posts: 360
Blog Entries: 1

Original Poster
Rep: Reputation: 38
Honestly, I don't know if a kernel governor is even loaded. It is plugged into the wall though. There's still a lot of downloading, decompression, and copying going on. I imagine if it was running at full speed I'd still see 100% CPU usage.
 
Old 06-24-2011, 09:58 AM   #4
salasi
Senior Member
 
Registered: Jul 2007
Location: Directly above centre of the earth, UK
Distribution: SuSE, plus some hopping
Posts: 3,901

Rep: Reputation: 775Reputation: 775Reputation: 775Reputation: 775Reputation: 775Reputation: 775Reputation: 775
Quote:
Originally Posted by mpyusko View Post
...There's still a lot of downloading, decompression, and copying going on. I imagine if it was running at full speed I'd still see 100% CPU usage.
It is probably the case that this is an example of a task which wouldn't go any faster if the cpu was running at a higher clock speed. When the cpu is waiting for network or disk IO, all that will happen by turning the clock speed up is that it will wait faster (and use more power).

Depending on how you are measuring the speed, the clock speed may also be altering and your measurement may only be telling you that it is low at the instant that you are measuring it. How are you doing that?
 
Old 06-24-2011, 04:20 PM   #5
mpyusko
Member
 
Registered: Oct 2003
Location: Rochester, NY, USA
Distribution: Salckware ver 10.1 - 14.1, Debian too.
Posts: 360
Blog Entries: 1

Original Poster
Rep: Reputation: 38
I thought about that and continued to keep track of it during the installation. But now that the machine is up and running, I'm still not getting the speed I should be.
Code:
mpyusko@hal9000:~$ cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 13
model name      : Intel(R) Pentium(R) M processor 1.80GHz
stepping        : 6
cpu MHz         : 600.000
cache size      : 2048 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr mce cx8 sep mtrr pge mca cmov clflush dts acpi mmx fxsr sse sse2 ss tm pbe up bts est tm2
bogomips        : 1199.23
clflush size    : 64
cache_alignment : 64
address sizes   : 32 bits physical, 32 bits virtual
power management:

mpyusko@hal9000:~$ cpufreq-info
cpufrequtils 007: cpufreq-info (C) Dominik Brodowski 2004-2009
Report errors and bugs to cpufreq@vger.kernel.org, please.
analyzing CPU 0:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 10.0 us.
  hardware limits: 600 MHz - 1.80 GHz
  available frequency steps: 1.80 GHz, 1.60 GHz, 1.40 GHz, 1.20 GHz, 1000 MHz, 800 MHz, 600 MHz
  available cpufreq governors: userspace, ondemand, performance
  current policy: frequency should be within 600 MHz and 600 MHz.
                  The governor "userspace" may decide which speed to use
                  within this range.
  current CPU frequency is 600 MHz.
mpyusko@hal9000:~$
I ran into a similar issue with my PDC E6700@3.2GHz, and I managed to get it working in Slack 13.37 but I can't remember how. That and my Slackware desktop runs it and configures it in different ways. I tried using a few Debian/Ubuntoo guides, but I still can't seem to make it work.

Edit: I should note that no matter what governor I load, it always keeps coming up between 600 and 600.

Last edited by mpyusko; 06-24-2011 at 04:21 PM.
 
Old 06-24-2011, 04:23 PM   #6
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,592
Blog Entries: 2

Rep: Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046
What is you actual problem? Doesn't the speed go up when the machine is under load?
 
Old 06-24-2011, 04:31 PM   #7
mpyusko
Member
 
Registered: Oct 2003
Location: Rochester, NY, USA
Distribution: Salckware ver 10.1 - 14.1, Debian too.
Posts: 360
Blog Entries: 1

Original Poster
Rep: Reputation: 38
Quote:
Originally Posted by TobiSGD View Post
What is you actual problem? Doesn't the speed go up when the machine is under load?
No. It's not scaling at all. It's stuck at 600MHz.
 
Old 06-24-2011, 04:33 PM   #8
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,592
Blog Entries: 2

Rep: Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046
Which governor is loaded?
May it be that the powersafe-governor is loaded?
 
Old 06-24-2011, 04:42 PM   #9
mpyusko
Member
 
Registered: Oct 2003
Location: Rochester, NY, USA
Distribution: Salckware ver 10.1 - 14.1, Debian too.
Posts: 360
Blog Entries: 1

Original Poster
Rep: Reputation: 38
If I'm reading what I pasted correctly, then I'm pretty sure userspace is loaded. But honestly, Performance, Userspace, ondemand, etc... they all have the same end result 600MHz.
 
Old 06-25-2011, 02:46 AM   #10
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,375

Rep: Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557
Quote:
Originally Posted by mpyusko View Post
If I'm reading what I pasted correctly, then I'm pretty sure userspace is loaded. But honestly, Performance, Userspace, ondemand, etc... they all have the same end result 600MHz.
There's all sorts of frequencies measured at all sorts of places. How are you measuring cpu speed?
 
Old 06-25-2011, 10:24 AM   #11
mpyusko
Member
 
Registered: Oct 2003
Location: Rochester, NY, USA
Distribution: Salckware ver 10.1 - 14.1, Debian too.
Posts: 360
Blog Entries: 1

Original Poster
Rep: Reputation: 38
I posted outputs above for "cat /proc/cpuinfo" and "cpufreq-info".
 
Old 06-25-2011, 01:18 PM   #12
odiseo77
Member
 
Registered: Dec 2004
Location: London, UK
Distribution: Debian Sid, OpenSUSE 13.1
Posts: 995

Rep: Reputation: 298Reputation: 298Reputation: 298
I'm not an expert, but have you checked the BIOS? What frequency does it report? Could you check that all the CPU settings in the BIOS are OK? Maybe someone played with the CPU frequency configuration or SpeedStep settings? (My SpeedStep settings are set to "Disabled", but I'm using a desktop, not a laptop, so I'm not sure how they should be in a laptop)

Regards.
 
Old 06-25-2011, 01:34 PM   #13
mpyusko
Member
 
Registered: Oct 2003
Location: Rochester, NY, USA
Distribution: Salckware ver 10.1 - 14.1, Debian too.
Posts: 360
Blog Entries: 1

Original Poster
Rep: Reputation: 38
Speedstep is set to enabled in the Bios and is reported at 600MHz (but then again the computer is idle). Also I just uninstalled the cpufreqd and cpufrequtils packages, rebooted twice, then reinstalled them. No change. However, during boot the cpufreqd line returns "failed". The acpi-cpufreq module is loading and has been all along (except when I uninstalled).

Code:
root@hal9000:/etc# lsmod |grep cpu
acpi_cpufreq            4915  0 
cpufreq_conservative     4018  0 
cpufreq_userspace       1444  0 
cpufreq_stats           1940  0 
cpufreq_powersave        602  0 
processor              26259  2 acpi_cpufreq
root@hal9000:/etc#
 
Old 06-25-2011, 07:04 PM   #14
mpyusko
Member
 
Registered: Oct 2003
Location: Rochester, NY, USA
Distribution: Salckware ver 10.1 - 14.1, Debian too.
Posts: 360
Blog Entries: 1

Original Poster
Rep: Reputation: 38
I just booted to XP, re-flashed the BIOS with A14 (same version), rebooted back to Squeeze and the computer started up running 1.8GHz. But now, an hour later, all governors max at 600MHz. WTF???

Code:
cpufreq-info
cpufrequtils 007: cpufreq-info (C) Dominik Brodowski 2004-2009
Report errors and bugs to cpufreq@vger.kernel.org, please.
analyzing CPU 0:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 10.0 us.
  hardware limits: 600 MHz - 1.80 GHz
  available frequency steps: 1.80 GHz, 1.60 GHz, 1.40 GHz, 1.20 GHz, 1000 MHz, 800 MHz, 600 MHz
  available cpufreq governors: conservative, userspace, powersave, ondemand, performance
  current policy: frequency should be within 600 MHz and 600 MHz.
                  The governor "userspace" may decide which speed to use
                  within this range.
  current CPU frequency is 600 MHz (asserted by call to hardware).
  cpufreq stats: 1.80 GHz:9.16%, 1.60 GHz:0.23%, 1.40 GHz:0.37%, 1.20 GHz:0.47%, 1000 MHz:0.49%, 800 MHz:0.56%, 600 MHz:88.71%  (21470)
root@hal9000:/etc#
BTW, it's a Dell Inspiron 8600, Pentium M @ 1.8GHz, 2GB RAM, 80GB IDE


I just rebooted after editing the /etc/default/acpid file...
Code:
mpyusko@hal9000:/etc/default$ cat acpid
# Options to pass to acpid
#
# OPTIONS are appended to the acpid command-line
#OPTIONS=""

# Linux kernel modules to load before starting acpid
#
# MODULES is a space seperated list of modules to load, or "all" to load all
# acpi drivers, or commented out to load no module
#MODULES="battery ac processor button fan thermal video"
MODULES="all"
mpyusko@hal9000:/etc/default$
now I get....
Code:
mpyusko@hal9000:/etc$ cpufreq-info
cpufrequtils 007: cpufreq-info (C) Dominik Brodowski 2004-2009
Report errors and bugs to cpufreq@vger.kernel.org, please.
analyzing CPU 0:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 10.0 us.
  hardware limits: 600 MHz - 1.80 GHz
  available frequency steps: 1.80 GHz, 1.60 GHz, 1.40 GHz, 1.20 GHz, 1000 MHz, 800 MHz, 600 MHz
  available cpufreq governors: conservative, userspace, powersave, ondemand, performance
  current policy: frequency should be within 600 MHz and 1.80 GHz.
                  The governor "ondemand" may decide which speed to use
                  within this range.
  current CPU frequency is 600 MHz.
  cpufreq stats: 1.80 GHz:26.34%, 1.60 GHz:0.69%, 1.40 GHz:0.74%, 1.20 GHz:1.12%, 1000 MHz:1.30%, 800 MHz:0.78%, 600 MHz:69.04%  (902)
mpyusko@hal9000:/etc$
4 minutes after rebooting, and loading KDE, The CPU dropped to 600MHz and now I have this....
Code:
mpyusko@hal9000:/etc/default$ cpufreq-info
cpufrequtils 007: cpufreq-info (C) Dominik Brodowski 2004-2009
Report errors and bugs to cpufreq@vger.kernel.org, please.
analyzing CPU 0:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 10.0 us.
  hardware limits: 600 MHz - 1.80 GHz
  available frequency steps: 1.80 GHz, 1.60 GHz, 1.40 GHz, 1.20 GHz, 1000 MHz, 800 MHz, 600 MHz
  available cpufreq governors: conservative, userspace, powersave, ondemand, performance
  current policy: frequency should be within 600 MHz and 600 MHz.
                  The governor "ondemand" may decide which speed to use
                  within this range.
  current CPU frequency is 600 MHz.
  cpufreq stats: 1.80 GHz:37.17%, 1.60 GHz:0.73%, 1.40 GHz:0.67%, 1.20 GHz:0.85%, 1000 MHz:1.34%, 800 MHz:1.02%, 600 MHz:58.21%  (2853)
mpyusko@hal9000:/etc/default$
I rebooted again and waited in the console for over 10 minutes and the CPU stayed happy at 600 - 1800 MHz. Within a few minutes of loading KDE the computer dropped and stayed locked at 600 - 600MHz. What is KDE loading that the console isn't?

Edit (several hours later): /usr/lib/pm-utils/sleep.d/94cpufreq ... I chmod'd to 644. We'll see if it works.

Edit (Seven more minutes later): Nope, didn't work.

Edit (Another hour later): I rebooted and started using Gnome. Not as much running, but eventually, while downloading updates, the fan kicked on and the processor dropped and locked 600/600 again. I noticed that happened the last time too. But the strange part is even after the CPU cools, won't restore the speed. Still searching.... I never had this issue with Lenny.

Last edited by mpyusko; 06-26-2011 at 02:15 AM. Reason: More info...
 
Old 06-26-2011, 11:25 AM   #15
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,375

Rep: Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557
Have you a kernel source? run make -j10 in the kernel and see if the cpu sweats. If it does, relax. You have 'enough' cpu.
 
  


Reply

Tags
debian, install, speedstep


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
slow web page loading in squeeze edhe1 Debian 5 05-25-2011 03:43 AM
Slow performance on wine (Squeeze) habl Debian 6 03-27-2011 11:06 PM
[SOLVED] Waiting for Squeeze stable vs installing Squeeze right now and keeping it up to date alanv Linux - Newbie 2 11-03-2010 02:43 AM
Why remote X is slow (squeeze client, lenny server)? kaz2100 Debian 1 08-21-2010 03:27 AM
[SOLVED] network-manager, vpn: no/slow connection, options not saved (debian squeeze) mike11 Linux - Networking 2 01-23-2010 09:43 PM


All times are GMT -5. The time now is 01:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration