LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   installing nvidia driver I get: ./nvidia-installer can't find (http://www.linuxquestions.org/questions/debian-26/installing-nvidia-driver-i-get-nvidia-installer-cant-find-863897/)

lord_didger 02-20-2011 02:52 PM

installing nvidia driver I get: ./nvidia-installer can't find
 
I wanted to change my kernel to amd64 because I have got i7 860 and I found out there is 64 bit kernel version for the processor.

I downloaded newest driver from nvidia and executed. The error occured: ./nvidia-installer can't be found. I did install before the driver for x86 and never got that. I unpacked the driver and tried to execute nvidia-install manually. Bash said that there is no file nvidia-install here but it was quite the contrary.

I don't know if my bash is faulty but it is the only case I can't execute a binary file.

My debian is up-to-date, version 6.0.

Any hint 'll be appreciated.

corp769 02-20-2011 03:23 PM

To me this is obvious, but just to ask.... Did you chmod +x the file you are trying to run?

lord_didger 02-20-2011 03:47 PM

Of course I did but this action had no effect because the file is already +x for root. Nevertheless, shouldn't bash tell me I can't execute the file instead there is no file?

corp769 02-20-2011 03:51 PM

Yes. I was just making sure. Can you do a ls -al for me? Maybe the permissions are jacked and/or it needs to be chown'd.

repo 02-20-2011 03:55 PM

Quote:

The error occured: ./nvidia-installer
Are you sure the filename is correct?
In general it ends on run or bin.

Kind regards

lord_didger 02-20-2011 04:40 PM

ll (not exactly ls -al but...) returns:
Quote:

drwxr-xr-x 4 root root 4096 01-19 02:04 32
-rw-r--r-- 1 root root 469008 11-18 22:43 glext.h
-rw-r--r-- 1 root root 72949 11-18 22:43 gl.h
-rw-r--r-- 1 root root 36857 11-18 22:43 glxext.h
-rw-r--r-- 1 root root 14021 11-18 22:43 glx.h
drwxr-xr-x 2 root root 4096 01-19 02:03 html
drwxr-xr-x 2 root root 4096 01-19 02:03 kernel
-rwxr-xr-x 1 root root 8748230 01-19 01:19 libcuda.so.260.19.36
-rw-r--r-- 1 root root 658 01-19 02:03 libGL.la
-rwxr-xr-x 1 root root 980368 01-19 01:12 libGL.so.260.19.36
-rwxr-xr-x 1 root root 5259592 01-19 01:14 libglx.so.260.19.36
-rwxr-xr-x 1 root root 1937496 01-19 02:03 libnvcuvid.so.260.19.36
-rwxr-xr-x 1 root root 132664 01-19 01:15 libnvidia-cfg.so.260.19.36
-rwxr-xr-x 1 root root 20458880 01-19 02:02 libnvidia-compiler.so.260.19.36
-rwxr-xr-x 1 root root 27089296 01-19 01:11 libnvidia-glcore.so.260.19.36
-rwxr-xr-x 1 root root 5936 01-19 01:14 libnvidia-tls.so.260.19.36
-r-xr-xr-x 1 root root 295416 11-18 23:52 libnvidia-wfb.so.260.19.36
-rwxr-xr-x 1 root root 21296 01-19 01:19 libOpenCL.so.1.0.0
-rw-r--r-- 1 root root 1652664 01-19 01:14 libvdpau_nvidia.so.260.19.36
-rwxr-xr-x 1 root root 4056 01-19 01:14 libvdpau.so.260.19.36
-rwxr-xr-x 1 root root 46864 01-19 01:14 libvdpau_trace.so.260.19.36
-rw-r--r-- 1 root root 212556 01-19 01:00 libXvMCNVIDIA.a
-rwxr-xr-x 1 root root 152160 01-19 01:00 libXvMCNVIDIA.so.260.19.36
-rw-r--r-- 1 root root 5725 01-19 00:48 LICENSE
-rwxr-xr-x 1 root root 23383 01-19 00:48 makeself.sh
-rwxr-xr-x 1 root root 12336 01-19 02:02 mkprecompiled
-rwxr-xr-x 1 root root 12969 01-19 00:48 nvidia-bug-report.sh
-rw-r--r-- 1 root root 89982 01-19 01:15 NVIDIA_Changelog
-rwxr-xr-x 1 root root 6043328 01-19 01:00 nvidia_drv.so
-rw-r--r-- 1 root root 11 01-19 00:49 nvidia.icd
-rwxr-xr-x 1 root root 259208 01-19 02:02 nvidia-installer
-rw-r--r-- 1 root root 6951 01-19 02:02 nvidia-installer.1.gz
-rwxr-xr-x 1 root root 1820040 01-19 01:15 nvidia-settings
-rw-r--r-- 1 root root 7111 01-19 01:15 nvidia-settings.1.gz
-rw-r--r-- 1 root root 232 01-19 01:14 nvidia-settings.desktop
-rw-r--r-- 1 root root 3485 01-19 00:48 nvidia-settings.png
-rwxr-xr-x 1 root root 93648 01-19 02:03 nvidia-smi
-rw-r--r-- 1 root root 2018 01-19 02:03 nvidia-smi.1.gz
-rwxr-xr-x 1 root root 164056 01-19 01:15 nvidia-xconfig
-rw-r--r-- 1 root root 7639 01-19 01:15 nvidia-xconfig.1.gz
-rw-r--r-- 1 root root 192 01-19 02:04 pkg-history.txt
-rw-r--r-- 1 root root 381169 01-19 01:15 README.txt
drwxr-xr-x 2 root root 4096 01-19 02:03 tls
-rwxr-xr-x 1 root root 5064 01-19 00:48 tls_test
-rwxr-xr-x 1 root root 4920 01-19 00:48 tls_test_dso.so
file returns:
nvidia-installer: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.4.0, stripped

drivers that I tested: NVIDIA-Linux-x86_64-260.19.29, NVIDIA-Linux-x86_64-260.19.36.

extension run is in the driver shell script name

corp769 02-20-2011 04:46 PM

Just curious, did you trying running ./nvidia-installer as root? I know it may seem repetitive a bit, but I am just ruling out the obvious.

lord_didger 02-20-2011 05:17 PM

yes, i did, man ...

I know my problem looks ridiculous. However, I can't cope with it myself. Do you have any idea of a test I could run to find out what is wrong: my bash or kernel or what ever.

I have just did excactly the same (unpack, execute the file) with NVIDIA-Linux-x86-260.19.29 (32 bit version) and it behaves as expected.

corp769 02-20-2011 05:26 PM

Maybe it is possibly corrupted. Delete it and redownload for the hell of it before we get too deep into this, it is possible that something happened along the download process.

odiseo77 02-20-2011 05:31 PM

If this is the driver downloaded from nvidia.com, you don't need to unpack it, but simply execute:

Code:

sh /path/to/NVIDIA-Linux-x86_64-260.19.36.run

corp769 02-20-2011 05:38 PM

Quote:

Originally Posted by odiseo77 (Post 4265155)
If this is the driver downloaded from nvidia.com, you don't need to unpack it, but simply execute:

Code:

sh /path/to/NVIDIA-Linux-x86_64-260.19.36.run

Damn, I didn't even think to ask what the OP actually download. That is 100% correct. All you need to do is chmod the run file to execute and that's all.

lord_didger 02-20-2011 06:13 PM

Quote:

Originally Posted by corp769 (Post 4265160)
Damn, I didn't even think to ask what the OP actually download. That is 100% correct. All you need to do is chmod the run file to execute and that's all.

:banghead:

I know it is that easy but when I do it I get response
Quote:

file ./nvidia-installer can't find
. That is why I unpacked the driver and try do it manually. I have described it in the first post of the thread btw.

Quote:

Maybe it is possibly corrupted.
it it not fault of any file I downloaded because my bash can't find a file that I order to execute (at least it says so) and the file is there.


I guess you don't understand what the problem is, then I'll describe it in detail:
(that is what I do and what bash responses)

sh NVIDIA-Linux-x86_64-260.19.36.run

Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86_64 260.19.36........................................................................................... ........................................
NVIDIA-Linux-x86_64-260.19.36.run: 899: ./nvidia-installer: not found

sh NVIDIA-Linux-x86_64-260.19.36.run -x

Creating directory NVIDIA-Linux-x86_64-260.19.36
Verifying archive integrity... OK
Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86_64 260.19.36........................................................................................... ........................................

./NVIDIA-Linux-x86_64-260.19.36/nvidia-installer

bash: ./NVIDIA-Linux-x86_64-260.19.36/nvidia-installer: Nie ma takiego pliku ani katalogu #translation: there is no file or directory
(but the file is excactly there and I - root I mean - has: -rwxr-xr-x 1 root root 259208 01-19 02:02 nvidia-installer)
That is all I've done in this matter.

Any hint what to do next?

odiseo77 02-20-2011 07:00 PM

For your first post I assume you're on a 32 bit system with a 64 bit kernel and you're trying to install a 64 bit driver? I'm not sure since I haven't done it, but maybe 32 bit bash can't find the nvidia-installer executable inside the driver since it's 64 bits? I'm not sure if this will work, since I haven't tried this, but you could install the ia32-libs package and attempt to reinstall the driver to see if it works.

odiseo77 02-20-2011 08:11 PM

Sorry, the package you probably need is amd64-libs, not ia32-libs (amd64-libs is intended for 32 bit systems running 64 bit kernels).

Regards and good luck.

lord_didger 02-21-2011 05:11 AM

I don't understand why you say my system is 32 bit. i7 860 has 64 bit instruction set what makes it 64 bit. However, I tried install ia32-libs and I failed because dpkg says it couldn't install the package due to its architecture which is ia64 while my is i386.

I have more questions. Why ia32-libs is not in the repository available through aptitude (I have source.list set wright)? Why kernel is for amd64 and ia64 while ia32-libs has 2 packages for each architecture. Why dpkg says I'm i386 not ia64? ia64 means Xeon? Will amd64-libs be suitable for my processor?


All times are GMT -5. The time now is 04:21 AM.