LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 07-12-2008, 11:10 AM   #1
linuxsimulationboy
LQ Newbie
 
Registered: Jul 2008
Posts: 3

Rep: Reputation: 0
Installing NS2.26 (Network Simulator) Error:can't find X library


Hi All,
I am trying to install NS2.26 and encountering some problems.
Some Info
Latest version of Debian.
Used instructions from Mathew Miller
www.matthewjmiller.net
Compiling using gcc 2.95


I get an error during the compilation of NS2.26 stating
checking XOpenDisplay in -lX11... (cached) no
can't find X library
Ns configuration failed!


I have installed the below
apt-get install libstdc++2.10-glibc2.2
apt-get install libx11-dev
apt-get install libxt-dev


Has anybody any idea what I am missing on my installation?

Many thanks

Colin
 
Old 07-12-2008, 11:54 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,286

Rep: Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664
The latest version is ns--2.33 ... usually builds with gcc 4.x.x
on any new system.

Here is the an example on Ubuntu 8.04
http://suchaxplore.blogspot.com/2008...buntu-804.html

"ns-allinone-2.33.tar.gz" has few dependencies, e.g.
Ubuntu 7.10 will need: 'libx11-dev' and 'libxmu-dev'
Ubuntu 8.04 : the same + 'libxmu-headers' and 'libxt-dev'

( I have not yet tested ns2 on Debian, but "latest" would
probably be like Ubuntu 8.04 )

Good Luck !
 
Old 07-12-2008, 04:47 PM   #3
linuxsimulationboy
LQ Newbie
 
Registered: Jul 2008
Posts: 3

Original Poster
Rep: Reputation: 0
Hi,
Thanks for the reply. Unfortunately i need to use the older NS2.26 version as I am using the MNS2.0 module and a RSVP-TE patch that have been developed for this version.

I have been told I need to compile it with gcc 2.95, which I have been doing.

Cheers.
 
Old 07-13-2008, 03:41 AM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,286

Rep: Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664
Well, impossible to say anything about your errors,
when your Debian is unknown. Etch ? Sid ? Unstable ?

Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ns2- network simulator problem vivekr Linux - Networking 5 02-16-2011 01:25 PM
How to install NS2 simulator(version 2.29) in Fedora 7. mrbhush General 1 05-06-2009 02:41 AM
NS2 - network simulator liquid.o Linux - Networking 0 11-24-2006 11:36 AM
strange linking error -- can not find shared library George2 Programming 1 07-10-2006 12:24 PM
Problem installing jfsutils-1.1.7, cannot find uuid library kit_johnson Linux - Software 1 11-30-2004 09:07 AM


All times are GMT -5. The time now is 06:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration