LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 07-16-2008, 05:46 AM   #1
guldo
Member
 
Registered: Aug 2003
Location: Morio Cho
Distribution: debian sid
Posts: 124

Rep: Reputation: 15
installing mod_python on debian unstable


Hello,
I would like to install mod_python on my debian sid.
I have found the package called libapache2-mod-python, but it depends on python (>=2.5).
As far as I can see, the package called python in debian sid is stuck to version 2.4.4-6.

Anyway, I also have the packages python2.4 (2.4.5-1) and python2.5 (2.5.2-2) installed.

How can I install mod_python?
(other than installing from source)

Thank you.
 
Old 07-16-2008, 07:00 AM   #2
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
Quote:
Originally Posted by guldo View Post
As far as I can see, the package called python in debian sid is stuck to version 2.4.4-6.

Anyway, I also have the packages python2.4 (2.4.5-1) and python2.5 (2.5.2-2) installed.

http://packages.qa.debian.org/p/python-defaults.html


Quote:
Oldstable 2.3.5-2
Stable 2.4.4-2
Testing 2.5.2-1
Unstable 2.5.2-1
http://packages.qa.debian.org/p/python2.5.html
Quote:
Stable 2.5-5
Testing 2.5.2-6
Unstable 2.5.2-8
Looks like you shouldn't have a problem. As of today, mod_python is installable.

Last edited by nx5000; 07-16-2008 at 07:04 AM.
 
Old 07-16-2008, 03:23 PM   #3
guldo
Member
 
Registered: Aug 2003
Location: Morio Cho
Distribution: debian sid
Posts: 124

Original Poster
Rep: Reputation: 15
Thank you very much nx5000, you're right.
I fixed my system and upgraded the python package, but...
I had a problem with python-fuse:
Code:
 /var/cache/apt/archives/python-fuse_1%3a0.2-pre3-6_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Now I have unmet dependencies, because python-fuse depends on python (<2.5)

How should I fix it?

Thanks.

Last edited by guldo; 07-16-2008 at 03:26 PM.
 
Old 07-17-2008, 11:14 AM   #4
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
Quote:
Originally Posted by guldo View Post
because python-fuse depends on python (<2.5)
Hum no

I have a list of uninstallable package in sid and there is not a single problem with this package or anything related to apache. A few problems with python but not what you are using.


Somehow I wonder if you are not mixing stable/unstable etc.. ?

Can you try this:

apt-cache policy python-fuse

And usually you should post the complete error messages, not the last lines. Here it doesn't mean anything, only because you said "unmet dep" that we can figure out which kind of problem you have.

Maybe also your list of repository (sources.list) is not correct?

Last edited by nx5000; 07-17-2008 at 11:16 AM.
 
Old 07-17-2008, 02:28 PM   #5
guldo
Member
 
Registered: Aug 2003
Location: Morio Cho
Distribution: debian sid
Posts: 124

Original Poster
Rep: Reputation: 15
Thank you very much for your help

Code:
debian:~# LC_MESSAGES=POSIX apt-get -s upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
  python-fuse: Depends: python (< 2.5) but 2.5.2-1 is installed
E: Unmet dependencies. Try using -f.
debian:~#
My current sources.list:
deb http://ftp.ch.debian.org/debian/ unstable main contrib non-free
deb http://www.debian-multimedia.org unstable main
deb http://http.us.debian.org/debian/ unstable main contrib non-free

Please notice I am on amd64.
I installed debian 64bit a few months ago with the net install, upgrading immediately to sid.

Code:
$ LC_MESSAGES=POSIX apt-cache policy python-fuse
python-fuse:
  Installed: 1:0.2-pre3-4
  Candidate: 1:0.2-pre3-6
  Version table:
     1:0.2-pre3-6 0
        500 http://ftp.ch.debian.org unstable/main Packages
        500 http://http.us.debian.org unstable/main Packages
 *** 1:0.2-pre3-4 0
        100 /var/lib/dpkg/status
$
 
Old 07-18-2008, 06:48 AM   #6
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
A dependency is blocking everything, try

apt-get -f install

As it said.
Usually, follow the advice of apt-get, it's quite clever
 
Old 07-18-2008, 07:02 AM   #7
guldo
Member
 
Registered: Aug 2003
Location: Morio Cho
Distribution: debian sid
Posts: 124

Original Poster
Rep: Reputation: 15
Thank you for your suggestion.
I noticed that, but, you know, I was a bit worried about it...
I'll try asap.

Thanks a lot
 
  


Reply

Tags
apache2, python


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
installing gecko-sharp on Debian unstable nagromo Linux - Newbie 4 04-18-2004 09:28 AM
installing debian stable, unstable ... ? acker Debian 12 04-12-2004 09:00 AM
Installing KDE on Debian Unstable jriis Debian 2 01-28-2004 08:53 PM
installing woody packages in unstable debian? (java3D) bronko Debian 3 01-04-2004 07:15 AM
Help with installing gforge on debian unstable campusloop Linux - Software 0 12-01-2003 05:16 AM


All times are GMT -5. The time now is 02:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration