LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 03-29-2007, 10:45 AM   #1
knobby67
Member
 
Registered: Mar 2006
Posts: 546

Rep: Reputation: 42
installing an old version of GCC on Etch


Hello everyone, I hoping someone who has done this before can offer some advise. I've just updated my system to Etch, howevery after about a week of testing and thinking I was going mad I have been told that some software I'm wrote will not work correctly due to the fact that it calls a libary/package lib3ds which although it compiles will not work correctly with new compilers, so GCC 4.1 which is provided with Etch does not work. I think my best fix for this is to install an old version of GCC and reinstall lib3ds and use it to compile my code. This is something I've never done before, however I can see from apt-cache search there's old versions of GCC to download, do I just apt-get install the version I require? I presume it will just overwrite the version I'm using? Thanks for any advise
 
Old 03-29-2007, 11:35 AM   #2
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 64
Quote:
Originally Posted by knobby67
This is something I've never done before, however I can see from apt-cache search there's old versions of GCC to download, do I just apt-get install the version I require? I presume it will just overwrite the version I'm using? Thanks for any advise
No it will just install the version you specify Debian allows multiple versions to be installed at the same time giving you the option to use something like export CC=/usr/bin/gcc-4.0 in a shell to have that version used for the compile.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Regarding distribution + kernel version + gcc version + glib version. JCipriani Linux - General 8 04-19-2008 03:54 PM
installing older version of gcc and and adding path variables jaind Linux - Desktop 3 11-26-2006 07:18 AM
gcc version check failed - installing LAN/audio drivers piccolo solo Linux - Software 8 04-09-2006 06:53 PM
has anybody any experience on installing a second gcc version? perfect_circle Slackware 2 02-16-2006 03:42 AM
installing another version of gcc kulmis Linux - Newbie 3 06-21-2005 02:24 PM


All times are GMT -5. The time now is 06:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration