LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 01-08-2010, 10:39 PM   #1
jefm
Member
 
Registered: Oct 2009
Location: Missouri
Distribution: Debian Lenny, Android
Posts: 30

Rep: Reputation: 16
Installed/removed pulseaudio, lost ALSA


At one point, I thought I needed pulseaudio for sound, so I messed around with installing it, even though at the time I had ALSA installed. (suffice to say, I know very little about linux sound). Pulseaudio never did work, I removed it with aptitude. But now ALSA seems to reach to pulseaudio for some reason.

Code:
jefm@ascension:~$ aplay -vv ~/Noise.wav
*** PULSEAUDIO: Unable to connect: Connection refused
aplay: main:564: audio open error: Connection refused
jefm@ascension:~$
More confusing is that there are no "alsa" looking processes in ps -A. But apparently, the basics are there
Code:
jefm@ascension:~$ sudo apt-get install alsa-base
Reading package lists... Done
Building dependency tree       
Reading state information... Done
alsa-base is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 101 not upgraded.
jefm@ascension:~$
There's only one thing in init.d that seems relevent to alsa:
Code:
jefm@ascension:~$ sudo /etc/init.d/alsa-utils start
Setting up ALSA...done.
jefm@ascension:~$
But doing this does not help anything. Does anyone know what to do from here?

And because I'm curious, how come I get sound from Flash Player and Audacity with no problem? Thanks for any and all help.
 
Old 01-08-2010, 11:46 PM   #2
mark_alfred
Senior Member
 
Registered: Jul 2003
Location: Toronto, Ontario, Canada
Distribution: Ubuntu Linux
Posts: 1,054

Rep: Reputation: 95
Maybe it would help to purge pulseaudio, and then reconfigure alsa-base.

Code:
apt-get purge pulseaudio && dpkg-reconfigure alsa-base
The other thing you way wish to do is use a mixer (kmix, alsamixer, or xmixer) to check your volume levels, especially if you're getting sound from some things but not others.

Last edited by mark_alfred; 01-08-2010 at 11:50 PM.
 
1 members found this post helpful.
Old 01-10-2010, 08:57 AM   #3
jefm
Member
 
Registered: Oct 2009
Location: Missouri
Distribution: Debian Lenny, Android
Posts: 30

Original Poster
Rep: Reputation: 16
Thank you for the reply, Mark :}

I tried what you suggested. However the problem persists
Code:
jefm@ascension:~$ sudo apt-get purge pulseaudio && sudo  dpkg-reconfigure alsa-base
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package pulseaudio is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 101 not upgraded.
jefm@ascension:~$ aplay -vv ~/Noise.wav
*** PULSEAUDIO: Unable to connect: Connection refused
aplay: main:564: audio open error: Connection refused
jefm@ascension:~$
The alsa reconfigure does not really ask anything, I assume it should? I'll keep messing with it, maybe uninstall/reinstall alsa? It just seems odd that the pulse stuff is still there, for other programs too:

Code:
jefm@ascension:~$ /usr/bin/mocp ~/Noise.wav
Running the server...
Trying JACK...
Trying ALSA...
*** PULSEAUDIO: Unable to connect: Connection refused
*** PULSEAUDIO: Unable to connect: Connection refused
Trying OSS...

FATAL_ERROR: No valid sound driver


FATAL_ERROR: Server exited

jefm@ascension:~$ /usr/bin/mocp ~/Noise.wav -R --sound-driver ALSA
Running the server...

FATAL_ERROR: No valid sound driver


FATAL_ERROR: Server exited

jefm@ascension:~$
 
Old 01-10-2010, 02:12 PM   #4
mark_alfred
Senior Member
 
Registered: Jul 2003
Location: Toronto, Ontario, Canada
Distribution: Ubuntu Linux
Posts: 1,054

Rep: Reputation: 95
Maybe there are various other pulseaudio packages that are still on your system. Perhaps try apt-get purge pulseaudio* (or, and probably even better, aptitude purge pulseaudio*) to remove any other pulseaudio packages on your system.

Last edited by mark_alfred; 01-10-2010 at 02:15 PM.
 
1 members found this post helpful.
Old 01-11-2010, 08:39 PM   #5
jefm
Member
 
Registered: Oct 2009
Location: Missouri
Distribution: Debian Lenny, Android
Posts: 30

Original Poster
Rep: Reputation: 16
Howdy,
I did an apt-get purge for the pulseaudio and even alsa base as well... then put alsa back on. It still does not work right,
Code:
jefm@ascension:~$ /usr/bin/mocp
Running the server...
Trying JACK...
Trying ALSA...
*** PULSEAUDIO: Unable to connect: Connection refused
*** PULSEAUDIO: Unable to connect: Connection refused
Trying OSS...

FATAL_ERROR: No valid sound driver


FATAL_ERROR: Server exited

jefm@ascension:~$
Still not sure what to do, open to suggestions. Thanks again, jefm
 
Old 01-12-2010, 07:38 AM   #6
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Testing/Unstable Amd64
Posts: 1,476

Rep: Reputation: Disabled
Check what pulseaudio packages you have remaining on your system with:

Code:
dpkg -l | grep pulse
I've just looked at my own system,which does not use pulse audio.
Although it does have one pulseaudio package which is libpulse0.

So if the above command shows that you have pulse packages installed,try using aptitude to 'simulate' removing the packages with something like:

Code:
aptitude -s purge <package>
You can then see what the effects are before you actually start removing packages from the system.
Also you don't mention which branch of Debian you are using?.
It would be useful to know to help setting up Alsa.
I'd suggest adding it to your profile.

Last edited by the trooper; 01-12-2010 at 07:41 AM.
 
1 members found this post helpful.
Old 01-13-2010, 11:32 PM   #7
jefm
Member
 
Registered: Oct 2009
Location: Missouri
Distribution: Debian Lenny, Android
Posts: 30

Original Poster
Rep: Reputation: 16
Hello Trooper,
thanks for the reply. I did the dpkg line and apparently I'd missed the server, somehow:

Code:
jefm@ascension:~$ dpkg -l | grep pulse
ii  libpulse0                            0.9.10-3+lenny1              PulseAudio client libraries
rc  libpulsecore5                        0.9.10-3                     PulseAudio sound server core
rc  pulseaudio                           0.9.10-3+lenny1              PulseAudio sound server
rc  pulseaudio-module-x11                0.9.10-3+lenny1              X11 module for PulseAudio sound server
I went ahead and removed it. However, I still seem to call pulse somehow (I even rebooted, lol)

Code:
jefm@ascension:~$ dpkg -l | grep pulse
ii  libpulse0                            0.9.10-3+lenny1              PulseAudio client libraries
jefm@ascension:~$ 
jefm@ascension:~$ aplay
*** PULSEAUDIO: Unable to connect: Connection refused
aplay: main:564: audio open error: Connection refused
jefm@ascension:~$
I left the libpulse0 because it threatened to break libxine and a couple other things.
Something, somewhere still looks for pulseaudio. I really need to study this sound system stuff.
I'm on Debian Lenny btw, I also updated my sig accordingly. Thanks for the help!
 
Old 01-14-2010, 11:40 AM   #8
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Testing/Unstable Amd64
Posts: 1,476

Rep: Reputation: Disabled
Hey jefm,

Let's try another way.
As you are using Lenny,you can run alsaconf as root.
When asked select the appropriate sound device and let alsaconf configure it for you.
Once this is finished run alsamixer and make sure none of the volume settings are muted.You can then store the settings with alsactl store.

Once the above is finished try running speaker-test,see if you hear any output.
 
1 members found this post helpful.
Old 01-14-2010, 10:37 PM   #9
jefm
Member
 
Registered: Oct 2009
Location: Missouri
Distribution: Debian Lenny, Android
Posts: 30

Original Poster
Rep: Reputation: 16
Hi and thanks again for the help. I tried what you said, things looked really good for a moment, but then got familiar:
Code:
jefm@ascension:~$ sudo alsaconf
(Graphics... It found an Intel 82801G and legacy ISA... I went with Intel. I let alsaconf modify /etc/modprobe.d/sound, after which it said the sound card is configured. Back to text)
Code:
Unloading ALSA sound driver modules: snd-hda-intel snd-pcm snd-seq snd-timer snd
-seq-device snd-page-alloc.
Building card database...


Loading driver...
Setting default volumes...
*** PULSEAUDIO: Unable to connect: Connection refused
amixer: Mixer attach default error: Connection refused


===============================================================================

 Now ALSA is ready to use.
 For adjustment of volumes, use your favorite mixer.

 Have a lot of fun!


jefm@ascension:~$ aplay
*** PULSEAUDIO: Unable to connect: Connection refused
aplay: main:564: audio open error: Connection refused
jefm@ascension:~$ alsamixer
*** PULSEAUDIO: Unable to connect: Connection refused

alsamixer: function snd_ctl_open failed for default: Connection refused
jefm@ascension:~$
I am lost... I think I might toss this to the Alsa mailing list and see what they say. Thanks again for the help and all the handy command line tools!
 
Old 01-15-2010, 02:07 PM   #10
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Testing/Unstable Amd64
Posts: 1,476

Rep: Reputation: Disabled
Sorry i couldn't help further.
If you find the solution please post it here.
 
Old 03-22-2012, 04:32 PM   #11
lns
LQ Newbie
 
Registered: Mar 2012
Posts: 1

Rep: Reputation: Disabled
Not sure if you have checked your /etc/asound.conf file, but I remember when configuring PA you have to set the default devices through this (or alternatively on a per-user basis in ~/.asoundrc). Hopefully you've fixed the issue by now (a year later), but if not try checking that.


Cheers,
Jordan
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
permissions issue in audio/alsa/pulseaudio kev000 Linux - Mobile 2 10-27-2009 09:39 PM
Mandriva: how to disable pulseaudio and enable Alsa veezee Linux - Hardware 5 09-16-2009 08:21 AM
sound is very faint (alsa and pulseaudio, Fedora 10) bach-fiend Linux - Newbie 3 02-16-2009 03:11 PM


All times are GMT -5. The time now is 09:21 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration