LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 05-07-2005, 01:17 PM   #1
rossjman1
Member
 
Registered: Oct 2004
Location: Chicago, IL, USA
Distribution: Debian
Posts: 71

Rep: Reputation: 15
Installed Debain Sarge, Xserver resolution


I just installed Debain Sarge. I also installed XFree86, but the screen resolution is too small. How can I change the resolution? I have done some googling, but this command doesn't work:

- dpkg-reconfigure xserver-xfree86
. . Command not found.
- xf86config
. . Configured everything right, nothing's changed after reboot...

HP Pavilion 6545C
128 Mb PC 100 SDRAM
500 MH Intel Celeron
intel 810 chipset
i810 graphics controler
11MB Video mem (I rounded it off and put 11000Kb during the config)
Dell M991 Color Monitor
- hsync range: 30-96 kHz
- vsync range: 50-160 kHz
- max. resolution: 1280x1024 (I use)
Tell me if you need any more info.

I had Debian on my system before, but it was cluttered and not organized(Knoppix Hd Install). Everything was already set up for me, except for the sound, so I never experienced anything like this before. I'm using gdm with GNOME. Also, my middle mouse button doens't work(scroll wheel). I have a Microsoft IntelliMouse Optical. It has 7 buttons, and I would like all 7 to work.

This is how I set everything up (in order) after I got the Debian base-install compleated:

apt-get update
apt-get upgrade
apt-get install aptitude <= almost all the apt-get lines after this I did with aptitude.
apt-get install xserver-common <= I think that's the name
apt-get install xserver-xfree86 <= "
apt-get install IceWM
apt-get install gnome-desktop-environment
apt-get install gnome
apt-get install gdm
>I set gdm as the default, not xdm
apt-get install mozilla-firefox

Is there anything I'm missing? Thanks in advance.
 
Old 05-07-2005, 01:36 PM   #2
rossjman1
Member
 
Registered: Oct 2004
Location: Chicago, IL, USA
Distribution: Debian
Posts: 71

Original Poster
Rep: Reputation: 15
Now I feel stupid. Right after posting this I tried
Code:
dpkg-reconfigure xserver-xfree86
and it worked! I got the resolution problem fixed, but the middle mouse button still doesn't work.
 
Old 05-07-2005, 01:41 PM   #3
brynjarh
Member
 
Registered: May 2004
Location: Iceland
Distribution: Ubuntu Dapper Drake
Posts: 172

Rep: Reputation: 30
Can you show me your XFree86 config file? It's at /etc/X11/XF86Config-4

There is a section in it that defines what resolution you can use, in my file it looks like this:

Code:
Section "Screen"
        Identifier      "Default Screen"
        Device          "NVIDIA Corporation NV18 [GeForce4 MX - nForce GPU]"
        Monitor         "Generic Monitor"
        DefaultDepth    24
        SubSection "Display"
                Depth           1
                Modes           "1280x960" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           4
                Modes           "1280x960" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           8
                Modes           "1280x960" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           15
                Modes           "1280x960" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           16
                Modes           "1280x960" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           24
                Modes           "1280x960" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection
If I add "1600x1200" I can use that resolution for example. Also be sure you are using the correct driver for your graphic card, for a i810 graphics controller I believe the driver is "i810", that's also defined in that file, should look something like this:

Code:
Section "Device"
        Identifier      "NVIDIA Corporation NV18 [GeForce4 MX - nForce GPU]"
        Driver          "nv"
EndSection
As you can see I'm using the "nv" driver. You should use "i810", or at least I think so, I'm not completely sure.
 
Old 05-07-2005, 01:48 PM   #4
rossjman1
Member
 
Registered: Oct 2004
Location: Chicago, IL, USA
Distribution: Debian
Posts: 71

Original Poster
Rep: Reputation: 15
I got the resolution part fixed, but I still need help with my mouse. During configuration I said no to 'emulate 3rd button', so maybe that's the problem. I would also like all 7 of the buttons to work, but I'm real new at this, so could someone guide my through it?
 
Old 05-07-2005, 03:10 PM   #5
samael26
Member
 
Registered: Oct 2004
Location: France, Provence
Distribution: Debian
Posts: 848

Rep: Reputation: 30
Yes. You must have the following in your Xfree86 config file :

Mouse section : add this : Option "ZAxisMapping" "4 5"

Check that you also have : Option "Protocol" "IMPS/2"

Option "Emulate3Buttons" "true"

That should work.

Cheers
 
Old 05-07-2005, 03:16 PM   #6
rossjman1
Member
 
Registered: Oct 2004
Location: Chicago, IL, USA
Distribution: Debian
Posts: 71

Original Poster
Rep: Reputation: 15
I posted this problem at another forum, and the person there said that the mouse section should look like this:
Code:
Section "InputDevice"
	Identifier "Configured Mouse"
	Driver "mouse"
	Option "CorePointer"
	Option "Device" "/dev/input/mice"
	Option "Protocol" "ExplorerPS/2" #<--This is the first line to change
	Option "Emulate3Buttons" "false" #<-- "This can be true, I set the button 	to nothing, because my wheel sucks because it's old"
	Option "ZAxisMapping" "6 7" #<-- This must be added
	Option "Buttons" "7" #<-- This too
EndSection
He said that this would allow all of the mouse buttons to work. I'm not sure if this is true.
 
Old 05-07-2005, 03:34 PM   #7
samael26
Member
 
Registered: Oct 2004
Location: France, Provence
Distribution: Debian
Posts: 848

Rep: Reputation: 30
The ZAxisMapping part is to make your wheel mouse working. The rest might work, as well.
It's true that in Debian I have only a generic mouse. I don't know for the 7 buttons but in my
own XFreeconf file, there is the ZAxisMapping part enabled and scrolling works.
Try what was suggested, the only thing that can break is your patience..

Cheers
 
Old 05-07-2005, 03:40 PM   #8
rossjman1
Member
 
Registered: Oct 2004
Location: Chicago, IL, USA
Distribution: Debian
Posts: 71

Original Poster
Rep: Reputation: 15
I did try it, but it didnt work. I was just asking if his and your suggestion was nearly the same (if that makes sense). Here was the entire suggestion:

Quote:
Next for the mouse, I have an Intellimouse explorer 3.0 USB and have all buttons working. To do this you need to do 5 things. First edit your XF86Config file in the /etc/X11 dir and modify the mouse area. Modify them to read:

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2" <--This is the first line to change
Option "Emulate3Buttons" "false" <-- "This can be true, I set the button to nothing, because my wheel sucks because it's old"
Option "ZAxisMapping" "6 7" <-- This must be added
Option "Buttons" "7" <-- This too
EndSection

and in your home directory add the following line to your .xinitrc:
xmodmap -e "pointer = 1 2 3 6 7 4 5"

Now all the buttons are mapped so X can see them. Next is to get the program imwheel through apt, aptitude, ...(I recommend just using synaptic, its GUI is easier for people to navigate).

Next you'll have to make in your home directory you need to make a file called .imwheelrc, here's what mine looks like:

".*"
None, Right, Alt_L|F4 <-- Maps the forward button to close stuff
None, Left, Alt_L|Left <-- Maps the backwards button to go back

You can do a lot with this program and can map buttons or individual programs this has a couple examples: http://lug.mtu.edu/lists/lug-l-0311/msg00011.html

Last in Gnome goto desktop preference, advanced, session and under startup programs add the command:
imwheel -b "456789"

Now your mouse will work and you can change what the buttons do by making keyboard bindings and modifying your .imwheelrc to map the key to the new shortcut.
 
Old 05-08-2005, 12:40 AM   #9
rossjman1
Member
 
Registered: Oct 2004
Location: Chicago, IL, USA
Distribution: Debian
Posts: 71

Original Poster
Rep: Reputation: 15
Installing the kernel did the it! there is one problem that might be easy to fix:

the 2 side buttons(back/forward buttons) work, but only act as a new left and right mouse button.

Last edited by rossjman1; 05-08-2005 at 01:00 AM.
 
Old 05-09-2005, 12:11 PM   #10
rossjman1
Member
 
Registered: Oct 2004
Location: Chicago, IL, USA
Distribution: Debian
Posts: 71

Original Poster
Rep: Reputation: 15
Does anyone have any suggestions as to what I should do to get all the buttons on my mouse to work?
 
Old 06-18-2005, 01:53 AM   #11
mofungo
LQ Newbie
 
Registered: May 2005
Location: cleveland
Distribution: debian/sid
Posts: 6

Rep: Reputation: 0
My scroll didn't work but after following Samael26 example,I changed my mouse type to IMPS/2.Quick Crt-Alt-Backspace and it now works,funny though how the IMPS/2 was the default during installation,for some reason I didn't like it,so I changed it.Duh!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to increase the screen resolution of the text console (No Xserver installed)? Akhran Debian 1 11-10-2005 04:32 PM
Sound Config on Debain Sarge doctorwebbox Debian 8 05-24-2005 01:12 PM
Just installed debain testing and iv'e got some problems Zadatak Linux - Newbie 5 04-10-2005 02:07 AM
Guide to Display Chinese in Debain Sarge NanoFxJ Debian 3 04-05-2005 06:21 PM
Debain (sarge) Basic How To's notolerance Debian 0 12-10-2004 05:30 PM


All times are GMT -5. The time now is 02:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration